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1 Introduction

The Allworx OfficeSafe 7 PC application performs Allworx server backups and restores. 
It includes a Windows service that performs the backups and an Administration tool to 
configure the Windows service and the restores, as well as manage the backups. The 
OfficeSafe application is capable of doing backups of individual customer systems 
interactively or providing an ongoing backup service to multiple customers.

1.1 Backup/Restore Overview

Each Allworx server backup is a system image. The Allworx server initiates the backup 
and transmits the information over the network to the PC running the Allworx OfficeSafe 
application. Plan backups for:

• Newly-installed systems, as soon as the configuration is complete. This 
enables users to re-establish the site configuration easily. 

• Regularly scheduled backups.

• After making changes to the Allworx server configuration.

• Prior to installing Allworx software upgrades. 

Do restores on-site using the OfficeSafe 7 application loaded on a service PC, as 
necessary. If the preferred backup is not in the service PC OfficeSafe database (i.e. the 
service PC did not do the backup), copy the backup onto the service PC, anywhere on 
the file system.

1.2 Full and Incremental Backups

The backup configurations on the Allworx server include a Mode setting for choosing full 
and incremental backups. 

• Full Backup: includes a copy of all server data, e.g., operating system, 
software load, system configurations, and user voicemails. The number and 
length of voicemails on the system affects the size of the backup files and can 
take a long time to transmit to the OfficeSafe PC. 
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• Incremental Backup: includes only changed data since the last backup, e.g., 
new voicemails and call details records. Therefore, incremental backups are 
normally much smaller than full backups and take less time to transmit.

The recommended server Mode setting is Incremental, which performs a full backup the 
first time, and then performs smaller, faster incremental backups. If doing regularly 
scheduled, incremental backups, it is best practice to do a full backup periodically. 

The collection of full and subsequent incremental backups requires extra disk space and 
can become cumbersome to manage. The OfficeSafe 7 application has the ability to 
override the server Mode setting and force doing a full backup under certain conditions 
such as the passage of time or after saving of a certain number of incremental backups. 
See the “User Configuration” on page 8 for information on configuring these settings.

1.3 Mapped Network Drives

Users may select disk drives on other network servers mapped on the PC within the 
Windows account as the destinations for backups. When selecting a network drive, the 
user must provide the necessary credentials for the drive. The provided credentials 
continue to enable storing backups on the network drive even when there are no 
privileged users logged into the PC.

1.4 Compatibility

1.4.1 Allworx Servers

Use the OfficeSafe 7 application to do backups and subsequently restore any Allworx 
server model running Allworx system software versions 7.0 and higher.

1.4.2 Allworx OfficeSafe Versions

Allworx recommends installing the OfficeSafe 7 application on all PCs and using it for all 
backups. For PCs with OfficeSafe 5 or lower applications doing backups, leave the 
OfficeSafe 5 application on the PC. Backup the Allworx Servers with the newer 
OfficeSafe 7 application, and then remove the older OfficeSafe application version and 
older backups from the PC. Do not remove the OfficeSafe 5 or lower application until all 
OfficeSafe 7 backups are complete.

The compatibility requirements of the OfficeSafe 6 and OfficeSafe 7 application include:
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• OfficeSafe 6 and OfficeSafe 7 cannot reside on a PC at the same time. 
Uninstall OfficeSafe 6 before installing OfficeSafe 7.

• OfficeSafe 6 or OfficeSafe 7 can reside on a PC at the same time as 
OfficeSafe 5 or lower. 

• OfficeSafe 5 or lower cannot do backups until stopping the OfficeSafe 6 or 
OfficeSafe 7 Windows service. 

• OfficeSafe 6 and OfficeSafe 7 are not compatible with backups made using 
OfficeSafe 5 or lower. 

• Users cannot import OfficeSafe 5 backups into the OfficeSafe 6 or 
OfficeSafe 7 application. 

• Users cannot restore OfficeSafe 5 backups to Allworx servers using the 
OfficeSafe 6 or OfficeSafe 7 application.

1.4.3 Windows Versions

The OfficeSafe 7 application is compatible with the following Windows operating 
systems:

• Windows XP Professional with Service Pack 3 (32-bit version)

• Windows 7 with Service Pack 1 (32-bit and 64-bit versions)

• Windows 8/8.1 (32-bit and 64-bit versions)

• Windows Server 2008 (32-bit and 64-bit versions) and Windows 2008 R2 

• Windows Server 2012 and Windows 2012 R2
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2 Installation and Configuration

2.1 Installation

Install the Allworx OfficeSafe 7 application on every PC used for Allworx server 
installation and support or on a Windows-based server at a central location to do 
backups of Allworx servers on multiple sites. The central server must have a network 
communications path to all servers identified for backup such as over the Internet or 
VPN. Allworx servers include the ability to configure and schedule automatic backups at 
various frequencies.

If the upgrade is from an earlier version of the OfficeSafe 6 or OfficeSafe 7 application, 
uninstall the current OfficeSafe application from within the Control Panel. It is not 
necessary to uninstall the OfficeSafe 5 or lower application.

The Windows Server 2008 R2 operating system requires .NET Framework 3.5.1 prior to 
installing the OfficeSafe 7 application. 

To install the.NET Framework version 3.5 SP1 installer on the Windows XP 
operating system:

1. Navigate to www.microsoft.com and locate the .NET Framework 3.5 SP1 installer 
file.

2. Click the Download button.

3. Double-click the downloaded file to begin the install. Follow the on-screen prompts to 
complete the installation. 

To install the .NET Framework version 3.5 SP1 installer on the Windows 7 or 
Windows 8 operating system:

1. Navigate to the computer Start Menu > Control Panel. Verify the view is the Classic 
view, and click the Programs and Features icon.

Note:
If upgrading from an earlier version of the OfficeSafe 6 or OfficeSafe 7 application 
(requiring a removal of the earlier version), the application configuration information is 
retained and unchanged. In addition, no backup information is lost
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2.  Click Turn Windows Features on or off (located in the left column). 

Windows 7, and Windows 8 operating systems have User Account Control. Accept to 
proceed.

3. Select the .NET Framework 3.5 (includes .NET 2.0 and 3.0) installer and click OK the 
install begins. Click Download files from Windows Update. The install completes. 

To install the .NET Framework 3.5.1 on Windows Server 2008 (32-bit and 64-bit 
versions) and Windows 2008 R2:

1. Navigate to the computer Server Manager > Add Features > .NET Framework 
3.5.1. 

2. Select the .NET Framework 3.5 (includes .NET 2.0 and 3.0) installer and click OK 
the install begins. Click Download files from Windows Update. The install 
completes. 

To install the .NET Framework 3.5.1 on Windows Server 2012 (32-bit and 64-bit 
versions) and Windows 2012 R2:

1. Navigate to the computer Server Manager > Manage > Add Roles and 
Features. The dialog box opens.

2. Click Next and verify the Role-based or feature-based installation selection. 
Click Next.

3. Navigate to Select a server from the server pool > Next > .NET Framework 
3.5 Features. Click Next and follow the on-screen prompts. 

To install the OfficeSafe 7 application:

1. Download the OfficeSafe 7 zip file from the Allworx Partner Portal and unzip the 
file to a folder on a PC. 

2. Double-click the setup.exe file and follow the screen prompts. 

3. Select a folder to store the backups. Accept the default (C:\backup) or select 
another folder on a drive that has enough space for the backups.

Note: A user with Windows Administrator rights must install the OfficeSafe 7 application.
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4. Click Close to finish the installation process.

The setup program installs a Windows service that handles the work of doing the 
backups. The service starts automatically after installation. The OfficeSafe 
Administration Tool application also installs and places an icon to open it on the desktop. 
Use the Administration Tool to configure the backup / restore settings and manage the 
stored Allworx server backups on the PC (described later in this document).

If running firewall software on the PC, configure the PC to enable backups. Procedures 
for enabling backups through the Windows Firewall are provided below. If using a 
third-party firewall program, use the appropriate procedures for the product. If 
connecting the PC through a hardware firewall, route the OfficeSafe port (the default is 
5001) through the firewall to the OfficeSafe PC.

To enable the OfficeSafe application through the Windows Firewall - Windows 7 
and Windows Server 2008:

This procedure requires Administrator privileges.

1. Open the Windows Control Panel.

2. Click Windows Firewall. If the Windows Firewall does not display in the Control 
Panel window, navigate to System and Security > Windows Firewall.

3. Click Allow a program or feature through Windows Firewall. A list of programs 
displays. Click Allow another program. The Add a Program window displays.

Windows 7: If there is a prior version of the OfficeSafe application installed on this 
PC, the OfficeSafe application may display in the Programs list. Ignore this. If 
OfficeSafeService.exe does not display not in the list, click the Change settings 
button. 

4. Click Browse in the Add a Program window.

5. Navigate to My Computer > C: > Program Files > Allworx > OfficeSafe 
Service (Not OfficeSafe but OfficeSafe Service). 

Windows 7: If the Windows operating system is the 64-bit version, navigate to 
Program Files (x86) rather than Program Files.

6. Click OfficeSafeService.exe, and then click Open. The Browser window closes.
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7. Locate OfficeSafeService.exe in the Programs list, and then click Add. The Add 
window closes. OfficeSafeService.exe displays in the Allowed programs window 
and its box is checked. Click all unchecked buttons on the same row as 
OfficeSafeService.exe, and then click OK.

To enable the OfficeSafe application through the Windows Firewall - Windows XP:

This procedure requires Administrator privileges.

1. Open the Windows Control Panel.

2. Click Windows Firewall. If Windows Firewall does not display in the Control 
Panel window, click Switch to Classic View (in the left pane of the window).

3. Click the Exceptions tab. If there is a prior version of the OfficeSafe application 
installed on the PC, the OfficeSafe application displays in the Programs list. 
Ignore this. If OfficeSafeService.exe is not in the list, click Add Program. If 
OfficeSafeService.exe is in the list, then the firewall is already set up. Click 
Cancel to exit the Windows Firewall window.

4. Click Browse in the Add a Program window.

5. Navigate to My Computer > C: > Program Files > Allworx > OfficeSafe 
Service (Not OfficeSafe but OfficeSafeService).

6. Click OfficeSafeService.exe, and then click Open. The Browse window closes.

7. Locate OfficeSafeService.exe in the Programs list and its box should be 
checked. Click OK in the Add a Program window.

2.2 User Configuration

Prior to using the Administration Tool to manage backups, ensure the users have Read 
and Write access to the Backup Folder containing the stored Allworx Server backups. 
Any user changing the OfficeSafe configuration must be a Windows Administrator.

To access the configuration options:

1. Double-click the Administration Tool icon to launch the application. After it 
synchronizes with the OfficeSafe Service, the main window displays any stored 
backups in the OfficeSafe backup repository.
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2. Click Tools > Options. The Backup Options tab displays. There are two sub-tabs. 

• Default backup setting
• Server-specific settings.

2.2.1 Default Backup Settings Tab

The settings on the Defaults sub-tab applies to the first backup of new servers and to 
any selected existing servers.

• Backup Repository – This is the main storage directory for all OfficeSafe 
backups. The OfficeSafe application creates a backup sub-folder for each 
server. If changing the Backup Repository folder, the application saves all 
subsequent backups of new and existing servers using the default settings in 
the new folder. If configuring the Backup Repository on a network drive, the 
Windows Administrator must enter the required Credentials (Domain, User 
Name, and Password) for accessing the drive. See “Credentials” on page 13 
for more information.

• Move backups using defaults to a new repository – If changing the Backup 
Repository folder and this box is left unchecked, the application stores the new 
backups in the new location, but any previously-stored backups remain in the 
previous directory. If this box is checked, the application moves previously-
stored backups to the new location.

• Overrides for Full Backup – The recommended setup for the server backup 
Mode is Incremental, meaning the first backup made for the server is a full 

Note:
If there is a check in the Move backups using defaults to a new repository box, 
changing the repository location to or from a network drive could take several minutes, 
depending on the amount of data and the speed of the network. 

Note:
If a using network folder to store backups, the network folder may display in a format that 
includes the server address where the folder resides. This is not necessarily a problem. It 
can be the result of two possible issues: (1) The Windows account does not have a drive 
mapping for the network folder or (2) the Windows Administrator does not have sufficient 
access rights to the folder. In either case, users cannot manage the backups stored on 
the network drive. The application continues to store backups into the folder successfully, 
if the network drive credentials are still valid.

Note:
Changing the repository location to or from a network drive could take several minutes 
depending on the amount of data and the speed of the network. 

Note:
If the user does not have write permissions for both source and destination folders, it is 
not be possible to move the existing backups. The ‘Move backups’ checkbox is not 
available.
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backup but all subsequent backups are incremental backups. The OfficeSafe 
application overrides the Incremental backup setting by forcing a full backup, 
based on the selected condition.

• Previous Backup Sets retained – Whenever doing a full backup, the 
application creates a new Backup Set. The Backup Set contains the full 
backup along with all subsequent incremental backups for that server. Select 
the number of prior backup sets to retain in the OfficeSafe backup database.

• Notify Settings: Recipient Group – Users may configure the OfficeSafe 
application to send an email indicating the status of backup operations as 
completed. A Recipient Group is a collection of email addresses to send 
notifications. Define the Recipient Groups on the Notification options tab. To 
send a notification, select a group from the list of defined groups.

2.2.2 Server-specific Backup Settings
• Named Server – Servers with complete backups display in the Named Server 

list. Click a server to view and modify the settings for subsequent backups of 
that server.

• Rename – Change the servers with completed backups displayed name. It 
may be convenient to change the server name to the customer site name. 
Users also have the option to rename the folder for the server backups to 
match the new server name. The server folder is in the main backup folder 
and stores the backups for the selected server.

• Folder – Storage folder for the selected server backups. If changing the folder, 
already stored backups move to the new folder and the application saves all 
subsequent backups. If configuring the Backup Repository on a network drive, 
the Windows Administrator must enter the required Credentials (Domain, User 
Name, and Password) for accessing the drive. See “Credentials” on page 13 
for more information. 

• Overrides for Full Backup – Recommended setup for the server backup 
Mode is Incremental, which is the first server backup is a full backup but all 
subsequent backups are incremental backups. The OfficeSafe application 

Note:
Changing the repository location to or from a network drive could take several minutes 
depending on the amount of data and the speed of the network. 

Note:
If a using network folder to store backups, the network folder may display in a format that 
includes the server address where the folder resides. This is not necessarily a problem. It 
can be the result of two possible issues: (1) The Windows account does not have a drive 
mapping for the network folder or (2) the Windows Administrator does not have sufficient 
access rights to the folder. In either case, users cannot manage the backups stored on 
the network drive. The application continues to store backups into the folder successfully, 
if the network drive credentials are still valid.
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overrides the Incremental backup setting by forcing a full backup, based on 
the selected condition.

• Previous Backup Sets retained – Creates a new backup set whenever a 
doing full backup. The Backup Set contains the full backup along with all 
subsequent server incremental backups. Select the number of prior backup 
sets to retain in the OfficeSafe backup database.

• Notify Settings: Recipient Group – Configure the OfficeSafe application to 
send an email indicating the status of backup operations as completed. A 
Recipient Group is a collection of email addresses to send notifications. 
Define the Recipient Groups on the Notification options tab. To send a 
notification, select a group from the list of defined groups.

• Set Defaults – Open a window to configure this or all existing servers to use 
default Backup and/or Notification settings. Once configured this way, the 
server or servers use the default settings until Set Defaults options are 
changed.

2.3 Restore Options

Use an on-site service PC loaded with the OfficeSafe 7 application to do a restore, as 
needed. If using a dedicated backup PC for backups, copy the preferred backup file to 
the on-site service PC.

The Restore options enable users to select which backup to use for restore of an Allworx 
server. From the main window, click View > Options. Click the Restore tab. The 
Restore Options tab displays.

• Most Recent Backup – Use the most recent backup in the OfficeSafe 
database for the server being restored. If the application does not find any 
backups for this server, the restore fails.

• Named Server – Use a backup from a different server that in the OfficeSafe 
database. This is useful when switching servers. The Administrator can load 
the original server configuration onto the replacement server. 

• Select Backup File – Use this option if the backup file is not in the OfficeSafe 
database on the service PC. This is often the case when doing backups on a 
dedicated, backup PC but the administrator is using a different PC (e.g. a 
service laptop) to do the restore. Therefore, copy the file from the dedicated 

Note:
When backing up from a different server, the application does not restore the original 
server feature keys or activate the features on the new server. The administrator must 
obtain feature keys specifically created for the new Allworx server. 
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backup PC to the service laptop. Choosing Select Backup file enables users 
to browse the file system of the laptop to select the copied backup file.

2.4 Network Options

The Administrator can receive backups on any network interface configured on the PC, 
including VPNs. Use the Network Options tab for setting the port number and adjusting 
the maximum number of simultaneous connections for backups. To view or modify the 
Network options, click Tools > Options > Network. 

• Maximum Allowed Connections – Controls the number of backups 
happening at one time. The value can be set to a maximum of 10. If 
simultaneous backups are using too much network bandwidth, decrease the 
value.

• Connection Port – Default port (5001) for both the OfficeSafe application and 
Allworx servers. Users may select a different port, if required. Verify the 
OfficeSafe application and all of the Allworx servers identified for backup are 
set to the same port number. If changing the Connection Port, restart the 
OfficeSafe service. From the Main Window, click Tools > Backup Service > 
Restart. It may take up to two minutes for the restart to complete.

• Active Network Interfaces – IP address and description of each active 
network interface on the PC displays. If connecting to the customer’s site 
using a VPN, connect to the VPN, and then verify that the VPN IP Address is 
in the Active Network Interfaces list. If not, check the VPN interface.

Windows 7 Note

Even when installing with Administrator permissions, the options to Start, Stop and 
Restart the Backup Service may remain disabled. 

For a user with Administrator permissions to enable these options:

1. Navigate to My Computer > C: > Program Files > Allworx > OfficeSafe 
Service. If the Windows 7 operating system is the 64-bit version, navigate to 
Program Files (x86) rather than Program Files. 

2. Right-click the OfficeSafeAdmin.exe file, and click the Create shortcut option. 
The Windows 7 operating system indicates that a direct shortcut creation is not 
possible and asks to place it on the desktop instead. Click Yes.

Note: Only users with Administrator permissions on the PC can restart the service.
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3. Right-click the newly-created shortcut on the desktop and select Properties.

4. Locate the Shortcut tab and click Advanced… The Advanced Properties dialog 
box displays. Check the Run as Administrator checkbox, and then click OK.

5. Click the General tab and modify the shortcut title to indicate that this shortcut 
has Administrator privileges. Click OK.

6. Click OK to accept the configuration selection.

7. Double-click on this new shortcut and navigate to Tools > Backup Service from 
within the application. Depending on the state of the OfficeSafe service, one or 
two of the options should be available.

2.4.1 Credentials

When selecting a network drive for storing backups, the user must enter credentials 
(Domain, User Name, and Password) to access the drive. After entering the information, 
users can view and manage the credentials on the Credentials page. Navigate to Tools 
> Options > Credentials.

• Delete – Only available if the selected Credential is not in use within any 
backup configuration. If the Credentials are in use, an asterisk (*) displays in 
the In Use column. 

• Modify – Change the existing Credentials. This is necessary if the password 
for the user to access the network drive has changed.

2.4.2 Notifications

Users can configure the OfficeSafe application to provide automatic notification emails 
for backup successes, failures, or both. Users can setup the notifications for specific 
servers or for all servers. To set up notifications, define an email Recipient Group. 
Navigate to Tools > Options > Notification > New… The Notification Configuration 
window displays.

• Recipient Group – Enter a descriptive name.

• Used By – Identify which server backup configurations use the notification 
setup.

• Notify On – Select when to notify: backup passes, fails, or both.

• SMTP Server – Enter the DNS name or IP address of the mail server using 
this notification. The email account provider should supply this information.
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• Port – Enter the Port number for the SMTP Server. The email account 
provider should supply this information.

• Use Authentication – Check this box and fill in the User Name and 
Password, if the SMTP Server requires authentication. The email account 
provider should supply this information.

• Secure Connection – Select the SMTP server security protocol, if any. The 
email account provider should supply this information.

• Sender’s Email (from) – Enter the account email address on the SMTP 
Server.

• To, CC, Bcc. – Enter email addresses for the intended recipients of the 
notification.

• Test Email – After entering the required information, click Test Email to verify 
that the notification is set up properly. The application sends a test email to the 
configured recipients. Verify all recipients received the email prior to using this 
Notification setup for backup notifications.

2.4.3 Troubleshooting Notifications

If the recipients are not receiving notifications, there may be a problem with the network, 
the email server, or both. Check if the PC is queuing notification emails. Navigate to 
View > Notify Queue. The Notification Queue table displays.

This window displays any notifications that the OfficeSafe application was unable to 
send the notification. Users can also set the Retry Interval and the Maximum Life. After a 
notification exceeds the Maximum Life setting, the application no longer retries to send 
the notification and deletes it. Entering a zero for Maximum Life causes the application to 
delete unsuccessful emails immediately.

If notification emails are stuck in the queue, check the email server setup in the 
Notification Options or contact your system Administrator.
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3 Backups

3.1 Setup the OfficeSafe PC

1. Connect the PC to the customer network or ensure there is a connection to the 
server over the Internet to the site. 

If a VPN is necessary to connect to the customer network, log into the VPN.

2. Navigate to Tools > Options > Network tab. 

3. Verify the IP address of the PC connection to the customer network is present in 
the Active Network Interfaces list.

4. Click View Current Activity to open the Current Activity window.

3.2 Setup the Allworx Server

1. Log into the Allworx System Administration web page. Navigate to Maintenance 
> Backup > Modify.

2. Set the IP Address and TCP/IP Port to the public IP address and port number of 
the PC running the OfficeSafe application. If the PC is behind a router, verify the 
port is forwarded to the backup PC. You can find the IP address and port number 
on the OfficeSafe Tools > Network Options tab.

3. Click the Update button.

3.3 Initiate a Backup

1. Navigate to the Allworx System Administration Backup page, and click the 
Backup Now button. A confirmation box displays. Click OK.

Within a few seconds, a progress bar displays for the backup in the OfficeSafe 
Administration Tool Current Activity window.
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2. Wait for the backup to complete, and then click Close to exit the Current Activity 
window. The entries for the Allworx server and this backup display in the left pane 
of the Administration Tool main window.

If doing additional backups on this server, indicate the backup schedule date, 
time, and frequency on the server Backup page.

3.4 Setup a PC at the Customer Site

A PC can be set up at the customer site to capture backups on a regular basis. 
Configure a PC described in “Setup the OfficeSafe PC” on page 15. 

1. Verify the PC has sufficient disk space to store a number of backups. 

2. Log in to the Server Admin page and navigate to Maintenance > Backup > 
Modify. 

3. Select the IP Address of the PC, the port number to use, the backup frequency 
and the time of day to start the backups.

4. Click the Update button. 

5. Test the connection to the PC - click Backup Now and verify the backup is 
successful. 
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4 Restoring Allworx Servers

Before starting a restore, disconnect the server from the customer network and reboot it 
in SafeMode. Directly connect a PC to the LAN of the Allworx server. Verify the PC 
requirements:

• Obtains the IP address automatically.

• Installation of the OfficeSafe 7 application.

• Preferred backup file is available, either within the OfficeSafe application or 
elsewhere in the file system.

4.1 Server Setup
To disconnect the server to restore from the custom network:

1. Disconnect the server LAN and WAN ports (or the T1 port, if using for the WAN) 
from the customer network.

2. Reboot the server into SafeMode and connect the PC running the OfficeSafe 
application to the server LAN port.

3. Set up the PC network interface to obtain an IP address via DHCP.

4. Verify that the PC has an IP address on the 192.168.2.x network. Release and 
renew the IP address, if necessary.

5. Open the Server Admin page (http://192.168.2.254:8080) in a web browser. The 
SafeMode page displays.

6. Enter the IP address and port number of the OfficeSafe PC in the upper left 
corner. Find this information in the OfficeSafe Administration Tool on the Tools > 
Options > Network tab. It starts with 192.168.2. Do not click Restore yet!

Note:
Do not use the OfficeSafe 6 or OfficeSafe 7 application to restore backups made using 
OfficeSafe version 5.x and lower. The OfficeSafe 6 or OfficeSafe 7 application is not 
compatible with OfficeSafe version 5.x and lower.

Note:
If restoring the backup to a new Allworx server, the restore does not install any server 
feature keys from the original server. Obtain the feature keys for the new server from the 
Allworx distributor.
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4.2 OfficeSafe PC Setup

Verify the backup file is on the PC. If the server displays in the server pane of the 
OfficeSafe Administration Tool main window, then the files are available. If the server 
was backed up using a different PC, copy the backup file onto the PC using a USB flash 
drive or similar device.

1. Navigate to Tools > Options > Network tab. 

2. Verify that an IP address beginning with 192.168.2 is present in the Active 
Network Interfaces list.

3. Navigate to Tools > Options > Restore tab.

4. Select the option that describes which backup to use.

5. Click OK to return to the OfficeSafe main window.

6. Navigate to View > Current Activity.

4.3 Initiating the Restore

1. Locate the server SafeMode page, and then click the Restore from OfficeSafe 
button. A confirmation box displays, click OK.

Within a few seconds, a progress bar displays in the OfficeSafe Administration 
Tool Current Activity window.

Within a few minutes after the progress bar indicates that the restore is complete, 
the server SafeMode page displays Restore Successful in the upper left corner.

Option When to use

Most Recent 
Backup

If the restored server displays in the OfficeSafe Administration Tool server pane, and 
when using the most recent backup for the server.

Named Server

If restoring a backup from a different Allworx server stored in the OfficeSafe 
application on this PC. Verify the Allworx server model of the selected server is the 
same as the restored server. Backups from different models of Allworx servers are 
not compatible.

Select Backup File
If the preferred backup is NOT in the server pane of the OfficeSafe Administration 
Tool main window. This option enables selecting an OfficeSafe 7 or OfficeSafe 6 
backup file that is not in the PC OfficeSafe server database.
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2. Select Reboot in Normal Mode, and then click the Reboot button. 

3. Click the Close button to close the OfficeSafe Current Activity window.

4.4 After the Restore

To ensure the restored system network settings are correct, reconnect the Allworx 
server to the customer network, as before.

• If the OfficeSafe PC connections changed to do the restore, return the PC 
connections and IP addressing to the original configuration.

• If the restored server is a different server from the backup that was made and if 
there are feature keys for the new server, connect the service PC to the network, 
open the Server Admin page, and install the new feature keys.
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5 Managing Backups

After doing the backups, a tree view of the servers and the backups display in the 
Administration Tool main window. The backups display from newest to oldest. Each 
backup is a complete backup set that includes the original full backup and all 
subsequent incremental backups performed prior to the next full backup. 

Selecting either the Server Name or one of the individual backups causes pertinent 
information display in the Details pane. Drag-and-drop the individual backups to 
Windows Explorer in order to copy the files to different folders. This is useful when 
transferring a backup to a service PC performing a server restore.

A right-click pops up a menu with several backup management options.

• Rename – enables changing the server name displayed in the tree and on the 
Options tabs or renaming the folder that stores the current and subsequent 
backups. The Rename option is only available after selecting a server name.

• Delete – removes the server from the tree, all of the backup files, and the server 
entry from the OfficeSafe database. Selecting Delete for an individual backup 
removes only that backup while leaving the server entry and the other backups 
in the OfficeSafe database.

• Options – opens the Options dialog. See “User Configuration” on page 8 for 
more information.
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