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Introduction
Important information

What happens if the power goes out or if the IP network to VoIP fails?

To ensure a reliable network connection, all elements of the VoIP network should be connected 

to back-up power supplies (UPS). These elements should include LAN switches, routers, 

firewalls, broadband connection devices (i.e. cable modems, DSL modems), and VoIP devices. 

If the power goes out at the Internet Service Provider, no VoIP calls can be made. Calls can still 

be placed over the telephone lines.

Change password frequently

Setting and frequently changing the system password is recommended to avoid unauthorized 

changes to system configuration and settings.

PBX fraud

It is recommended that call bridge (DISA) and call back PIN codes are changed frequently to 

avoid unauthorized users making telephone calls through the phone system.

Emergency service numbers

Ensure emergency service numbers are not blocked by the toll restriction feature. Frequently 

used emergency service numbers are pre-programmed to avoid blocking, but other local 

numbers may be used in some location. If your location has an atypical emergency service 

number, enter it in the routing and blocking rules on the User Privilege page to ensure it will be 

routed to an appropriate phone line.

Before routing any emergency service numbers to a VoIP service provider, check that they do 

handle emergency service calls and any conditions associated with this service.

Call redirection and service provider billing advisory

Use of the call detail recording and routing and blocking features does not imply any guarantee 

whatsoever by regulatory authorities, telephone service provider(s), Fortinet or its distributors 

and resellers, with regard to the accuracy of these features and that the use of such features 

may not be considered by a telephone company in any disputes which may arise regarding the 

accuracy of any subscriber's telephone account.

Please read the Start Guide that came with your phone system before reading this user guide. 

The Start Guide contains critical information about setting up your phone system.
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Configuration
Introduction

This chapter contains detailed information about all the features in the Management software, 

with step-by-step instructions on how to customize these features to best suit your needs.

Starting the Management software 

1. Plug in the power adapter to turn on your phone system.

2. Turn on your computer.

3. Start the phone system Management software. The Configuration Selection page appears, 

and the software attempts to detect your phone system. 

4. Select your language. You can select English, Français or Español.

5. Once the software detects the system, click Configure Auto-Detected System. The software 

loads the configuration from the unit, and the About page appears.

6. If the software was unable to detect your system, check that all your wires and plugs are 

securely connected, and then click Retry Auto-Discovery. The software loads the 

configuration from the unit, and the About page appears.

When a unit is being configured, it is locked to prevent other computers or persons using a 

phone from configuring changes at the same time. If you leave the software open for longer 

than one hour, the unit unlocks itself to allow configuration changes.
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7. If auto-detection does not work:

a. Click Connect to a System Via IP. The Connect Via IP window appears. 

b. Enter the URL / IP address and Port of the system, and then click OK. This is the public 

IP address or public domain name of the system. The software loads the configuration 

from the system, and the About page appears.

8. To open a configuration file:

a. Click Open a Configuration File or Template. The Open File or Template 

window appears.

b. Click Open a File. The Open window appears.

c. Browse to the .tsd file, and then click Open. The software opens the configuration file.

d. If the selected configuration file is not compatible with your software, you will be 

prompted to convert the file to a newer format. If you select OK, software will first make 

a backup copy with the filename suffix “_old”, then convert the selected file to make it 

compatible with your software.
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About

The About page displays and allows you to change system information.

1. Select the About page.

The System Information area shows:

• The current time and date programmed into the system.

• The current mode. 

• The model numbers of the units in the system.

• The number of new voicemail messages, and the total number of voicemail messages.

• The version number of the Management software.

• When the configuration was last saved to the system.

• The type of connection to the system.

• The region of the system.

System time

System time shows the current date and time programmed into the system. Clicking the System 

time link displays the Date and Time Properties window. It allows you to change the date, time, 

time zone, and NTP server programmed into the system. See “System time” on page 11.

Current mode

Current mode shows the current mode. Clicking the Current mode link displays the Change 

Mode window. It allows you to change the mode of the system. See “Change mode” on page 9.
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My system

My system shows the model numbers of the units in the system. Clicking the My system link 

displays the Discovered Network window. It shows the MAC address, IP address, system ID, 

model number, firmware version, and length of operation for each unit.

To identify a unit, click the Identify button. The Identify button will change to a Stop button. All 

the lights on the front panel will start flashing. Click the Stop button to end the flashing.

Voicemail messages

Voicemail messages shows the number of new voicemail messages in the system, and the total 

number of voicemail messages in the system. Clicking the Voicemail messages link displays the 

Voicemail Memory Usage window. It shows message statistics for each voice mailbox. See 

“Mailbox status” on page 85.

Administration

The Administration page allows you to set up the system name, system password, numbering 

plan, region, language, and how to route the call if a user dials an operator number.
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1. Select the Administration page.

 

Administration

The Administration area allows you to set up the system name and system password. 

1. Optionally enter the System name. This should be the company name, or a shortened form 

suitable for use as caller ID during VoIP calls. If you enter a system name, you will require it 

when logging in through a browser for status or call detail record (CDR) information. 

2. Enter the System password. It has to be a 4- to 8-digit numeric password, so you can also 

enter it on a touchtone phone.

The system password allows access to the configuration. It is entered when you start the 

Management software, and when you access the configuration through a local extension or 

outside phone.

Use a system password, otherwise the system will be vulnerable to configuration changes, 

misuse and/or lock-out by callers or users. If the router has port 9393, 8485 and 8486 mapped 

to the system for remote configuration, the system will also be vulnerable to anyone on 

the Internet.

Change the system password frequently to prevent unauthorized users from making calls or 

changing the configuration.
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System numbering plan

You can use a 3, 4 or 5-digit plan for extensions, ring groups, mailboxes and speed dials in your 

system. The default is 3 digits. To change it, click Change and select the desired number of 

digits. This selection is system-wide; you can’t have a mix, for example, of 3 and 5-digit 

extension numbers.

Numbers available per plan:

3-digit numbers: 100 to 899

4-digit numbers: 1000 to 8999

5-digit numbers: 10000 to 89999

Region selection

The Region Selection area allows you to select the country where your system will operate.

Language

The Language area displays the language loaded into the system, and allows you to load and 

remove language files.

1. To change the language files loaded into the system, click Edit. The Language File 

Management window appears, listing loaded language files.

a. To load a language file, click Add, and then select the language file.

b. To remove a language file, select the language, and then click Remove.

2. Select the default language for prompts heard by callers and users in the Default language 

for system prompts to callers list.

Dial 0 or 9 routing

The Dial 0 routing area (or Dial 9 routing area in some regions) allows you to select how the 

system will route the call if a user dials 0 or 9. For example, you can configure the system to 

connect the user to the receptionist at extension 114.

1. Select the action in the Connect to list. Choices are:

• perform no action — Does not connect to a resource.

• go to voicemail — Connects to the selected voicemail.

• go to local extension — Connects to the selected local extension.

• go to remote extension — Connects to the selected remote extension.

• go to ring group — Connects to the selected ring group.

• play announcement — Plays the selected announcement.

• go to auto attendant — Connects to the selected auto attendant.

• queue at ring group — Connects to the call queue of the selected ring group.

• dial-by-name directory — Accesses the dial-by-name directory.

2. Select the resource. Depending on the action, resources are voice mailboxes, extensions, 

announcements or auto attendants
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Scheduling

A mode is a period of time when the system uses a particular call handling setup for incoming 

calls. Mode 1 is typically office hours, and Mode 2 is typically evening and weekend hours. 

Holiday Mode is when your office is closed for a statutory holiday or shutdown.

The system can use a different call handling setup for each mode, and can automatically 

change mode with the time of day, day of week and on holidays. This way it can handle calls in 

different ways according to a schedule.

The Scheduling page allows you to set up Mode 1, Mode 2 and Holiday Mode. You can also 

adjust the time and date, and can switch modes manually. 

1. Select the Scheduling page.

Modes

The Modes area allows you to enable, name and switch modes, and displays the current mode.

1. Enter the Mode 1 label and the Mode 2 label. Note that Mode 1 and Mode 2 are always 

available, so you cannot disable the Enable Mode 1 and Enable Mode 2 checkboxes.

Ensure the Management software is closed during automatic mode switching, or if an 

administrator is manually switching modes using a phone. In these cases the mode cannot 

switch while the Management software is open.

Note that the mode can switch while the Management software is open, if the user is manually 

switching modes using the software, as described later.
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2. Set up Holiday Mode to handle incoming calls differently during a holiday:

a. Select the Enable holiday mode checkbox to enable Holiday Mode. The window enables 

the Settings button.

b. Enter the Holiday Mode label.

c. Click Settings. The Holiday Settings window appears. The calendar shows the current 

date in green. 

d. Select your country in the Populate calendar with holidays observed in list, and then click 

Populate. The calendar will show your country’s statutory holidays in grey.

e. Using the calendar, select the month and then click the date of the holiday. The date is 

added to the Selected Dates area, and the calendar will show the date in blue. Click the 

date again to remove it.

f. Repeat the above step until all required holidays have been added.

g. Select the mode in the Use the following Call Cascade settings for Holiday Mode. 

Choices are Mode 1 and Mode 2. This setting determines whether extensions will use 

their Mode 1 or Mode 2 call cascades during Holiday Mode.

Change mode

The Modes area displays the current mode.

1. To change mode, click Change Mode. The Change Mode window appears.

2. Select the mode. The new mode immediately takes effect. You do not have to save 

the configuration.

You can also change the mode by phone.
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Remotely

1. Ensure the Management software is closed.

2. Remotely call the system.

3. At the auto attendant, enter command mode by pressing #.

4. Enter the system password, followed by #.

5. Enter one of the following commands:

• 30 + #  to hear the current mode.

• 31 + #  to enable Mode 1.

• 32 + #  to enable Mode 2.

• 33 + #  to enable Holiday Mode.

6. Press * to exit command mode.

Locally

1. Ensure the Management software is closed.

2. Pick up a local extension.

3. Enter one of the following commands:

• ***30 + #  to hear the current mode.

• ***31 + #  to enable Mode 1.

• ***32 + #  to enable Mode 2.

• ***33 + #  to enable Holiday Mode.

Note: a password is not required.

4. Press * to exit command mode.

Scheduling

The Scheduling area allows you to specify when the system will change modes.

1. Select the Use automatic mode switching checkbox to enable the modes. The window 

enables the Scheduling area.

2. Select the day.

3. Select whether to use one mode or multiple modes during that day:

• Select Continuously run to use the selected mode the whole day.

• Select Switch modes depending on time to switch between Mode 1, Mode 2 and 

Holiday Mode during the day. The window enables the schedule controls.

4. If you selected Continuously run, select Mode 1, Mode 2 or Holiday Mode.

5. If you selected Switch modes depending on time, set when the mode should change. The 

default settings are:

• Mode 1 at 9:00 AM on Monday to Friday.

• Mode 2 at 5:00 PM on Monday to Friday.

• Mode 2 continuously on Saturday and Sunday.

To change the mode switch time for more than one day, make the change to one day and 

click the Copy schedule to other days button. In the dialog box, check the desired days to 

apply the new time.
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System time

The Scheduling area shows the date and time programmed into the system. Clicking the Adjust 

button displays the Date and Time Properties window. It allows you to change the date, time, 

time zone, and NTP server programmed into the system.

1. Click Adjust. You can also choose Options > Set Date & Time. The Date and Time Properties 

window appears.

Date & time

The Date & Time area allows you to set the date and time programmed into the system.

1. Select the month and date for the system.

2. Set the time for the system.

Time zone

The Time Zone area allows you to set the time zone for the system, and whether daylight 

savings time is used in your region.

1. Select the time zone for the system.

2. If your region uses daylight savings time, select the Automatically adjust clock for daylight 

saving changes checkbox.

You can configure the system to get the time and date (but not the year or time zone) from caller 

ID. See “Clock Preferences” on page 136.
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NTP server

The NTP Server area allows you to set the NTP (Network Time Protocol) server for the system. It 

provides the same time to the units and to the external IP extensions.

1. Select the NTP Server tab.

2. Enter the NTP server. 
Configuration Page 12 FortiVoice v7.31 User Guide

http://www.fortinet.com/


IP Configuration

The IP Configuration page allows you to set up the system for Internet communications. The 

Internet can be used for external IP extensions, a VoIP network, a subscription to a VoIP 

service, and remote configuration.

1. Select the IP Configuration page.

System IP settings

The System IP Settings area shows IP addresses. By default, Obtain IP and DNS information 

automatically is selected and the area shows IP addresses from the router. 

1. Change Obtain IP and DNS information automatically to Use configured IP and DNS 

information in order to lock in the IP addresses.

2. In some cases, the System IP Settings area may be blank because your router has not 

delivered the IP addresses. If so, enter the following IP addresses from your 

LAN administrator:

a. Enter a static IP address for each unit in the Unit IP address boxes.

b. Enter the Subnet mask for the LAN. This address determines the subnet the unit IP 

addresses belong to.

c. Enter the IP address of the Default gateway on your network. A gateway is a hardware 

device that connects the office network to the Internet. The router may act as 

default gateway.

d. Enter the IP address of the Preferred DNS server. DNS is a service used to resolve a 

domain name to an IP address. The router may act as DNS server.

e. If applicable, enter the IP address of the Alternate DNS server.

PRI Interface Address

The PRI Interface Address area allows you to assign an IP address to the PRI interface. This IP 

address must be different than the system IP address.
Configuration Page 13 FortiVoice v7.31 User Guide

http://www.fortinet.com/


Public IP address

The Public IP Address section allows you to set up Internet parameters so the system can 

communicate with other locations over the Internet.

1. Set the Type of public address. Choices are:

• Dynamic public IP address — This is the default setting. Your ISP (Internet Service 

Provider) will assign different public IP addresses to your location. The system will check 

its public IP address every five minutes. When the public IP address changes, the 

system will automatically use the new one. This allows it to manage VoIP calls properly.

• Static public IP address — A static IP address is fixed. Your ISP assigns the static IP 

address.

If Static public IP address is selected, the window allows you to enter the Current public 

IP address.

2. If you selected Dynamic public IP address, enter the Public domain name. A public domain 

name is only required if this location has external IP extensions.

A DDNS (Dynamic Domain Name Service) provider such as www.dyndns.com can create a 

public domain name to resolve to your IP address, so your external IP phones will continue 

to work when the IP address changes.

If you are using DDNS, ensure your router supports your DDNS service, and configure it to 

update the DNS servers.

If your router does not support DDNS, download one of the applications specified on 

www.dyndns.com. To update the DNS servers, the application needs to run on a PC 

connected to the same LAN as the system.

3. If you selected Static public IP address, enter the Current public IP address from your ISP. 

Leave the Public domain name box blank.

If the unit is not behind a router, or if a private virtual network is used, the public IP address 

should be set to the local IP address of the unit acting as local proxy.

Note that it will take up to one minute for the new static public IP address to take effect.

Firewall settings

The Firewall Settings area displays the IP address of the gateway (i.e. router), and whether 

router configuration is required.

A router is a gateway between the local area network and the Internet. Most routers have a 

firewall to block unwanted data from the Internet. For voice data to reach the system through 

the firewall, port forwarding is required. Port forwarding allows the router to map ports to the IP 

addresses of the units. Valid Internet data will use the ports to go through the firewall to the 

units.

If you are setting up external IP extensions, or a VoIP service that doesn’t handle port 

forwarding, port forwarding is required.

If port forwarding is required, and your router supports uPNP (Universal Plug and Play), ensure 

uPNP is enabled. The system will use uPNP to automatically set up port forwarding, and the 

Automatic (uPNP Enabled) link will appear. No router configuration is required.

If port forwarding is required but your router doesn’t support uPNP, or automatic port forwarding 

doesn’t work, the Manual Port Mapping Required link will appear. You will need to configure the 

router as described below.
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1. Click the Manual port mapping required link. The Manual Port Mapping window appears. It 

lists the packet type, port number, IP address and protocol of each required port. 

2. To access the router configuration:

a. Click the link containing the IP address of the gateway. The default browser starts, and 

prompts you for the router’s user name and password.

b. Enter the router’s user name and password. The browser shows a setup screen.

c. Navigate to the screen used to set up port forwarding. See your router documentation.

d. Set up port forwarding using the information from the Manual Port Mapping window. See 

your router documentation for instructions on how to map ports. For information on 

configuring routers and mapping ports, visit 

http://www.portforward.com/english/routers/port_forwarding/routerindex.htm.

3. To check the status of each port through the firewall, click Check Firewall. The Firewall Test 

window appears.

4. Select the services you want to check.

5. Click Test Ports. The system will check the ports of the selected services.
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Configuring the router manually

If you cannot access the router configuration through the IP Configuration page, configure the 

router manually.

1. Open the router configuration and navigate to the screen used to set up port forwarding. 

See your router documentation.

2. In the Management Software on the IP Configuration page, click the Manual Port Mapping 

Required link.

3. Map the port indicated for SIP (VoIP) signaling.

If required, you can map a different port. Select Troubleshooting > VoIP and enter the port in 

the SIP signalling port field.

Map the rest of the ports to the IP addresses indicated in the Manual Port Mapping window.

If required, you can map different ports. Select Troubleshooting > VoIP.

4. Map ports 9393, 8485 and 8486 (Type: TCP) to the unit acting as local proxy to allow remote 

configuration of the system.

5. If available, enable Quality of Service (QoS) to give voice traffic priority over data.

6. Save the configuration to the router.
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On-Hold/Ringback

Music on hold plays when a caller is on hold, or is being transferred to an extension. The system 

plays a double beep tone or ringback tone by default, but you can have it play music or a 

recorded message instead.

The system can play music on hold from an internal .wav file or from an external audio source. 

An external audio source is a CD player or MP3 player. It must be connected to the MUSIC jack 

on the back of each unit.

The recording time for internal music on hold, voicemail, and the auto attendants is shared on 

the unit.

The On-Hold/Ringback page allows you to set up music on hold.

1. Select the On-Hold/Ringback page.

On-hold settings

The On-hold Settings area allows you to select the sound to play while the caller is on hold.

1. Select the sound to play while the caller is on hold. Choices are:

• Play “double beep” tones — Plays a “beep beep” sound.

• Play music whose source is connected to the MUSIC jack — Plays music from a CD 

player connected to the MUSIC jack.

• Play music from file loaded on the system — Plays the .wav file loaded into the system.

2. If you selected Play music from file loaded on the system:

a. Obtain an 8 kHz, 8 bit, Mono, u-Law .wav file that contains the music or recorded 

message.

You can also convert .mp3 and other file formats to .wav with an audio converter utility.
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b. Click Load Wav file. The Select Wav File window appears.

c. Click Browse to select a .wav file. Click Load to load the .wav file into the system. The 

file size and date loaded will be dispayed. Play and Stop buttons are also provided, if 

you prefer to listen to the file before loading it.

d. Save the configuration to allow the music on hold to take effect.

3. Adjust the volume of music on hold.

a. Check the volume by placing a test call and going on hold.

b. Change the volume by setting the Playback volume for music file list. Choices are:

• loudest

• louder

• default

• quieter

• quietest

c. Choose File > Save.

You must save the configuration for the volume setting to take effect.

d. Repeat Steps a. – c.

Deleting a music on hold file

You can delete a music on hold file. This may be required if you need more space for voicemail 

messages. In this case you can use an external audio source for music on hold, or you can 

upgrade the memory capacity of the units.

1. Click Delete Wav File. The system deletes the .wav file from the unit(s).

Playing music on hold on the PA system

You can play music on hold through the PA jack.

1. Dial *80 to play or stop playing music on hold through the PA jack.

If music on hold is playing through the PA jack, and a user dials *0 to make an overhead page, 

the overhead page will interrupt the music on hold. However, if the PA jack is configured for 

voicemail screening, and music on hold is playing, voicemail screening will not interrupt the 

music on hold. See “Paging Options” on page 132.

Transfer settings

The Transfer Settings area allows you to select the sound to play while the caller is being 

transferred from an auto attendant or to another extension.

1. Select the sound to play while the caller is being transferred. Choices are:

• Music — Plays music on hold as configured in the On-Hold Settings area.

• Ringback — Plays the ringback tone, which is the normal sound heard when the other 

person’s phone is ringing.
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Email Service

The system can send an e-mail if a voicemail message has been left in a mailbox. The e-mail 

includes the caller ID, and can include the voicemail message as an attachment.

The e-mail can optionally include links to delete or save the voicemail message. If you delete the 

voicemail message, it will be removed from the system. If you save the voicemail message, the 

system will change its status from “new” to “saved”. A voicemail message that is saved will no 

longer activate the new message indicator on the user’s extension.

The system can send notification to up to four e-mail addresses per mailbox. For example, if a 

caller leaves a message in the general mailbox for the sales group, the system can send an 

e-mail to four members of the sales group.

An e-mail address can be assigned to multiple mailboxes. For example, the system can send 

e-mails to a user if callers leave messages in the user’s local extension mailbox, remote 

extension mailbox or a general mailbox.

The Email Service page allows you to maintain e-mail addresses, set up the e-mail server 

parameters, and test the e-mail server.

1 Select the Email Service page. 

Email notification settings

The Email Notification Settings area allows you to add up to 255 e-mail addresses.

1. Select a slot for the e-mail address.

2. Enter the recipient’s Full name.

3. Enter the recipient’s Email address.
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4. Select the Notification option. Choices include:

• Include voice message as attachment — Attaches the voicemail message to the e-mail 

as a .wav file. The e-mail includes options to save or delete the voicemail from the 

system.

• Email notification only (Full length) — Does not attach the voicemail message to the 

e-mail, but includes full details about the contents of the voicemail, including sender, 

time sent and length, along with a talley of new and saved messages.

• Email notification only (SMS length) — Does not attach the voicemail message to the 

e-mail as above, and includes the same information abbreviated to under 130 

characters.

Import an email list

The Import an Email List area allows you to import e-mail addresses from a .csv file.

Each entry in the file must be formatted as follows: name,e-mail address. For example:

John Doe,john.doe@email.com
Jane Doe,jane.doe@email.com

1. Click Select File. The Import an Email List window appears.

2. Select the .csv file, and then click Open.

E-mail server settings

The Email Server Settings area allows you to set up the e-mail server parameters, include links 

to delete or save the voicemail message, and test the system’s ability to send e-mail.

You will need an e-mail address to send notifications from. 

Use e-mail account information from your Internet service provider (ISP), system administrator, 

or alternatively, obtain one from a compatible online e-mail provider. 

1. Enter an e-mail address in the Dedicated email address for sending/receiving emails box. 

When e-mail notifications arrive from the system, this e-mail address will show up in the 

From field.

Notification may not work properly if the SMTP server uses Microsoft Exchange Server, and/or 

certain security features are enabled.
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2. Enter the name of the Outgoing mail server (SMTP).

3. To configure authentication and server port numbers, click More Settings. The Outgoing 

Email Settings window appears. See “Outgoing server authentication” on page 21 and 

“Server settings” on page 22.

4. To include links within the e-mail notification, select the Enable delete/save messages 

option checkbox. The links will allow the recipient to delete or save the voicemail message. 

The e-mail notification can only include the links if the voicemail message is attached.

5. Deleting the voicemail message will remove it from the unit. Saving the voicemail message 

will change its status from “new” to “saved”. A voicemail message that is saved will no 

longer activate the new message indicator on the user’s extension.

6. Enter the name of the Incoming mail server (POP3). The name will automatically appear in 

the My Outgoing Server (SMTP) Requires Authentication area.

7. To configure authentication, server port numbers and how often the system should check 

the POP3 server, click More Settings. The Incoming Email Settings window appears. See 

“Incoming server authentication” on page 22, “Incoming server port numbers” on page 22 

and “Incoming mail server options” on page 23.

Outgoing server authentication

The My Outgoing Server (SMTP) Requires Authentication area allows you to enter account 

information for the outgoing server. The outgoing server is also referred to as the SMTP server. It 

can have its own account information, or can use the account information from the incoming 

server. The incoming server is also referred to as the POP3 server.

1. If the outgoing server requires authentication, select the My Outgoing Server (SMTP) 

Requires Authentication checkbox.

2. Select the type of login your server requires:

• If the outgoing server uses its own login information, and can send e-mail without first 

logging in to the incoming server:

i. Select This server requires SMTP login information.

ii. Enter the User name of the account from the outgoing server.

iii. Enter the Password of the account from the outgoing server.

• If the outgoing server uses login information from the incoming server, and must log in to 

the incoming server before sending e-mail:

i. Select This server requires you to login to the incoming mail server before sending 

mail.

ii. Enter the name of the Incoming mail server (POP3). The name will automatically 

appear in the Enable Delete/Save Messages Option area.
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iii. Enter the User name of the account from the incoming server. The user name will 

automatically appear in the Incoming Server Authentication area.

iv. Enter the Password of the account from the incoming server. The password will 

automatically appear in the Incoming Server Authentication area.

Server settings

The Server Settings area allows you to enter a port number for the outgoing server. 

1. The default Outgoing mail server (SMTP) port is 25. If required, enter a different port number 

ranging from 1 to 65535.

2. Select an acceptable authentication method for your server. If you’re uncertain, click the 

Test Account Settings button on the Email Services page. The correct authentication 

method will be set automatically. The Test Email routine will test the server and confirm the 

authentication method supported by the server and will set the value accordingly.

Incoming server authentication

The Incoming Server Authentication area allows you to enter the user name and password of 

the account from the incoming server. The incoming server is also referred to as the POP3 

server.

1. Enter the User name of the account from the incoming server. The user name will 

automatically appear in the My Outgoing Server (SMTP) Requires Authentication area.

2. Enter the Password of the account from the incoming server. The password will 

automatically appear in the My Outgoing Server (SMTP) Requires Authentication area.

Incoming server port numbers

The Server Settings area allows you to enter a port number for the incoming server. 

1. The default Incoming mail server (POP3) port is 110. If required, enter a different port 

number ranging from 1 to 65535.

2. If your POP3 server supports secure authentication, check the box. Please refer to your mail 

server settings.
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Incoming mail server options

The Incoming Mail Server Options area allows you to specify how often the unit should check 

the incoming server for e-mail messages from users deleting and saving voicemail messages. 

The incoming server is also referred to as the POP3 server.

1. Select the Email request interval, ranging from 2 minutes to 30 minutes.

2. To delete e-mail messages that aren’t from users (i.e. spam), select the Delete any 

unrecognized inbound emails checkbox.

Testing the e-mail server settings

1. Click Test Account Settings.

2. Click Save. The system saves the configuration, then the Test Account Settings 

window appears.

3. Enter an e-mail address in the Test email address box, and then click Start. The following 

window shows a successful result, with each task completed.

If a task fails, the system is not able to send e-mail messages. Adjust the e-mail server 

parameters accordingly:

• If Find outgoing mail server (SMTP) fails, check the SMTP server name in the Outgoing 

mail server (SMTP) box.

• If Log onto outgoing mail server (SMTP) fails, check the SMTP server authentication 

parameters in the Outgoing Email Settings window.

4. Ensure the e-mail address has received the test e-mail. Note that the e-mail may have been 

routed to a junk or spam folder.
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Managing voicemail messages

If the Notification option is set to Include voice message as attachment, the recipient can play, 

save or delete the voicemail message.

1. To play the voicemail message, the recipient double-clicks the attachment. The default .wav 

player opens the voicemail message.

2. To save the voicemail message, the recipient clicks Save message. The e-mail program 

creates a new e-mail message with the To and Subject fields completed. The recipient 

sends this e-mail message. Upon receiving the e-mail message, the system will change the 

status of the voicemail message from “new” to “saved”, and the local extension will turn off 

the new message indicator. However the system will not delete the voicemail message.

Note that the system allows up to 99 voicemail messages per mailbox. Once a mailbox fills 

up, callers won’t be able to leave voicemail messages for that user. Therefore users should 

delete voicemail messages before the mailbox fills up.

3. To delete the voicemail message, the recipient clicks Delete message. The e-mail program 

creates a new e-mail message with the To and Subject fields completed. The recipient 

sends this e-mail message. Upon receiving the e-mail message, the unit will delete the 

voicemail message.

Setting up POP3 service with Microsoft Exchange

If your system uses Microsoft Exchange, and you wish to include voicemail messages as 

attachments within the notification emails, you must set up POP3 service.

For instructions on how to download, install and configure POP3 service, refer to the Microsoft 

documentation included with your version of Exchange. See 

http://technet.microsoft.com/en-us/library/aa998454(EXCHG.65).aspx for more information.

Risks of enabling POP3 service

• The default configuration does not use encryption when sending the username 

and password.

• Unauthorized clients can use the POP3 service.

• E-mails from users for saving and deleting voicemail messages are not stored on the 

Exchange server, but are pulled through to the client (i.e. the system).

Security recommendations

1. Install the system on the same LAN as the Exchange server.

2. Follow the Microsoft procedures for tightening security.

3. The POP3 service is a virtual server. You can use the following techniques to control 

incoming access to a virtual server. Refer to the Microsoft documentation included with 

your version of Exchange.

• Grant or deny access using IP addresses or Internet domain names.

• Require authentication for incoming connections.

• Restrict concurrent connections.

• Set connection time-out values.
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Global Dial Plan

Configuring multiple locations with the global dial plan

FortiVoice FVC-40, 70 and 100 systems in multiple locations can be connected over the public 

internet or a closed network such as a VPN. Extensions in any office can call any other office by 

using a location code prefix. Calls can be transferred and conferenced between locations.

The global dial plan is set by the central administrator and instantly broadcast to all other 

locations.

Setting up the global dial plan: master system

1. Select the Global Dial Plan page in the FortiVoice Management software.

2. Check the Activate Global Dial Plan checkbox.

3. Check the This site is the master location checkbox. Enter your public IP address or the IP 

address of the system if you are using a VPN.

4. Create an 8-character User Key. The user key will be shared among the locations.

5. Create a Password. The password is for authentication of the plan and should be known to 

the central admin only.
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Add the locations

1. Click on the Create Dial Plan File button. The Create Dial Plan File window opens. 

2. Click the Add button. The Add Location window opens. 

3. Enter the Name of the master location.

4. Assign a location Code. Location codes can be 2 or 3 digits. Each location must have the 

same number of digits.

5. Enter the IP address or Fully Qualified Domain Name of the master location

6. Select the number of digits in the master location's dialing plan. For optimum usability, each 

location should use the same number of digits in extensions, but the plan will work if they 

differ.

7. The SIP Port and HTTP Port values are prepopulated. If you have changed the defaults for 

the site, you must enter the correct values.

8. Click Done and repeat for all of the sites.

9. Save settings to the system.
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Setting up the global dial plan: all other systems

1. Select the Global Dial Plan page in the FortiVoice Management software at each location. 

2. Check the Activate Global Dial Plan checkbox.

3. Enter the public IP address or the IP address of the master system if you are using a VPN.

4. Enter the User Key.

5. Save settings to the system.

Using the directory

Click the View Directory button for the full directory of all extensions in all locations. Each 

location’s directory can be exported as a comma-separated file by clicking the Export button.

Configuring Call Handling (optional)

If a user dials a location code without an associated extension number, the call will go through 

to that location. You can set the way a location handles those calls in the Call Handling section. 

For each available mode, select the desired call handling from the first pull-down menu, and 

select a resource, if applicable, from the second. 
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VoIP Configuration

The VoIP Configuration page allows you to set up to four service provider profiles. You can also 

view registration status, set codec options, and reserve VoIP lines for specific setups.

Setting up a service provider profile

A service provider profile contains the settings that allow your system to register with the 

provider.

Service configuration guides for certified VoIP service providers are available in the Windows 

program folder under Service Configuration Guides.

1. Select the VoIP Configuration page.

2. Select a Profile (SP 1 to SP 4).

Activate profile

You can set up a service provider profile automatically or manually.

Automatic configuration

1. Select the Activate Profile checkbox.

2. The Service Provider menu offers a list of certified VoIP service providers. If your service 

provider appears in the menu, click on the name. The name is then displayed in the Service 

Provider field.
Configuration Page 28 FortiVoice v7.31 User Guide

http://www.fortinet.com/


3. Click the Update Configuration button. The essential settings for communication with the 

service provider’s registration server will be completed automatically.

 

4. If you want to customize other aspects of your VoIP lines, you may do so in the System VoIP 

Options area. See  “System VoIP options” on page 32.

Account-specific and number-specific settings are not automatically configured. These 

must be entered on the VoIP Numbers page.

Manual configuration

1. Select the Activate Profile checkbox.

2. Enter the Profile name. The default profile name is Service provider n (e.g. Service 

provider 1).

Additional settings

Public IP

If your service provider requires you to register using your private IP address, select the Disable 

public IP address substitution checkbox. Check with your service provider.

NAT

1. If your service provider requires keep alive messages, and if your router does not support 

uPNP, check the Enable NAT keep alives checkbox.

For selected service providers in your region, a link may appear beside the Profile name to 

permit easy access to the provider’s website.
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a. Select the method used to keep ports open. Choices are:

• Simple ping — A standard ping message that works with all SIP servers.

• Nortel ping — A ping message that works with Nortel SIP servers (e.g. Nortel 

MCS 5200).

b. If necessary, change the ping frequency. The default setting is 45 seconds. 

Preferred ID

Preferred Identity is a supported service provider feature that allows your system to make calls 

with an anonymous caller ID. Please ensure your service provider offers this feature before 

enabling it, or you might be unable to make calls.

Codec

You can specify which codecs to use by clicking the Additional Settings button. See “Setting 

codec options” on page 31.

Registration method

Some providers require the system to register using the username or account information rather 

than the VoIP number(s) provided. If so, check the Register with authentication username box to 

have the system register with the username information provided in the VoIP numbers page. 

Check with your VoIP service provider if you’re uncertain which method of registration is 

required.

VoIP Provider

Enter the IP addresses or public domain names, as provided by the service provider, into the 

following boxes. If the service provider does not specify a value, leave the box blank.

• Proxy/Registrar server name

• Registrar server name

• Outbound proxy

• Realm/domain

The View All Registrations button will allow you to confirm connection to your service provider 

once you have completed the configuration of your VoIP numbers. See “Viewing registration 

status” on page 31.

If you want to customize other aspects of your VoIP lines, you may do so in the System VoIP 

Options area. See “System VoIP options” on page 32.
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Viewing registration status

Clicking the View All Registrations button shows a window with a list of VoIP numbers, their 

registration status, and the number of seconds until their registrations with the SIP server will 

expire. This confirms the system is registered with a SIP server.

1. Click View All Registrations. The Registration status window appears.

2. Choose All Registrations or an active profile.

• Client lists the VoIP numbers set up within the system.

• Status is the registration status (Registered or Not registered).

• Expires is the amount of time, in seconds, until the client has to re-register with the 

SIP server.

Setting codec options

A codec is a method of compressing and decompressing audio signals for communication 

across a network. The system supports the G.729 and G.711 (µ-law or A-law) codecs for VoIP 

calls. If your service provider or equipment requires specific codecs for VoIP or Fax over IP 

calls, you can restrict the system to use the required codec. The following codes are supported:

• G.729 — This codec provides good quality. It requires the least bandwidth and 

accommodates the highest number of concurrent calls.

• G.711µ — This codec provides high quality and supports Fax over IP. It requires the most 

bandwidth and accommodates the fewest number of concurrent calls. G.711µ is used in 

North America and Japan.

• G.711A — This codec provides high quality and supports Fax over IP. It requires the most 

bandwidth and accommodates the fewest number of concurrent calls. G.711A is used 

worldwide outside North America and Japan.

• Voice activity detection (VAD) — Enabling VAD reduces voice bandwidth when no speech is 

detected, and reduces transmission of background noise. We recommend disabling VAD to 

keep bandwidth available for speech.
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You may select which codecs to use or clear the unsupported codecs as well as select a 

Preferred codec.

System VoIP options

VoIP Caller ID

The VoIP Caller ID area allows you to set up the source for the caller ID name for outbound VoIP 

calls. The same setting is used for Global Dial Plan and all service provider profiles. Extension 

names are used by default.

1. Set the caller ID information for outgoing VoIP calls:

• To use the System name from the Administration page, select Use system name in Caller 

ID information for all outgoing VoIP calls.

• To use the First name and Last name from the Local Extensions/Fax page, select Use 

extension names in Caller ID information for all outgoing VoIP calls.

See “Caller ID settings” on page 49 to select the phone number that will appear on the 

other phone.

Line reservation

By default, all VoIP lines are available for external IP extensions, calls to other locations in a 

multi-branch network, and/or service provider calls on a first-come first-served basis. You can 

also reserve VoIP lines for a specific use. For example, you could set aside two lines for external 

IP extensions.

Reserving VoIP lines guarantees resources for a specific network. Sharing VoIP lines uses them 

most efficiently.

When reserving VoIP lines for a service, the choice ranges from 1 to the number of unreserved 

VoIP lines at this location. Shared means do not reserve any VoIP lines for this service. Only 

unreserved lines will be available.

1. Click Reserve VoIP Lines. The VoIP Resource Reservation window appears.

2. Select the number of VoIP lines to reserve for External IP extension calls using its pull-down 

menu.
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3. Select the number of VoIP lines to reserve for Global Dial Plan calls using its pull-down 

menu.

4. Select the number of VoIP lines to reserve for Service Provider calls for each provider using 

its pull-down menu.
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User Privileges

User privileges control the lines and features an extension can use.  You can set different 

profiles to apply to management and staff, for example, or for different departments. You can 

also route or block calls to specific numbers. Each extension must have a user privilege profile. 

This is also known as class of service.

You can configure user privilege profiles on the User Privileges page. By default, Profile 1 is 

active. Select any other profile and check the Activate User Privileges checkbox to activate it, or 

click on an active profile to edit its settings.

Outgoing Access

The Outgoing Access area controls the hunt groups an extension can use. If a user dials a hunt 

group without access, a PIN code will be required to gain access. By default, Profile 1 has 

access to all hunt groups. 

To assign hunt group access:

1. Check the Hunt Group Access checkbox

2. Click the Edit… button

3. Check the boxes for the hunt groups this user profile may access.

Blocking outbound access

If you wish all users in a profile to use a PIN code in order to access a hunt group, check the PIN 

required for outbound access checkbox.

Call Bridge (DISA) access

Call bridge access allows the user to call into the system and seize an outbound line for calls. If 

you wish the users in a profile to have access to call bridge, check this checkbox. For more 

information, see “Using call bridge” on page 169.
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Feature Access

Check the features that you wish this profile to have access to.

Intercom Calls — Allows users to call another extension. Typically, courtesy phones aren't 

allowed to call other extensions.

Remote Extensions — Allows users to call remote extensions.

Ring Groups — Allows users to call or transfer calls to Ring Groups.

Speed Dial — Allows users to dial system speed dials

Command Mode — Allows users to enter command mode to make changes to the system. 

Paging — Allows users to page other extensions or use the overhead paging system.

Global Dial Plan— Allows users to call or transfer calls to other locations.

Log in/out of Ring Groups — Allows users to join or leave ring groups.

Call Barge — Allows a user to join another user’s call. This feature is restricted to calls 

connected via PSTN telephone line to an outside party.

Additional Settings

Personal Identification Numbers

If your user profiles have access to call bridge or require a PIN code to get outbound access, 

you must assign PIN codes to the users. PIN codes must be 4 to 8 digits. PINs can be assigned 

a different user privilege profile to supersede the current active profile to provide additional 

access if required.

The PIN Code Configuration area allows you to add and remove access codes.

Adding a PIN

1. Select an ID.

2. Enter a Name. This is typically the name of the user, or the name of the office where the 

extension is located.

Alternatively, you can click the Browse button to display the Browse for Extension window. 

It allows you to select an extension number and the associated first name and last name as 

the name. 

If a call is made from a restricted local extension, the call detail record (CDR) will display the 

name associated with the PIN, and not the PIN itself.

3. Enter a Code. This is a numeric code that can be dialed using a telephone keypad. Each 

PIN works with all restricted extensions.

4. Assign a User Privilege to this PIN.

Enable password protection when PINs are used. Change the system password frequently to 

prevent unauthorized users from making calls or changing the configuration. 

See “Administration” on page 6.
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Removing a PIN

1. Select the PIN.

2. Click Clear Code.

Routing and blocking

The routing and blocking rules control the numbers that can be dialed by users from the system 

and the lines they access.  Each rule can be applied to any of the user privilege profiles to 

control which extensions are allowed to dial long distance or international calls.

Routing handles outgoing calls depending on the leading digits. It can also prefix phone 

numbers with certain carrier codes depending on the leading digits and time of day so calls can 

use specific telephone lines, alternative carriers, or VoIP lines for least-cost routing. For 

example, you can route international calls to a VoIP service provider and local calls to a carrier 

offering discounted rates.

If the user dials a hunt group number, routing and blocking rules can override the selection and 

use a different hunt group depending on the leading digits.

The leading digits are the first numbers dialed when placing a telephone call. For example, 

“1900” are the leading digits of 1-900-555-1234.

Calls with leading digits that do not match the routing and blocking rules will be routed to the 

hunt group originally dialed by the caller.

Routing and blocking acts on the longest leading digits entry matching the dialed number. For 

example, an entry in the routing and blocking rules blocks numbers with leading digit “1” to 

prevent long-distance calls. However a second entry routes numbers with leading digits “1800” 

through a hunt group because they are toll-free. Because the second entry (1800) is longer than 

the first entry (1), the second entry has precedence. Therefore a call with leading digits “1800” is 

routed, even though leading digit “1” would otherwise cause it to be blocked. This reduces the 

number of rules required and can restrict calls to all but specific area codes or countries.

• Leading digits can be 1–11 numbers in length. 

• The leading digits exclude the hunt group number dialed by the user.

Carrier codes

A carrier code is prefixed to the phone number dialed by the user. It tells the telephone company 

to route the call to an alternative carrier. For example, the carrier code could be a calling card 

number and PIN number. You can set the system to use different carrier codes based on the 

leading digits and the time of day.

• Carrier codes can be up to 1–24 characters in length.

• Carrier codes can include numbers, *, #, “,” (comma for 2-second pause), and w (for 

wait-for-dial-tone). A 2-second pause is automatically added after dialing a carrier code.

Each entry in the routing and blocking table can have one or two carrier codes. Carrier code 1 is 

either used all day, or from Start time 1 until Start time 2. Carrier code 2 is used from Start time 2 

until Start time 1. 

Use of Carrier Selection Prefix and Carrier Codes may require a subscription to a carrier’s 

discount calling plan. This service may not be available in some countries and on some 

Enable password protection when routing and blocking is used. Change the system password 

frequently to prevent unauthorized users from making calls or changing the configuration. See 

“Administration” on page 6.
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telephone companies’ telephone lines. Carrier Selection Prefix may not be required if a 

“Pre-Selection” service is provided by the telephone company.

3-Way Calling/Conference service

The use of the telephone company‘s 3-Way Calling/Conference service is not recommended on 

telephone lines when routing and blocking rules are used. The system can’t control routing 

through these services.

Setting up routing and blocking

1. Configure the system password and hunt groups before setting up routing and blocking.

2. Click the User Privileges page. Select the Edit Rules button in the Routing and blocking 

section. The Edit Routing and Blocking Rules window appears.

Assigning routing and blocking rules

1. Select a free table entry, or edit an existing entry.

2. Enter the leading digits in the Number box. Omit the hunt group number from the leading 

digits. The system will only block or redirect calls where there is a matching leading digit 

match.
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3. Select the Action. Choices are:

• Hunt group (n) — Routes the call to the hunt group.

• Block calls — Blocks the call.

4. Assign the rule to applicable user privilege profiles.

Carrier code prefixes

The Carrier Code Prefix area allows you to set carrier codes the system will automatically use 

when the leading digits are dialed. A carrier code is prefixed to the number dialed by the user. It 

tells the service provider to route the call to an alternative carrier. For example, the carrier code 

could be a calling card number and PIN number. 

1. If the route requires one carrier code for the whole day:

a. Enter the carrier code in Carrier code 1.

b. Clear the Carrier code 2 checkbox.

2. If the route requires two carrier codes, one for each part of the day:

a. Enter the first carrier code in Carrier code 1.

b. Enter Start time 1.

c. Select the Carrier code 2 checkbox.

d. Enter the second carrier code in Carrier code 2.

e. Enter Start time 2.

Regulatory advisory notice 

Conference Bridge

The system supports up to 10 conference bridge accounts that will allow up to 8 participants to 

join a conference.  A conference bridge number is required for users to dial when they call into 

the system to enter the bridge.  Each caller enters an access code to join the correct 

conference. The participant access codes are created by the moderator.

Each moderator is assigned a unique access code to allow them to create and control their 

conference bridge. By default, participant codes are active for 24 hours, but can be extended to 

1 week or indefinitely. 

Local Extensions/Fax

A local extension can either be an analog extension or an IP extension.

An analog extension is a device (standard phone, cordless phone, fax machine or modem) 

connected to an extension jack on the unit.

Call Redirection & Service Provider Billing Advisory

Use of the routing and blocking and call detail recording features does not imply any guarantee 

whatsoever by regulatory authorities, your telephone service provider(s), Fortinet or its 

distributors and resellers, with regard to the accuracy of these features and that the use of such 

a features may not be considered by a telephone company in any disputes which may arise 

regarding the accuracy of any subscriber's telephone account.
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An IP extension is an IP phone connected through a network to a system. An internal IP 

extension is a phone connected on the same LAN as the system. An external IP extension is a 

phone connected outside the LAN. See “Adding IP phones” on page 55 for more information.

The Local Extensions/Fax page allows you to set up a local extension.

Local Extensions/Fax page

The Local Extensions/Fax page shows the extension type, user name, make and model, prompt 

language, user privileges, extension details, programmable keys, direct line access, voicemail, 

hotline, caller ID, and call cascade for each local extension.

In the list of extensions on the left side of the page, manually configured IP extensions will be 

shown in bold, and unregistered or disconnected extensions will be shown in red.

Before you begin, decide the number of digits you want your system to use for extensions, ring 

groups, mailboxes and speed dials. You can use 3, 4 or 5-digit numbers. The default is 3. If you 

want to use 4 or 5-digit numbers, you must change the System Numbering Plan setting on the 

Administration page, or your extension numbers will be rejected by the system.

Numbers available per plan:

  3-digit numbers: 100 to 899

  4-digit numbers: 1000 to 8999

  5-digit numbers: 10000 to 89999

Extension tab

1. Select the Local Extensions/Fax page.

2. Click Add.
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3. In the Add User / Extension dialog box, select the Extension type. Choices are Regular 

phone or fax and IP Extension. Regular phone or fax allows you to set up an analog 

extension.

4. In a multi-unit system, select the unit the extension will be associated with. This unit will 

hold the voicemail for the extension. For analog extensions, this must be the unit that the 

analog phone is plugged into.

5. Analog extensions: select the jack the analog phone is plugged into. Click Next. 

6. Enter the user’s First name and Last name. The names are used in the dial-by-name 

directory and caller ID. 

7. Enter the Extension number.

8. Select the Manufacturer.

We strongly recommend you only use supported IP phones. However, if you have an 

unsupported IP phone, you can select Other. Other IP phones that support the G.711 codec 

(µ-law or A-law) may work with the system, but some features may not work. As the system 

cannot enable special features, or customization of these IP phones, further configuration 

will be limited to the programmable options on the phone itself.

9. Select the phone Model. Supported models and manufacturers vary by market. 

10. If you’re setting up an IP phone, enter the MAC address of the phone. You can click Select 

to choose from addresses of phones connected to the system, or enter the MAC address 

manually. The MAC address is printed on the bottom of the phone and on the phone’s 

shipping box.

11. Click Finish.

The information you configured now appears in the Extension tab, and you can edit it directly 

there if you need to make changes. Select any extension in the menu under the Add and 
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Remove buttons to access the configuration details. In the Extension tab, assign a User 

Privilege for each extension. The default is 1 - Default.

The Voicemail tab is now visible for each extension. See “Voicemail tab” on page 49.

Regular extension details

If you set Extension type to Regular phone or fax, the Regular Extension Details area is enabled. 

You can edit the unit number and jack to which the extension is connected.

IP extension details

If you set Extension type to IP extension, the IP Extension Details area is enabled.

Once you save the configuration and reboot the IP phone, the system will configure the IP 

phone. Status will change to Registered, and the IP address of the phone will appear.

If you connected a proprietary IP phone to the LAN and used it to select an extension number, 

the Location and MAC address for that extension will be complete.

1. Set the Location of the phone. Choices are:

• Internal — An internal IP extension is located within the office, and is connected to the 

same LAN as the unit.

• External — An external IP extension is located outside the office, and is connected to the 

unit via Internet.

• Both — The phone can be used as an internal or external IP extension. This is available 

for the Counterpath eyeBeam softphone only. 

2. If you set Location to External, select the Time zone that matches the location of the 

IP phone.

3. Use one of the procedures below to identify the IP phone, depending on the make 

and model.

Configuring IP phone keys

1. If the Configure Keys button is visible and active, you can click it to set up the actions of 

your phone’s keys. See “About programmable function keys” on page 58 for further 

instructions.

2. Choose File > Save. The system will create a configuration file that the phone will download 

when the phone is restarted.

Using an external IP extension to call an emergency service number will not send the correct 

address to the emergency operator. We strongly recommend that you apply a warning label to 

any external IP extension stating:

If an emergency call is made from this phone, you must provide your address to the 

emergency operator.
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Setting handset ID for 850i or 860i phones

1. Select the Handset ID for the extension. Use the handset name on the handset screen.

2. Choose File > Save. The system will create a configuration file that the phone will download 

when the phone is restarted.

Counterpath or other IP phone

1. Enter the Username and Password. The default settings are user[extension number] and 

pass[extension number]. These are used to manage calls between systems and the IP 

extension and must match the username and password of the IP phone. Change only 

if required.

About call cascades

The Call Handling area allows you to set up call cascades for a local extension. A call cascade 

routes a call to an alternative or a series of alternatives when the target extension doesn't 

answer. You can set up different call cascades for Mode 1 and Mode 2. 

For example, if a call reaches your desk when you’re away, it can be sent to another local 

extension. If that extension isn’t answered, the call can be routed to your cell phone. If you don’t 

answer your cell phone, the call can go to your voicemail.

Note that the system can be configured to ignore the call cascade for an unanswered intercom 

call, or for an unanswered transferred call. See “Transfer Preferences” on page 132.

Setting up call handling

Busy call cascade

The busy call cascade is used when the extension is busy.

1. Select the Mode 1 tab or the Mode 2 tab.

2. Select the Busy tab.

3. Set up the first alternative.

a. Select the action in the If extension is busy list. Choices are:
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• go to voicemail — Transfers the call to the selected voicemail.

• go to local extension — Attempts to transfer the call to the selected local extension.

• go to remote extension — Attempts to transfer the call to the selected 

remote extension.

• go to ring group — Attempts to transfer the call to the selected ring group.

• play announcement — Plays the selected announcement.

• invoke call waiting — Notifies the user that a caller is attempting to reach them.

• go to auto attendant — Routes the call to the selected auto attendant.

• queue at extension — Transfers the call to the local extension’s call queue.

• play busy tone — Plays a busy tone in the caller’s phone.

• hang up — Disconnects the telephone line.

b. Select the resource, if applicable.

c. If you selected queue at extension, the caller will hear a prompt each time the reminder 

timer expires. The prompt says “If you wish to continue holding, please remain on the 

line. To leave a voicemail message, press 1”. You can set the duration of the reminder 

timer, to control how often the caller hears the prompt. See “Call Reminders” on 

page 135.

i. Choose Options > Call Reminders. The Call Reminder Timers window appears.

ii. Set the Queue options reminder timer.

4. If permitted, set up the second alternative.

a. Set the If busy or not answered after list to the number of rings to try the first alternative. 

Choices range from 1 to 9.

b. Set the action.

c. Select the resource, if applicable.

5. If permitted, set up the third alternative.

a. Set the If busy or not answered list to the number of rings to try the second alternative. 

Choices range from 1 to 9.

b. Set the action. Choices are:

• go to voicemail

• go to auto attendant

• play announcement

• hang up

c. Select the resource, if applicable.

No answer call cascade

The no answer call cascade is used when the extension is not answered.

1. Select the Mode 1 tab or the Mode 2 tab.
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2. Select the No Answer tab.

3. Set up the first alternative.

a. Set the If this extension is not answered after list to the number of rings to try the 

extension. Choices range from 1 to 9.

b. Select the action. Choices are:

• go to voicemail

• go to local extension

• go to remote extension

• go to ring group

• play announcement

• go to auto attendant

• go to extended ringing

• hang up

c. Select the resource, if applicable.

4. If permitted, set up the second alternative.

a. Set the If busy or not answered after list to the number of rings to try the first alternative. 

Choices range from 1 to 9.

b. Set the action. Choices are:

• go to voicemail

• go to local extension

• go to remote extension

• go to ring group 

• play announcement 

• go to auto attendant

• hang up

c. Select the resource, if applicable.

5. If permitted, set up the third alternative.

a. Set the If busy or not answered after list to the number of rings to try the second 

alternative. Choices range from 1 to 9.

b. Set the action. Choices are:

• go to voicemail

• go to auto attendant

• play announcement

• hang up

c. Select the resource, if applicable.
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Answered call cascade

The answered call cascade is used to enable call screening, typically for cell phone remote 

extensions.

1. Select the Mode 1 tab or the Mode 2 tab.

2. Select the Answered tab.

3. Set the When a call is answered list. Choices are:

• stay connected — Transfers the call to the extension. This option disables the remaining 

controls in the tab. This is the default.

• play caller’s name first — Performs a screened transfer. The caller is prompted to say his 

or her name. When the user answers the phone, the system plays the caller’s name, and 

prompts the user to accept the call. If the user accepts the call by pressing #, it gets 

connected. If the user rejects the call by pressing * or hanging up, the call is routed to 

the first alternative.

4. Set up the first alternative.

a. Set the If a call is rejected from this extension action. 

b. Select the resource, if applicable.

5. If permitted, set up the second alternative.

a. Set the If busy or not answered after list to the number of rings to try the first alternative. 

Choices range from 1 to 9.

b. Set the action.

c. Select the resource, if applicable.

6. If permitted, set up the third alternative.

a. Follow the same steps as the second alternative. 

Do not disturb cascade

The do not disturb call cascade is used when the extension is in Do Not Disturb mode.

1. Select the Mode 1 tab or the Mode 2 tab.

2. Select the Do Not Disturb tab.

3. Set up the first alternative.
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a. Set the If do not disturb is on for this extension list. Choices are:

• go to voicemail

• go to local extension

• go to remote extension

• go to ring group

• play announcement

• go to auto attendant

• hang up

b. Select the resource, if applicable.

4. If permitted, set up the second alternative.

a. Set the If busy or not answered after list to the number of rings to try the first alternative. 

Choices range from 1 to 9.

b. Set the action. 

c. Select the resource, if applicable.

5. If permitted, set up the third alternative.

a. Set the If busy or not answered after list to the number of rings to try the second 

alternative. Choices range from 1 to 9.

b. Set the action.

c. Select the resource, if applicable.

Setting do not disturb mode

The user can toggle Do Not Disturb mode by dialing *62 on their local extension.

The administrator can enable or disable Do Not Disturb mode for a local extension by phone.

1. Pick up a local extension, or remotely call the system.

2. Enter command mode by pressing # on an analog extension phone, or *55# on an IP phone 

(other brands may use *55 Send or *55 Dial).

3. Enter the system password, followed by #.

4. Enter one of the following commands:

• #60 [Local extension] # to disable Do Not Disturb mode for the local extension.

• #61 [Local extension] # to enable Do Not Disturb mode for the local extension.

5. Press * to exit command mode.

Ignoring call cascades for unanswered intercom calls

An intercom call is an internal call from a local extension to another local extension, remote 

extension or ring group. If the call is unanswered, the call follows that extension’s call cascade 

by default. However you can configure the system to ignore call cascades for unanswered 

intercom calls. See “Internal Calls” on page 138.

1. Choose Options > Internal Calls. The Intercom Calls Options window appears.
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2. To have the system ignore call cascades for unanswered intercom calls, clear the Intercom 

calls follow cascade settings checkbox.

• If the extension is busy, the caller will hear a busy tone.

• If the extension is not answered, it will continue to ring.

• If a local extension has call screening enabled, the caller won’t be prompted for their 

name. However, if a remote extension or ring group has call screening enabled, call 

screening will occur. If the call is rejected, the system will follow the call cascade.

• If a local extension has do not disturb mode enabled, it won’t ring, and the caller will 

hear “I’m sorry, that extension is unavailable at this time. Do not disturb on. Please try 

again later”. If all the local extensions in a ring group have do not disturb mode enabled, 

the caller will hear a busy tone.

Ignoring call cascades for calls transferred from local extensions

A user at a local extension can transfer a call to another local extension, remote extension or 

ring group. If the call is unanswered, the call follows that extension’s call cascade by default. 

However you can configure the local extensions, remote extensions and/or ring groups to 

ignore their call cascades for calls that are transferred from a local extension but unanswered. In 

this case, the system will ring back the local extension that transferred the call, reconnecting the 

user with the caller they transferred.

1. Choose Options > Transfer Preferences. The Transfer Preferences window appears.

2. Select the appropriate tab.

• To configure call handling for calls transferred to local extensions, select the To Local 

Extension tab (see “To local extension tab” on page 133).

• To configure call handling for calls transferred to remote extensions, select the To 

Remote Extension tab (see “To remote extension tab” on page 133).

• To configure call handling for calls transferred to ring groups, select the To Ring Group 

tab (see “To ring group tab” on page 134).

3. Select the call handling setup for calls transferred from a local extension but unanswered:

• To have the system ring back the local extension that transferred the call, select Ring 

back the extension that transferred the call.

• To use the Busy call cascade, select Perform the Busy action.

• To use the No Answer call cascade, select Perform the No Answer action.

Additional Settings

The Additional Settings tab enables you to set up or customize access to lines or hunt groups 

for outbound calls, designate the extension as a hotline and select CallerID display options.
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Prompt Language

In the Additional Settings tab, you can select the language for prompts heard by the user of the 

extension in the System prompt language list.

Direct line access

Under the Additional Settings tab, the Direct Line Access area allows you to select the hunt 

group that the local extension will use automatically. When an analog phone goes off-hook or a 

number is dialed on an IP phone, the system will automatically find an available line within that 

hunt group.

Example: You have a fax machine connected to the local extension and don‘t want to reprogram 

the speed dial numbers with hunt group numbers. Enable direct line access and select the hunt 

group. As soon as the fax goes off-hook, it finds an available line within the line hunt group.

1. Under the Additional Settings tab, select the Use direct line access on checkbox. The 

window enables the list of line hunt groups.

2. Select the hunt group. 

Hotline access

The Hotline Access area allows you to select the resource that the extension will connect to. 

This restricts the extension to one special task, and you cannot use the extension for any 

other purpose.

An analog phone or a corded FortiFone IP phone will automatically connect to the resource 

when you lift the handset or press the speaker or headset button. Other IP phones do not 

support hotline access.

1. Click the Additional Settings tab. 

When using direct line access, you hear the telephone company dial tone when you pick up the 

handset. You do not hear the internal dial tone. The following features are only available from 

the internal dial tone:

• Intercom calls

• System speed dial numbers

• Calling the receptionist

• Attaching an account code

• Intercom paging

• Group paging

• Overhead paging

• Hunt groups

• Stutter dial tone for new voicemail

• Voicemail retrieval/access

• Entering command mode

• Call pickup 

• Retrieving a parked call

• Do Not Disturb functions

To obtain an internal dial tone on an analog extension that is set for direct line access, pick up 

the handset, and then press Flash or Recall. On an IP extension, press **, and then dial the 

number or function.
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2. Select the action in the Connect to the following resource list. Choices are:

• None Selected — Does not automatically connect to a resource.

• go to voicemail — Connects to the selected voicemail.

• go to local extension — Connects to the selected local extension.

• go to remote extension — Connects to the selected remote extension.

• go to ring group — Connects to the selected ring group.

• go to auto attendant — Connects to the selected auto attendant.

3. Select the resource. Depending on the action, resources are voice mailboxes, extensions, 

or auto attendants.

Caller ID settings

The Caller ID Settings area allows you to select the phone number that will appear on the other 

phone when the local extension is used to make an outbound call on a PRI trunk or VoIP trunk.

1. Click the Additional Settings tab.

2. Set each Caller ID to be used for each service.

Choices include Default number, and the numbers set up in the PRI Numbers page or VoIP 

Numbers page. If Default number is selected, the phone number associated with the line is 

used. This selection makes the most sense if all your numbers have been configured to handle 

all inbound calls the same way.

See “System VoIP options” on page 32 to select the name that will appear on the other phone 

for VoIP calls.

Voicemail tab

The Voicemail tab allows you to activate the voice mailbox or announcement, load the greeting, 

set the action to perform if the caller dials 0 (9 in some regions), and set up voicemail 

notification.

By default, each local extension mailbox is activated.

The recording time for internal music on hold, voicemail, and the auto attendants is shared on 

the unit. 

Note that the system allows up to 99 voicemail messages per mailbox. Once a mailbox fills up, 

callers won’t be able to leave voicemail messages for that user. Therefore users should delete 

voicemail messages before the mailbox fills up.

1. Select the Local Extensions/Fax page.
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2. Select the Voicemail tab.

Note: Depending on the region, an operator may be dialed using 9 or 0.

3. If necessary, select the Activate Voice mailbox checkbox.

Mailbox greeting

The Mailbox Greeting area allows you to load a greeting, and configure the voice mailbox as a 

mailbox or announcement. Note that you can also record a greeting using a local extension 

connected to the unit.

The greeting should tell the caller to dial 0 (9 in some regions) to perform the action selected in 

“Caller options”, if you will configure these options.

1. To record a greeting:

a. Pick up a local extension connected to the unit.

b. Press ** <extension number>, and then follow the prompts to record a greeting.

2. To load a greeting:

a. Obtain an 8 kHz, 8 bit, Mono, u-Law .wav file that contains the greeting. The maximum 

file size is 5 minutes.

b. Click Load Greeting. The Select Wav File window appears.

c. Click Browse to select a .wav file. Click Load to load the .wav file into the system. Play 

and Stop buttons are also provided, if you prefer to listen to the file before loading it.

3. To configure the voice mailbox as a mailbox, leave the Play announcement only checkbox 

cleared. The unit activates the greeting and the mailbox, and enables all the controls on the 

page. The caller will hear a greeting, and will be able to leave a message in the mailbox.
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4. To configure the voice mailbox as an announcement, select the Play announcement only 

checkbox. The unit activates the greeting, disables the ability to leave a message, and 

disables the Notification Settings area. The caller will hear a greeting, but will not be able to 

leave a message.

Caller options

The Caller Options area sets the action to perform if the caller dials 0 (9 in some regions) during 

the voicemail greeting. You can set up different actions for Mode 1 and Mode 2.

1. For each mode, select the action to perform if a caller dials 0 (9 in some regions). 

Choices are:

• go to auto attendant

• go to local extension

• go to remote extension

• go to ring group

• go to voicemail

• play announcement

• dial-by-name directory

• perform no action

2. Depending on the action, enter the resource.

Notification options

The Notification Options area allows you to set up voicemail notification, which tells the user if a 

caller leaves a message. The system can:

• Notify up to four users by e-mail, with the voicemail message included as an attachment.

• Notify a user by phone and/or pager.

• Activate the message waiting light and stutter dial tone on one or more local extensions.

• Perform voicemail screening by routing audio to the PA jack.

Setting up notification by e-mail 

Note that e-mail notifications might be routed to the user’s junk or spam folder. Advise each 

user to set up their e-mail accounts to allow e-mail notifications to go to their inboxes.

1. Set up the e-mail addresses. See “Email Service” on page 19.

2. Select the Email Notification tab.

3. Select the Enable email notification checkbox.
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4. Click Edit. The Select Email Addresses window appears.

5. Select up to four e-mail addresses.

Setting up notification by phone

1. Select the Cell/Pager Notification tab.

2. Select the Enable remote phone notification checkbox.

3. Enter the Phone number. Enter the number as you would normally dial it (i.e. without the 

hunt group number). You can enter digits 0–9, space, dash, comma, # and *. A comma 

pauses dialing for two seconds.

4. Click Notification Settings. The Notification Settings window appears.
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5. Select the notification setting. Choices are:

• Select the first option to have the system play the notification message once, when the 

phone is answered. It will then consider notification to be successful. Note that if there is 

any answer other than a busy tone, (e.g. voicemail, “subscriber not available” message, 

etc.) It will consider notification to be successful.

• Select the second option to have the system repeat notification until the user either dials 

* to skip the message, or dials # to play the message. It will only consider notification to 

be successful once the user acknowledges notification by dialing a key. This is useful for 

cell phones where the telephone company plays a “subscriber not available” message 

instead of a busy tone.

Setting up notification by pager

1. Select the Cell/Pager Notification tab.

2. Select the Enable pager notification checkbox.

3. Enter the Pager number. Enter the number as you would normally dial it (i.e. without the 

hunt group number). You can enter digits 0–9, space, dash, comma, # and *. A comma 

pauses dialing for two seconds.

4. Enter the Numeric message that will appear on the user’s pager.

Setting up the notification options

1. Click Configure Notification Options. The Notification Settings window appears.

2. Select the hunt group the system will use to phone or page the user.

3. Select the number of rings before aborting attempt, ranging from 1 ring to 9 rings.

4. Select the number of attempts the system should make, ranging from once to 10 times.

5. Select the interval between attempts, ranging from 5 minutes to 60 minutes.

6. Select the modes when the system will perform notification. Choices include Mode 1, 

Mode 2 and All Modes.

Setting up message waiting light activation

If a local extension has a new message in its voice mailbox, the system activates notification on 

that extension, by default. The user hears a stutter dial tone when they pick up the handset (not 

applicable to the 850i or 860i phone models). If the extension supports an FSK message waiting 

indicator (not applicable to IP phones), the message waiting light flashes. Some phone models 

support a message waiting counter. The display on the extension shows the number of new 

messages stored in the mailbox(es) associated with that extension.

You can also have the system activate notification on a local extension if a message is received 

in any other local extension, remote extension, or general mailbox.
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1. Select the Message Waiting Light tab.

2. Click the Edit button. The Message Waiting Indication window appears. 

3. Select the extensions.

Voicemail screening

The system can be configured to perform voicemail screening in addition to overhead paging. In 

this case it will route audio to the PA jack when a caller leaves a voicemail message or a user 

accesses a voice mailbox. See “Paging Options” on page 132

1. Choose Options > Paging. The Paging Options window appears. The PA output option is 

set to PA Announcements by default, which allows overhead paging but not voicemail 

screening.

2. To enable voicemail screening, select Voicemail screening. The system will continue to 

allow overhead paging, but will also perform voicemail screening.

If a user has dialed *80 to route music on hold through the PA jack, voicemail screening will not 

interrupt music on hold.
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Adding IP phones

This section describes how to configure an IP phone as a local extension. An IP phone can be 

internal (located in the office) or external (located outside the office).

We recommend our IP phones and supported third-party IP phones for ease of configuration. 

The system currently supports the following third-party IP phones:

• Polycom IP 301, IP 320, IP 330, IP 430, IP 501, IP 550, IP 601 and IP 650. See “Adding 

Polycom IP Phones” on page 62.

• Grandstream GXP2000 and GXP2020. See “Adding Grandstream IP phones” on page 65.

• Counterpath eyeBeam softphone. See “Adding Counterpath IP phones” on page 68.

Overview

For each supported IP phone, this guide describes how to:

• Add the IP phone to the system configuration.

• Configure the router, if setting up an external IP extension.

• Connect the IP phone to the network.

• Check and update the IP phone firmware version, if required.

• Program the IP phone.

Refer to “Adding Other IP Phones” on page 72 for configuration information of non-supported 

IP phones.

Adding FortiFone IP phones

Connecting the IP phone to the network

1. Connect a network cable between the LAN port on the phone and your network (i.e. router 

or LAN connection) and then connect power to the phone. Refer to the phone’s quickstart 

guide for specific instructions.

2. If the phone is connected to the same network as the system, and an extension has been 

configured with the phone’s MAC address, the system will automatically register and 

configure the phone. When complete, the phone will display the extension name and 

extension number.

If the phone is connected to the network and no extension has been configured with the 

phone’s MAC address, the phone will bootup with the model number showing in the 

display.
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Adding the extension to the system

1. Launch the Management software.

2. Select the Local Extensions/Fax page.

3. Click the Add button. The Add User / Extension window appears.

4. Set the Extension type to IP Extension.

5. In a multi-unit system, select the unit the extension will be associated with. This unit will 

hold the voicemail for the extension. Click Next.

6. Enter the user’s First Name and Last Name. The names are used for caller ID and the 

dial-by-name directory.

7. Assign an Extension number.

8. If necessary, select the Manufacturer, and then select the Model.

9. Enter the MAC address of the phone:

• You can select the phone/base MAC Address from a list of automatically-detected 

phones connected to your LAN. To use this method:
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i. Click the Select button. A MAC Selection window appears and lists IP phones of the 

selected type. 

ii. Select the MAC address of the IP phone associated to the extension, and then click 

Select.

• You can enter the phone/base MAC Address manually. This is the required method if you 

are setting up an external IP extension. The MAC Address is a 12-digit alphanumeric 

string located in the barcode on the bottom of the phone and the box the phone came 

in.

Click Finish.

10. For the 850i/860i/870i, select the Handset ID for the extension.

11. In the Extension tab, select the language for prompts heard by the user of the extension in 

the System Prompt Language list. Setting the prompt language will also change the 

language for text displayed on the phone itself.

12. Choose File > Save. The system will create a configuration file that the phone will download 

when the phone is restarted.

IP extension details area

1. Set the Location:

• Internal — The phone is an internal IP extension located within the office, and is 

connected to the same LAN as the unit.

• External — The phone is an external IP extension located outside the office, and is 

connected to the unit over the internet. See the phone’s user guide for further details.

2. If you set Location to External, select the Time Zone that matches the location of the IP 

phone.

Calls to an emergency service number using an external IP extension will not send the correct 

address to the emergency operator. We strongly recommend that you apply a warning label to 

any external IP phone:

If an emergency call is made from this phone, you must provide your address to the 

emergency operator.
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About programmable function keys

Programmable functions keys allow the user to access features, and to monitor and engage 

lines, extensions and queued calls (i.e. line appearance).

The keys cannot be programmed if the extension has hotline access enabled. In this case, the 

phone will automatically connect the preconfigured resource (external number, extension etc.)

*with two FF-50E expansion modules attached

Programming function keys

1. Click Configure Keys.

2. For each key, select the Function and the Resource (if applicable). The function keys can be 

assigned for Line Appearance, Extension Appearance, Queue Appearance, Voicemail, Do 

Not Disturb (DND), Speed Dial, Park, Unpark, Call Pickup (any or specific extension), Group 

Page, Overhead Page, Phone Book configuration, Call Recording (360i/460i/560i only) or 

User Defined (phone). For further details, see “Phone programmable key functions” on 

page 60.

3. Optionally, you can apply predefined key assignments from a template file using the Open 

Template button. See “Using a key assignment template” on page 59.

If necessary, use the Default button to restore the keys to their default settings.

4. Use the Print button to print a label showing the key configuration. Cut out the printed label 

and insert it in the phone next to the key lights.

Model Programmable function keys

FON-260i 4

FON-350i/360i 6

FON-450i/460i 10 (34)*

FON-550i/560i 22 (46)*
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5. Your key assignments can be saved as a template for programming additional phones. See 

“Saving a key assignment template” on page 59.

Saving a key assignment template

You can use the template file as a starting point for the key assignments for another extension. 

After setting up the key assignments:

1. Click Save Template As to save the key assignments to a template file. The Save Template 

As window appears.

2. Enter the filename of the template file, and then click Save.

Using a key assignment template

1. To display the key assignments from a template file, click Open Template. The Open 

Template window appears.

2. Select the template file, and then click Open Template.

Further configuration

The steps above will configure your IP phone and will enable the programmable keys. Click the 

Local Extension/Fax Help  icons for instructions on configuring direct line access, Caller ID 

settings (VoIP only), call handling, and voicemail. 

For phone-specific configuration, refer to your phone user guide.

Contact your reseller or Customer Support if you require further assistance with special ports or 

network settings.
Configuration Page 59 FortiVoice v7.31 User Guide

http://www.fortinet.com/


Phone programmable key functions

Some TalkSwitch/FortiFone IP phone models have programmable keys. The function and 

associated resources are assigned using Management software in the Local Extensions/Fax > 

IP Extension Details > Configure Keys page. Supported functions for a phone model typically 

include most of the items listed below.

• Line appearance — Select a telephone line or VoIP number as the resource. The 

corresponding button or softkey will display the status of the line, and allow you to make 

calls with a single press of the button or softkey.

For phones equipped with button lights, the button will light up when the line is in use, flash 

if the line is ringing, or be off when the line is available.

For phones with softkeys, a status icon and line ID will be displayed beside the softkey. 

The display will show an off-hook icon when the line is in use, show a ringing icon when the 

line is ringing, and show an on-hook icon when the line is available.

• Extension appearance — Select a local extension as the resource. The corresponding button 

or softkey will display the status of the selected extension, and allow you to call the 

extension with a single press of the button or softkey.

For phones equipped with button lights, the button will light up when the selected extension 

is in use, flash if the extension is ringing, or be off when the extension is available.

For phones with softkeys, a status icon and extension call ID will be displayed beside the 

softkey. The display will show an off-hook icon when the selected extension is in use, show 

a ringing icon when the extension is ringing, and show an on-hook icon when the extension 

is available. The extension call ID is also be displayed.

• Queue appearance — Select a local extension as the resource. The corresponding button or 

softkey will indicate whether calls are queued at the selected extension, and allow you to 

pick up the oldest queued call with a single press of the button or softkey.

For phones equipped with button lights, the button will flash if calls are queued for the 

extension, or be off when there are no queued calls.

For phones with softkeys, a status icon, extension number and “Q” will be displayed beside 

the softkey. The display will show a ringing icon if calls are queued for the extension, or an 

on-hook icon when there are no queued calls. 

• Voicemail — Do not select a resource. Press the button or softkey to access the voice 

mailbox of the local extension. Lights or icons are not used for voicemail keys. Note: You can 

also access Voicemail by pressing **#.

• DND — Do not select a resource. Press the button or softkey to toggle Do Not Disturb mode 

on or off. Lights or icons are not used for DND keys. Note: You can also toggle DND mode by 

pressing *62#.

• Park — Do not select a resource. Press the button or softkey to put the call on hold, in the 

next available park orbit. The system will respond with the park orbit number (500 to 509). 

Lights or icons are not used for Park keys. Note: You can also Park a call by pressing  

*510# on a 350i, or  *510# on a 450i or 550i.

• Un-park — Do not select a resource. Press the button or softkey, select the park orbit 

number (500 to 509), then press Unpark to retrieve the call. Softkey displays will show the 

parked call ID beside the orbit number. Lights or icons are not used for Unpark keys. Note: 

You can also Unpark a call by lifting the handset, pressing **, dialing the park orbit number, 

then pressing #.

• Pickup any — Do not select a resource. Press the button or softkey to answer a call from an 

outside number ringing any extension. Lights or icons are not used for Pickup keys. Note: 

You can also pick up a call by pressing *9#.
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• Pickup ext — Do not select a resource. Press the button or softkey, dial an extension, then 

dial # (or softkey again) to answer a call from an outside number or extension ringing the 

selected extension. Lights or icons are not used for Pickup keys. Note: You can also pick up 

a call at a selected extension by pressing *7, dialing the extension, then pressing #.

• Intercom — Do not select a resource. Press the button or softkey, dial an extension, then 

press # to page the extension in Intercom mode. The intercom page function can only page 

proprietary phones. Lights or icons are not used for Page keys. Note: You can also page a 

proprietary phone by pressing *84, dialing the extension, then pressing #, or the Dial key or 

softkey. 

• Overhead page — Do not select a resource. Press the button or softkey to connect to an 

attached external PA system. Lights or icons are not used for Page keys. Note: You can also 

page the external PA system by pressing *0#. 

• Queue (show list) — Do not select a resource. Press the Queue softkey, select a queued call, 

then press Retrieve to connect to the selected call. This function is only available when 

programmed as a function key on supported phone models. 

• Phone book — Select the phone book record two-digit speed dial number as the resource. 

Press the button or softkey to place a call using the contact information from the associated 

phone book record. When the button is pressed, it will light up for the duration of the call. 

This function is available on the 350i, 450i and 550i models. 

• User Defined (phone) — The button or softkey function is assigned using the phone's 

configuration options, and is not assigned using Management software.

• None — The button or softkey is not programmed.

• System speed dial — Select the desired resource from speed dials configured on the System 

Speed Dials page. Press the button or softkey to call the resource.

• Group page — Select Ring/Page group. Press the button or softkey to page the phones in 

the group. Not all phones can receive pages.

• Call Recording (360i/460i/560i only) — Select Call Recording from the pulldown menu. Press 

the button to start call recording during a call. The light will flash and a tone will be played 

when call recording is started. Press the button to stop recording. Recorded calls will be 

saved to the extension’s voice mailbox.
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Adding Polycom IP Phones

Adding the extension to the system

1. Launch the Management software.

2. Select the Local Extension/Fax page.

3.  Click the Add button. The Add User / Extension window appears. 

4. Set the Extension type to IP Extension.

5. In a multi-unit system, select the unit the extension will be associated with. This unit will 

hold the voicemail for the extension. Click Next.

6. Enter the user’s First Name and Last Name. The names are used for caller ID and the 

dial-by-name directory. 

7. Assign an Extension number.

8. Select the Manufacturer, and then select the Model.

9. Enter the MAC address of the phone. The MAC Address is a 12-digit alphanumeric string 

located in the barcode on the bottom of the phone and the box the phone came in.

10. Click Finish.
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11. In the Extension tab, select the language for prompts heard by the user of the extension in 

the System Prompt Language list. Setting the prompt language will also change the 

language for text displayed on the phone itself.

12. Choose File > Save. The system will create a configuration file that the phone will download 

when the phone is restarted.

Click the Additional Settings button to set up:

• Direct line access (see “Direct line access” on page 48)

• Caller ID settings (see “Caller ID settings” on page 49)

IP extension details area

1. Set the Location. Choices are:

• Internal — The phone is an internal IP extension located within the office, and is 

connected to the same LAN as the unit.

• External — The phone is an external IP extension located outside the office, and is 

connected to the unit over the internet. 

2. If you are setting up an external IP extension, select the Time Zone of the IP phone.

3. See “Setting up call handling” on page 42 and “Voicemail tab” on page 49 for instructions 

on configuring call handling and voicemail.

4. Choose File > Save. The system will create a configuration file that the phone will download 

when the phone is restarted.

Configuring the system for external IP extensions

If you are setting up an external IP extension:

1. Ensure your system is connected to a network. See “Connecting to a network” on 

page 176.

2. Ensure that you have set up a public IP address for the system. See “Public IP address” on 

page 14.

3. Ensure the router is configured at the location. There should be no need to make any 

adjustments to the firewall at the remote location. See “Firewall settings” on page 14.

4. All VoIP lines are shared by default. You can also reserve VoIP lines for external IP 

extensions. See “Line reservation” on page 32.

5. External IP extensions will use the preferred codec set in the Extensions > IP Extensions 

window. See “Extensions > IP Extensions” on page 141. The default preferred codec is 

G.729.

Using an external IP extension to call an emergency service number will not send the correct 

address to the emergency operator. We strongly recommend that you apply a warning label to 

any external IP extension stating:

If an emergency call is made from this phone, you must provide your address to the 

emergency operator.
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Connecting the Polycom phone to the network

1. Connect a network cable between your router and the port marked LAN on the back of the 

phone. The PC port on the phone can be used to connect the PC if only one LAN port 

is available.

2. Connect the power adapter to the phone.

Programming the Polycom IP phone

The system requires the IP phone to have the latest firmware version.

The system automatically configures the necessary parameters required for the proper 

operation of the Polycom phone. On the phone:

1. Press the Menu key and select Settings > Advanced.

2. Enter the password, and then press the Enter key. By default this is 456. When the unit 

configures the phone, it changes the password to 23646 (which spells “admin” on the 

telephone keypad).

3. Select Admin Settings > Network Configuration.

4. Select Server Menu and change ServerType to TrivialFTP.

5. Select Server Address and press the Edit key. Press the 1/A/a key. If you are setting up an 

internal IP extension, enter the IP address of the unit acting as local proxy. If you are setting 

up an external IP extension, enter the public IP address or public domain name of the 

system. Use the * key to enter decimal points.

6. Press the Exit button three times. Advanced appears at the top of the menu.

7. Select Restart Phone and confirm by selecting Yes.

The phone connects to the local proxy and downloads the configuration file. If the configuration 

is successful, the phone will reboot and show the time, date and extension number. To ensure 

full functionality, dial another extension and check the audio transmission in both directions.

Configuring the phone to point to the firmware files

Changing the phone Server Address setting to the IP address of the PC with the TFTP program 

and the firmware files enables the update process. On the phone:

1. Press the Menu key and select Settings > Advanced.

2. Enter the password, and then press the Enter key. By default this is 456. When the unit 

configures the phone, it changes the password to 23646 (which spells “admin” on the 

telephone keypad).

3. Select Admin Settings > Network Settings.

4. Select Server Menu and change ServerType to TrivialFTP.

5. Select Server Address and press the Edit key. Press the 1/A/a key and enter the IP address 

of the PC running the TFTP server, using the * key to enter decimal points.

6. Press the Exit button three times. Advanced appears at the top of the menu.

7. Press 3 for Restart Phone and confirm by pressing the Yes button.

8. Once the firmware is updated, reconfigure the phone according to “Programming the 

Polycom IP phone” on page 64. Note that some errors will occur for files not found. These 

are expected and can be ignored.

For more information, refer to the “Troubleshooting” section in your phone user guide.
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Adding Grandstream IP phones

Adding the extension to the system

1. Launch the Management software.

2. Select the Local Extension/Fax page.

3.  Click the Add button. The Add User / Extension window appears. 

4. Set the Extension type to IP Extension.

5. In a multi-unit system, select the unit the extension will be associated with. This unit will 

hold the voicemail for the extension. Click Next.

6. Enter the user’s First Name and Last Name. The names are used for caller ID and the 

dial-by-name directory. 

7. Assign an Extension number.

8. Select the Manufacturer and the Model.

9. Enter the MAC address of the phone. The MAC Address is a 12-digit alphanumeric string 

located in the barcode on the bottom of the phone and the box the phone came in.  

Click Finish.
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10. In the Extension tab, select the language for prompts heard by the user of the extension in 

the System Prompt Language list. Setting the prompt language will also change the 

language for text displayed on the phone itself.

11. Choose File > Save. The system will create a configuration file that the phone will download 

when the phone is restarted.

Click the Additional Settings button to set up:

• Direct line access (see “Direct line access” on page 48)

• Caller ID settings (see “Caller ID settings” on page 49)

IP extension details area

1. Set the Location. Choices are:

• Internal — The phone is an internal IP extension located within the office, and is 

connected to the same LAN as the unit.

• External — The phone is an external IP extension located outside the office, and is 

connected to the unit over the internet.

2. If you are setting up an external IP extension, select the Time Zone of the IP phone.

3. See “Setting up call handling” on page 42 and “Voicemail tab” on page 49 for instructions 

on configuring call handling and voicemail.

4. Choose File > Save. The system will create a configuration file that the phone will download 

when the phone is restarted.

Configuring the system for external IP extensions

If you are setting up an external IP extension:

1. Ensure your system is connected to a network. See “Connecting to a network” on 

page 176.

2. Ensure that you have set up a public IP address for the system. See “Public IP address” on 

page 14.

3. Ensure the router is configured at the system’s location. There should be no need to make 

any adjustments to the firewall at the remote location. See “Firewall settings” on page 14.

4. All VoIP lines are shared by default. You can also reserve VoIP lines for external IP 

extensions. See “Line reservation” on page 32.

5. External IP extensions will use the preferred codec set in the Extensions > IP Extensions 

window. See “Extensions > IP Extensions” on page 141. The default preferred codec is 

G.729.

Using an external IP extension to call an emergency service number will not send the correct 

address to the emergency operator. We strongly recommend that you apply a warning label to 

any external IP extension stating:

If an emergency call is made from this phone, you must provide your address to the 

emergency operator.
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Connecting the Grandstream phone to the network

1. Connect a network cable between your router and the port marked LAN on the back of the 

phone. The PC port on the phone can be used to connect the PC if only one LAN port 

is available.

2. Connect the power adapter to the phone.

3. Once the phone boots up, it will attempt to obtain an IP address from a router DHCP server.

Programming a Grandstream IP phone

1. Note the IP address that appears on the screen of the Grandstream phone.

2. In a web browser, enter the IP address in the Address field.

3. Enter the password. By default this is admin. When the unit configures the phone, it 

changes the password to 23646 (which spells “admin” on the telephone keypad). The 

Grandstream Device Configuration page appears.  

4. On the Grandstream Device Configuration page, click Advanced.  

5. In the section for Firmware Upgrade and Provisioning, set Upgrade Via to TFTP.

6. If you are setting up an internal IP extension, set Config Server Path to the IP address of the 

unit acting as local proxy. If you are setting up an external IP extension, set Config Server 

Path to the public IP address or public domain name of the system.

7. Scroll to the bottom of the page and click the Update button to save the settings.

8. On the following screen, click the Reboot button to apply the settings.

The reboot process will be completed when you see the extension number and IP address 

on the display of the phone. When the phone successfully registers, you will see the filled-in 

Ethernet icon.

9. Test to ensure the phone is configured properly by dialing another local extension.
Configuration Page 67 FortiVoice v7.31 User Guide

http://www.fortinet.com/


Adding Counterpath IP phones

Adding the extension to the system

1. Launch the Management software.

2. Select the Local Extension/Fax page.

3. Click the Add button. The Add User / Extension window appears.

4. Set the Extension type to IP Extension.

5. In a multi-unit system, select the unit the extension will be associated with. This unit will 

hold the voicemail for the extension. Click Next.

6. Enter the user’s First Name and Last Name. The names are used for caller ID and the 

dial-by-name directory.

7. Assign an Extension number.

8. Select the Manufacturer and Model. Click Finish.

9. In the Extension tab, select the language for prompts heard by the user of the extension in 

the System Prompt Language list. Setting the prompt language will also change the 

language for text displayed on the phone itself.

10. Choose File > Save. The system will create a configuration file that the phone will download 

when the phone is restarted.

Click the Additional Settings button to set up:

• Direct line access (see “Direct line access” on page 48)

• Caller ID settings (see “Caller ID settings” on page 49)
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IP extension details area

1. Set the Location. Choices are:

• Internal — The phone is an internal IP extension located within the office, and is 

connected to the same LAN as the unit.

• External — The phone is an external IP extension located outside the office, and is 

connected to the unit over the internet. A VoIP-enabled unit is required.

• Both — The phone can be used as an internal or external IP extension.

2. If the phone can be used as an external IP extension, select the Time Zone of the IP phone.

3. Enter the Username and Password. The default settings are user[extension number] and 

pass[extension number].

4. See “Setting up call handling” on page 42 and “Voicemail tab” on page 49 for instructions 

on configuring call handling and voicemail.

5. Choose File > Save. The system will create a configuration file that the phone will download 

when the phone is restarted.

Configuring the system for external IP extensions

If you are setting up an external IP extension:

1. Ensure your system is connected to a network. See “Connecting to a network” on 

page 176.

2. Ensure that you have set up a public IP address for the system. See “Public IP address” on 

page 14.

3. Ensure the router is configured at the system’s location. There should be no need to make 

any adjustments to the firewall at the remote location. See “Firewall settings” on page 14.

4. All VoIP lines are shared by default. You can also reserve VoIP lines for external IP 

extensions. See “Line reservation” on page 32.

5. External IP extensions will use the preferred codec set in the Extensions > IP Extensions 

window. See “Extensions > IP Extensions” on page 141. The default preferred codec is 

G.729.

Using an external IP extension to call an emergency service number will not send the correct 

address to the emergency operator. We strongly recommend that you apply a warning label to 

any external IP extension stating:

If an emergency call is made from this phone, you must provide your address to the 

emergency operator.
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Configuring a new SIP account

The following procedure describes setting up the eyeBeam software to register on the network 

and to make itself available as a client for sending and receiving calls.

1. Install the eyeBeam software. The SIP Accounts window appears.

2. Click the Add button. The Properties of Account1 window appears.

3. Enter the User Details in the Account tab.

a. Set the Display Name to the name for Caller ID.

b. Set the User name to the local extension number.

c. Set the Password to the Password set up in step 3 of “IP extension details area” on 

page 69.

d. Set the Authorization user name to the Username set up in step 3 of “IP extension details 

area” on page 69.
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e. If setting up an internal IP extension, set Domain to the IP address of the unit acting as 

local proxy. If setting up an external IP extension, set Domain to the public IP address or 

public domain name of the system.

4. Set up the Domain Proxy area in the Account tab.

a. Select the Register with domain and receive incoming calls checkbox.

b. Select the target domain option. 

5. Set up the Voicemail tab.

a. Select Check for voice mail.

b. Enter ** in the Number to dial for checking voicemail field.

c. Enter *<voicemail number> in the Number for sending calls to voicemail field.

6. Click OK to save settings and close the Properties of Account1 window.

7. Click Close to close the SIP Accounts window and enable the newly configured SIP 

account. Once closed, the phone display will show:

• Discovering network…

• Registering…

• Ready, Your username is: [local extension number].

Updating eyeBeam software

The latest release of eyeBeam can be found at www.counterpath.net/eyebeam.html.
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Adding Other IP Phones

Other IP phones with the G.711 codec may work with the system but not all features may be 

supported. We strongly recommend you use only the supported IP phones.

If you connect an unsupported IP phone, select Other as the Manufacturer. As you cannot 

enable features, or customizations of these phones, further configuration will be limited to the 

programmable options on the IP phone itself. 

Refer to the specific IP phone user guide’s details for information on configuration.

External IP extensions

An external IP extension is an IP phone located outside the office that is configured as a 

local extension.

To enable external IP extensions, the feature must be supported on your model of phone 

system. Your system and the external location must both have a high-speed Internet 

connection. 

Configuring the router

If you are setting up an external IP extension, you must ensure the router at the phone system’s 

location is configured.

The Firewall Settings area of the IP Configuration page displays the type of gateway device (i.e. 

the type of router), the IP address of the gateway (i.e. router), and whether router configuration 

is required.

A router is a gateway between the local area network and the Internet. Most routers have a 

firewall to block unwanted data from the Internet. For voice data to reach the system through 

the firewall, port forwarding is required. Port forwarding allows the router to map ports to the IP 

addresses of the units. Valid Internet data will use the ports to go through the firewall to the 

units.

If you are setting up external IP extensions, or a VoIP service that doesn’t handle port 

forwarding, port forwarding is required.

If port forwarding is required, and your router supports uPNP (Universal Plug and Play), ensure 

uPNP is enabled. The system will use uPNP to automatically set up port forwarding, and the 

Automatic (uPNP Enabled) link will appear. No router configuration is required.

Calls to an emergency service number using an external IP extension will not send the correct 

address to the emergency operator. We strongly recommend that you apply a warning label to 

any external IP extension stating:

If an emergency call is made from this phone, you must provide your address to the 

emergency operator
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If port forwarding is required but your router doesn’t support uPNP, or automatic port forwarding 

doesn’t work, the Manual port mapping required link will appear. You will need to configure the 

router as described below.

1. Select the IP Configuration page.

2. If required, click the Manual port mapping required link. The Manual Port Mapping window 

appears. It lists the packet type, labels to aid in port identification, port number, IP address 

and protocol of each required port.

3. To access the router configuration:

a. Click the link containing the IP address of the gateway. The default browser starts, and 

prompts you for the router’s user name and password.

b. Enter the router’s user name and password. The browser shows a setup screen.

c. Navigate to the screen used to set up port forwarding. See your router documentation.

d. Set up port forwarding using the information from the Manual Port Mapping window. 

See your router documentation for instructions on how to map ports. For information on 

configuring routers and mapping ports, visit 

www.portforward.com/english/routers/port_forwarding/routerindex.htm.

4. To check the status of each port through the firewall, click Check Firewall. The Firewall Test 

window appears. 

5. Select the services you want to check.

6. Click Test Ports. The system will check the ports for the selected services.
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Configuring the router manually

If you cannot access the router configuration through the IP Configuration page, configure the 

router manually.

1. Open the router configuration and navigate to the screen used to set up port forwarding. 

See your router documentation.

2. In the Management Software on the IP Configuration page, click the Manual Port Mapping 

Required link.

3. Map the port indicated for SIP (VoIP) signaling.

If required, you can map a different port. Select Troubleshooting > VoIP and enter the port in 

the SIP signalling port field.

Map the rest of the ports to the IP addresses indicated in the Manual Port Mapping window.

If required, you can map different ports. Select Troubleshooting > VoIP.

4. Map ports 9393, 8485 and 8486 (Type: TCP) to the unit acting as local proxy to allow remote 

configuration of the system.

5. If available, enable Quality of Service (QoS) to give voice traffic priority over data.

6. Save the configuration to the router.
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Remote Extensions

A remote extension reaches an external phone by automatically selecting a line from a hunt 

group and dialing the phone number. For example, a remote extension could reach an 

employee’s cell phone or home phone, or a phone at a branch office.

A caller can connect to a remote extension through the auto attendant, or can be transferred to 

a remote extension by a call cascade. A user at a local extension can manually transfer a caller 

to a remote extension, or can dial a remote extension directly. If the remote extension is busy or 

unanswered, the system can route the call using the remote extension’s call cascade.

For example, a caller reaches the auto attendant and dials a local extension. The user is not 

there, so the call is unanswered. The call cascade of the local extension can be configured to 

transfer unanswered calls to a remote extension. The remote extension can be configured to 

dial the user’s cellular phone. This way the user is available outside the office.

There are three ways the system can transfer calls to a remote extension:

• If the telephone line has the Transfer and Clear service available and activated, the system 

can use the transfer and clear feature. When an outside caller is being routed to a remote 

extension, the system directs the telephone company to put the caller on hold. It then uses 

the same line to reach the remote extension. The telephone company connects the outside 

caller to the remote extension, and then frees the line.

• If the telephone line has the 3-Way Calling/Conference service available and activated, the 

system can use the same line connect feature. When an outside caller is being routed to a 

remote extension, the system directs the telephone company to put the caller on hold. It 

then uses the same line to reach the remote extension. The telephone company connects 

the outside caller to the remote extension, but the line to the unit remains occupied until the 

call is complete.

• If the telephone line doesn’t have these services, and an outside caller is being routed to a 

remote extension, the system puts the caller on hold. It then uses a second line to reach the 

remote extension. Both lines remain occupied until the call is complete.

If two lines are used to connect an outside caller to a remote extension, the user at the remote 

extension can:

• Place the call on hold by dialing **.

• Retrieve the call on hold by dialing **.

• Transfer the call by dialing ** + the extension number. The call can be transferred to a local 

extension, remote extension, ring group, or another location in a multi-branch network.

• Transfer the call to a voice mailbox by dialing *** + the voice mailbox number.

The remote extensions can be configured to perform a blind transfer or a screened transfer. 

However a transfer to another remote extension is always a blind transfer to avoid tying up a 

third line.

If the system is configured to perform a blind transfer, it plays “Call transferred. Goodbye.” and 

then hangs up. The call is transferred to the dialed extension and follows its call cascade if busy 

or unanswered.

If the system is configured to perform a screened transfer, the user is connected to the other 

extension and asks whether they want the call. If so, the user dials ** + 4 to complete the 

transfer. If the other person doesn’t want the call, the user dials ** + 5 to cancel the transfer and 

return to the caller.
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The Remote Extensions page allows you to set up a remote extension. 

Remote Extension tab

1. Select the Remote Extensions page.

2. Click the Add button. The Add Remote Extension window appears.

3. Enter the user’s First Name and Last Name. The names are used for caller ID and the 

dial-by-name directory.

4. Assign an Extension number.

5. Enter the Remote Phone Number. Enter the number as you would normally dial it (i.e. 

without the hunt group number). You can enter digits 0–9, space, dash, comma, # and *. A 

comma pauses dialing for two seconds.

6. Select the User Privilege. See “User Privileges” on page 34.

7. Select the hunt group in the Connect Using list. The unit will use a line from this hunt group 

to connect with the remote extension. We recommend the default Hunt Group 9 (or Hunt 

Remote extensions are designed to operate with local major telephone service providers. The 

feature may not function correctly with some telephone and mobile operator’s networks, 

especially for international phone numbers and mobile phones roaming internationally.
Configuration Page 76 FortiVoice v7.31 User Guide

http://www.fortinet.com/


Group 0 in certain regions) unless you have set up a different hunt group for calling remote 

extensions.

8. If you have the 3-Way Calling/Conference service from the telephone company, you can 

select the Use same line connect checkbox. The same line connect feature will direct the 

telephone company to put the caller on hold, and will then use the same line to try the 

remote extension. Because the same line is used, the hunt group setting from Step 7 

is ignored.

If you do not select the Use same line connect checkbox, the unit will put the caller on hold, 

and then use a second line to try the remote extension. The second line will be from the 

hunt group selected in Step 7.

If you enable the same line connect feature, the user at the remote extension will not be 

able to transfer the call to another extension.

When the same line connect feature is in use, the caller hears silence while they are on hold. 

This is because the caller is on hold at the telephone company and not at the unit. If you 

want the caller to hear music on hold while their call is being forwarded to the remote 

extension, do not use the same line connect feature.

The same line connect feature is not compatible with some telephone company lines.

Click OK.

9. In the Remote Extension tab, select the language for prompts heard by the user of the 

extension in the System prompt language list.

10. Set the type of transfer performed by users at remote extensions. This affects transfers to 

local extensions and ring groups. Transfers to other remote extensions are always blind 

transfers. See “To remote extension tab” on page 133. 

a. Choose Options > Transfer Preferences. The Transfer Preferences window appears. 

b. Select the To Remote Extension tab.

• To allow screened transfers, select Allow screening of calls.

• To allow blind transfers, select Perform a blind transfer. This is the default selection.

11. If you have the Transfer and Clear service from the telephone company, you can enable the 

transfer and clear feature. See “To remote extension tab” on page 133.

a. Choose Options > Transfer Preferences. The Transfer Preferences window appears.

b. Select the To Remote Extension tab.

c. To enable the transfer and clear feature, select the Clear telephone line after call 

transferred checkbox.
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About call cascades

See “About call cascades” on page 42.

Setting up call handling

The procedure for setting up a call cascade is similar to that described in Local Extension with 

the differences described below. See “Setting up call handling” on page 42.

• The Remote Extensions page does not have the Do Not Disturb tab.

• The If Extension is busy list in the Busy tab does not have the invoke call waiting or queue at 

extension options.

• The When a call is answered list in the Answered tab has the play accept/reject prompt 

option, in addition to the stay connected and play caller’s name first options.

If play accept/reject prompt is selected, the system will place the caller on hold and will then 

call the remote extension. When the user answers, the system will say: “You have a 

forwarded call. To accept the call, press #. To reject the call, press *.” If the user accepts the 

call, the system will route the call to the remote extension. If the user rejects the call, the 

system will try the next alternative in the remote extension’s call cascade.

In the following circumstances, the system will start by saying “This is call cascade”, instead of 

“This is call forward” or “You have a forwarded call”.

• An extension’s call cascade uses play caller’s name first or play accept/reject prompt, and

• The previous user answered but rejected the call, and

• The extension’s call cascade is now attempting to transfer the call to a remote extension.

This notifies the user that the call was rejected. If the user also rejects the call, it will be routed 

according to the other extension’s call cascade.

Voicemail tab

The procedure for setting up voicemail is identical to that described in Local Extension/Fax. See 

“Voicemail tab” on page 49.

Mailbox greeting

The procedure for setting up the mailbox greeting is identical to that described in Local 

Extension/Fax. See “Mailbox greeting” on page 50.

Caller options

The procedure for setting up the caller options is identical to that described in Local 

Extension/Fax. See “Caller options” on page 51.

Notification settings

The procedure for setting up the notification settings is identical to that described in Local 

Extension/Fax. See “Notification options” on page 51.

When setting the number of rings to wait for a remote extension to connect, it is very important 

to allow enough time for the telephone network to connect to the phone. For example, a call to 

a cell phone or PDA may take 12 seconds (i.e. 2 rings) just to connect.
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Ring and Page Groups

A ring group is a group of local extensions that ring in unison. Local extensions and auto 

attendants can dial a ring group. A page group is a group of extensions that can be paged in 

unison. Page groups require telephones that support group paging.

There are 10 ring/page groups available in the system.

Ring/page groups have two main uses: 

• A ring/page group can reach a group of employees. For example, ring/page group 301 can 

ring the sales group at extensions 111, 112, 113, and 114. When a customer calls the sales 

group, the first available salesperson answers for the group.

• A ring/page group with a different ring pattern can differentiate callers. For example, the 

president doesn’t want to answer calls from the general public, but wants to be alerted when 

important colleagues are on the line. His local extension is 111, but you can configure 

ring/page group 305 to ring his phone with a different ring pattern. The president tells his 

colleagues to reach him at extension 305, which is his private extension. He can tell by the 

ring pattern if the caller dialed extension 111 or 305, and can react accordingly.

1. Select the Ring/Page Groups page.
Configuration Page 79 FortiVoice v7.31 User Guide

http://www.fortinet.com/


2. Click the Add button. The Add Ring/Page Group window appears.

3. Enter the Group name.

4. Assign a Group number.

5. Select a Ring pattern to indicate the call is for the ring group. Click Next.

6. Use the checkboxes to select the local extensions you want to ring in unison. Click Finish.

About call cascades

See “About call cascades” on page 42.

Setting up call handling

The procedure for setting up a call cascade is similar to that described in Local Extension/Fax 

with the differences described below. See “Setting up call handling” on page 42.

• The Ring/Page Groups page does not have the Do Not Disturb tab.

• The If Extension is busy list in the Busy tab does not have the invoke call waiting option.

• The queue at ring group option replaces queue call, and places the call in the ring group’s 

call queue.
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Caller ID options

The Caller ID Options area allows you to set up the system so users will know the caller is trying 

to contact the ring group, and not them personally. 

Two options can be selected or combined:

1. The ring group number can be displayed in front of the caller ID information. For example, if 

John Smith is calling ring group 300, each extension in ring group 300 will display “300 - 

John Smith”.

2. The ring group name can be displayed in place of the caller ID information. For example, if 

John Smith is calling ring group 300, which has the name “Sales”, each extension in ring 

group 300 will display “Sales”. 
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General Voice Mailboxes

General voicemail is not associated with any extension, but is for general use or for a group.

There are 10 general voice mailboxes per unit.

The General Voice Mailboxes page allows you to set up general voicemail.

1. Select the General Voice Mailboxes page.

 

Note: In the Caller Options area, the screen may refer to when a caller presses 9 depending on the region.

2. Click the Add button. The Add General Mailbox window appears. 

3. Enter a Mailbox name.

4. Assign a Number. Click Next.
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5. Use the checkboxes to select the local extensions you want to receive notification of new 

voicemail in this box. Click Finish. 

Mailbox greeting

The procedure for setting up the mailbox greeting is identical to that described in Local 

Extension/Fax. See “Mailbox greeting” on page 50.

Caller options

The procedure for setting up the caller options is identical to that described in Local 

Extension/Fax. See “Caller options” on page 51.

Notification options

The procedure for setting up the notification settings is identical to that described in Local 

Extension/Fax. See “Notification options” on page 51.
Configuration Page 83 FortiVoice v7.31 User Guide

http://www.fortinet.com/


Voicemail Preferences

The Voicemail Preferences page allows you to set up the voice mailbox settings. Any changes 

entered on this window affect all mailboxes. You can also view mailbox data, reset mailboxes, 

delete the password for a mailbox and disable the password requirement for internal mailbox 

access.

1. Select the Voicemail Preferences page.

Mailbox setting

The Mailbox Setting area allows you to set up general mailbox settings.

1. Set the When listening to voicemail messages, always start with list to which message 

should be played first. Choices are Newest message or Oldest message.

2. Set the Notify the pager/remote phone after receiving list to how often the system should 

send notification. Choices are Every new message or Only 1st new message.

3. Set the Maximum recording length for each message list to how long a message can be. 

Choices range from 1 minute to 8 minutes.

4. Select the Automatically remove blank and ‘hang up’ messages checkbox, if you want the 

system to delete blank messages. A blank message occurs when the caller hangs up upon 

reaching your voicemail. If you have the caller ID service from your telephone company and 

choose to keep blank messages, you will be able to check the caller’s number when they 

leave a blank message.

5. If you selected the Automatically remove blank and ‘hang up’ messages checkbox, set the 

Only remove messages shorter than list. The system will automatically remove messages 

that are shorter than the selected length. Choices range from 1 second to 5 seconds.

Mailbox access

Local extensions can access voicemail without a password if you check Disable password 

request here. Passwords will still be required when checking voicemail remotely.
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Voicemail management

The Voicemail Management area has buttons that allow you to view “Mailbox status”, “Reset 

mailboxes”, and “Delete password” for a mailbox.

Mailbox status

The Voicemail Memory Usage window shows how much recording time is taken up by voicemail 

greetings and messages.

The recording time for internal music on hold, voicemail, and the auto attendants is shared on 

the unit. 

Note that the system allows up to 99 voicemail messages per mailbox. Once a mailbox fills up, 

callers won’t be able to leave voicemail messages for that user. Therefore users should delete 

voicemail messages before the mailbox fills up.

1. Click the Voicemail Memory Stats button. The Voicemail Memory Usage window appears.

Alternatively, you can choose Tools > Voicemail Manager > Voicemail Memory Stats.

Unassigned messages

Due to deactivation of mailboxes or errors, the system may display messages currently not 

assigned to a mailbox. Clicking on the Unassigned link will allow you to either download these 

files to your PC as .wav files, or delete them. The files will be stored in a folder in the 

Management software program directory.
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Reset mailboxes

When a user leaves an organization, you can reset the mailbox to return it to its default state for 

the next user. Resetting mailboxes deletes greetings, messages and passwords from the 

selected local extension, remote extension and general mailboxes. You can optionally delete the 

names recorded for the dial-by-name directory from these mailboxes as well. If you need to 

listen to the voicemail messages of an extension before resetting the mailbox, you can 

download them from the Voicemail Memory Usage window (see “Mailbox status” on page 85), 

or disable the password to listen to them from an extension (see “Delete password” on 

page 86).

1. Click Reset Mailboxes. The Reset Mailboxes window appears.

Alternatively, you can choose Tools > Voicemail Manager > Reset Mailboxes.

2. Select one or more mailboxes to delete their greetings, messages and passwords.

3. Select the Delete name from dial-by-name directory checkbox to delete the names 

recorded for the dial-by-name directory from these mailboxes.

4. Click OK. The greetings, messages and passwords (and optionally names for the 

dial-by-name directory) are deleted from the selected mailboxes.

Delete password

If a user has left your organization or is temporarily unavailable, you might need to listen to 

voicemails on a password-protected voice mailbox. You can delete the password from the 

selected local extension, remote extension or general mailbox. Once the password is deleted, 

voicemails can be listened to without a password. Note that anyone can listen to them, from a 

local extension or by calling in to the system, if they know the mailbox number.

The password can be reset by following the normal procedure. See “Retrieving messages and 

accessing a voice mailbox” on page 165.

You can also download messages from a mailbox without disrupting the password protection. 

See “Mailbox status” on page 85.

1. Click Delete Password. The Delete Password window appears. Alternatively, you can 

choose Tools > Voicemail Manager > Delete Mailbox Password. 

2. Select the mailbox to delete its password.
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Voicemail Broadcast

Voicemail broadcast distributes a recorded message to a group of voice mailboxes. You can set 

up to ten voicemail broadcast groups system-wide.

Add Broadcast Group

1. Open the Voicemail Broadcast page.

2. Click Add.

3. Enter a name for the group.

4. Assign a number for the group. Click Next.

5. Check the boxes next to the extensions you want to include in the group.

6. Click Finish.

You can set a password for the broadcast group by dialing ** + the group number from a local 

extension and following the prompts. The extensions in the group can also be added and 

deleted in the same way.
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System Speed Dials

System speed dials allow the user to quickly dial an outside phone number from any local 

extension by dialing a speed dial number. Because the speed dial numbers are maintained 

within the system, they don’t need to be programmed into each individual phone. If a new client 

is added or an existing client’s phone number changes, you can add or modify the speed dial 

number, and all users will have immediate access to the new phone number.

You assign system speed dials a 3, 4 or 5-digit number, based on the numbering plan you have 

specified for your system. See “System numbering plan” on page 7 for more information.

The System Speed Dials page allows you to define up to 100 speed dial numbers. Each speed 

dial number includes the first name, last name, phone number and hunt group. You can create a 

.csv file that contains speed dial numbers, and then import them into the system. You can also 

export the speed dial numbers to a .csv file. Caller ID name tagging can be enabled, which will 

substitute the caller ID name with the system speed dial name.

Activate speed dial

1. Select the System Speed Dials page.

You can define up to 100 speed dial numbers. Each speed dial number includes the first 

name, last name, phone number and hunt group.

2. Click the Add button. The Add Speed Dial window appears.

3. Enter a First name and Last name.
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4. Assign a Speed dial number.

5. Enter the Phone number. Valid characters are 0–9, -, , (pauses dialing for two seconds), w 

(pauses dialing until a dial tone is detected), * and #. The phone number can be up to 19 

characters long.

The phone number can be a regular phone number or a VoIP number from a service 

provider. 

If the phone number is a regular phone number, it can include a pause followed by an 

extension number. For example, the phone number is 555-1212 and the desired extension 

is 123. The phone number can be set to 555-1212,123. 

If auto route selection blocks the phone number, the phone number will not be blocked if a 

user dials the speed dial number.

6. Select the hunt group. Choices are the active hunt groups.

If auto route selection or permissions block the hunt group, the hunt group will not be 

blocked if a user dials the speed dial number.

If all lines in the hunt group are busy, but an overflow hunt group is set up, the system will 

try the overflow hunt group.

Click Finish.

Import system speed dial list

You can import a speed dial list created with a text editor like Microsoft Notepad or a 

spreadsheet program like Microsoft Excel. Each entry in the file requires the speed dial number, 

first name, last name, and phone number. If you’re using a text editor, The values must be 

separated by commas. The file must be saved as a .csv file.

If an entry has the same speed dial number as an existing speed dial number in the system, the 

imported entry will overwrite the existing speed dial number.

If you’re using a text file, it should look like this:

300,John,Doe,1235551212

301,Jane,Doe,1235551213

If you’re using a spreadsheet program, put the speed dial number, first name, last name and 

phone number each in their own column.

The phone number cannot include an extension number if it is a VoIP number from a service 

provider.
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Using a * prefix

You can add a * in front of speed dial numbers to differentiate them from other numbers in the 

system.

1. Click Select File. The System Speed Dial List (Import) window appears.

2. Select the .csv file, and then click Open. A progress bar appears.

3. Click Close.

4. Choose File > Save to save the imported speed dial list to the unit. Imported speed dial 

numbers will use the first available hunt group (i.e. 9, or 0 in some regions ).

Export system speed dial list

The Export System Speed Dial List area allows you to export the speed dial numbers to a .csv 

file. You can then share the .csv file as required, or print it for your users. The first line of the file 

is a title line, and subsequent lines contain entries. Each entry in the file has the following 

information: Index number, speed dial number, first name, last name, and phone number. The 

index entry represents the order of the list within the system.

If you open the .csv file in a text editor (e.g. Microsoft Notepad), each item will be surrounded by 

quotes. For example:

“INDEX”,“SSD”,“FIRST NAME”,“LAST NAME”,“PHONE NUMBER”
“1”,“300”,“John”,“Doe”,“1235551212”
“2”,“301”,“Jane”,“Doe”,“1235551313”

If you open the .csv file in a spreadsheet program (e.g. Microsoft Excel), the quotes will be 

omitted. For example: 

If the phone number has more than 15 digits and does not have any special characters (-, ,, w, * 

or #), Microsoft Excel will convert it to scientific notation. Do not attempt to import a .csv file 

that contains a phone number in scientific notation.
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1. Click Export. The System Speed Dial List (Export) window appears.

2. Enter the name of the .csv file, and then click Save. A progress bar appears.

3. Click Close.

Caller ID name tagging

The Caller ID Name Tagging area allows you to enable the substitution of the caller ID name with 

the name from the System Speed Dials page.

Caller ID name tagging compares the phone number from the caller ID of an incoming call with 

the phone numbers from the System Speed Dials page. If a matching phone number is present, 

the system will replace the name from the caller ID with the first name and last name from the 

System Speed Dials page. These names will appear on the extension instead of the caller 

ID name.

For more information, see “Caller ID (or CLID) Based Routing” on page 103.

1. To enable caller ID name tagging of the entries within the System Speed Dials page, select 

the Use the first and last names specified above to replace the incoming Caller ID names 

checkbox.

2. Select the order for the names. Choices are First name followed by last name, and Last 

name followed by first name.
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Telephone Lines

The Telephone Lines page allows you to set up the telephone numbers, telephone company 

services, and call handling for each telephone line. You can also optimize the unit to match the 

telephone lines.

1. Select the Telephone Lines page. 

Activate line

The Activate Line area allows you to activate a telephone line. All telephone lines are activated 

by default.

Line detected at initialization: Yes appears if the telephone line was connected when you started 

the Management software. Line detected at initialization: No appears if the telephone line was 

not connected.

1. Select a telephone line.

2. If necessary, select the Activate Line checkbox.

3. In certain countries, a Service Provider menu is displayed. Use the menu to identify the 

company that provides service for the selected telephone lines.

Phone numbers

The Phone Numbers area allows you to enter the main and distinctive ring phone numbers.

The Distinctive Ring service provides one or two additional phone numbers to ring the same 

telephone line. Each phone number has a different ring pattern. You can set up separate call 

handling for the main number, distinctive ring 1 number, and distinctive ring 2 number.

• Main number corresponds to the normal ring pattern.

• Distinctive ring 1 corresponds to a double ring pattern.

• Distinctive ring 2 corresponds to a triple ring pattern.
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Ringing patterns vary based upon region. Check with your service provider.

1. Enter the phone number of the telephone line in the Main number box.

2. If the telephone line has the Distinctive Ring service, and you want to set up different call 

handling for the distinctive ring numbers:

a. Select the Distinctive ring 1 and Distinctive ring 2 checkboxes. 

b. Enter the distinctive ring numbers.

3. If the telephone line has the Distinctive Ring service, but you want the same call handling for 

each distinctive ring number, clear the Distinctive ring 1 and Distinctive ring 2 checkboxes.

Phone line services

The Phone Line Services area allows you to select the telephone company services that are 

active on the telephone line. 

• Transfer and Clear allows the unit to release the line after transferring a call from an outside 

caller to a remote extension. You can enable this feature if the Transfer and Clear service will 

allow a call to remain in progress between the outside caller and the remote extension, after 

the unit hangs up. Enabling this feature without the service will result in the caller being 

disconnected when their call is transferred to a remote extension. To enable the feature, 

select the Clear telephone line after call transferred checkbox in the Transfer Preferences 

window. See “To remote extension tab” on page 133.

• 3-Way Calling/Conference allows the same line connect feature to work with the line’s 3-Way 

Calling/Conference service for call bridge (DISA) calls, and with incoming calls that are 

routed to remote extensions.

• Hunt/Rollover/Busy Forwarding indicates the line has a hunting facility or call forward on 

busy service. If an incoming call reaches a busy line, it will automatically try another line.

• Caller ID allows the unit to forward caller ID information to the local extensions. The unit can 

also use the time information provided by caller ID to update its internal clock.

• Call Waiting sounds a tone if an incoming call reaches a busy line. Call waiting is not 

recommended, since the system cannot answer the second call. If your installation has more 

than one line consider using the telephone company’s Hunt/Rollover service. The system 

has call waiting built-in, and does not require the Call Waiting service from the telephone 

company.

• When the Call Waiting service checkbox is enabled for an external telephone line, a user can 

pick up a waiting call on that line by pressing Flash or Recall then 89 on an analog phone, or 

Xfer/Transfer/TRNF then 89 on an IP phone.

• Line Reversal is used in some regions to exchange signals between the telephone company 

and your telephone equipment. If you select the Line Reversal checkbox, click the Line 

Reversal Settings button to select the reversal patterns used by your telephone company.

Note that line reversal configuration is not offered in the United States or Canada.

Line reversal settings

Line reversal is used in some regions to exchange signals between the telephone company and 

your telephone equipment. Line reversal can improve performance and lower costs on busy 

telephone lines. Check with your telephone company to see whether line reversal is used, and 

when. For example, the unit can send a signal when it:

• Seizes the line. The unit seizes a line when a user dials a hunt group number.

• Answers the line.

• Releases the line. The unit releases the line when the user hangs up.

Note that line reversal configuration is not offered in the United States or Canada.
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1. If line reversal is used, click Line Reversal Settings. The Line Reversal Settings 

window appears.

2. Select the reversal patterns specified by your telephone company for incoming and 

outgoing calls. The reversal patterns include:

• Ignore reversal — Do not send or respond to line reversal signals.

• Seizure and release — Send a signal when a line is seized, and again when the line 

is released.

• Seizure and answer — Send a signal when a line is seized, and again when the line 

is answered.

• Answer and release — Send a signal when a line is answered, and again when the line 

is released.

Call handling

The Call Handling area allows you to set up what happens when a call comes in from this line. 

Calls can be handled differently in each of the three modes. Calls can be sent directly to an 

extension, or they can ring extensions, go to an auto attendant, ring group, voice mailbox, 

announcement or VoIP location.

For example, the system can ring the receptionist when Mode 1 is active during the day. If the 

receptionist doesn’t answer, it can start ringing other users as well. If there is still no answer, it 

can play an auto attendant. The auto attendant provides the dial-by-name directory, and allows 

the caller to dial an extension. A voice mailbox can immediately answer the VoIP number when 

Mode 2 is active at night or on weekends. Another auto attendant can immediately route the call 

to a remote extension during Holiday Mode.

1. Select the Mode tab. Choices are Mode 1, Mode 2 and Holiday Mode.

2. Select the action you wish to apply:

• go to auto attendant — plays the selected auto attendant.

• go to local extension — goes to the specified extension. Busy or unanswered calls will 

follow the call cascade for that extension.

• go to remote extension — goes to the specified extension. Busy or unanswered calls will 

follow the call cascade for that extension.

• go to ring group — goes to the specified ring group. The call will follow the call cascade 

for that ring group.

• go to voicemail — Accesses the selected voice mailbox.

• play announcement — Plays the selected announcement.

• ring extensions — Sets extensions to ring. 

You can set up a ring sequence. The ring sequence determines when each local 

extension will start ringing. The extensions will not use their call cascades during the ring 

sequence. The system transfers the call to the first extension that is answered.
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i. Click Edit. The Ring Sequence window appears. 

ii. Select the local extensions to ring. 

iii. For each selected extension, set when the local extension will start ringing. All 

extensions ring after the first ring by default.

iv. If you assign a different value to each extension, the extension with the lowest 

number of rings will ring first. The other extensions will start ringing as the number of 

rings goes up. For example, the system can ring the receptionist first, and then ring 

other users if the receptionist doesn’t answer.

v. Set up call handling to route an unanswered call. Perform no action causes a generic 

auto attendant to answer after 15 rings to allow authorized callers to make 

configuration changes, access voicemail or dial extensions.

vi. Select when the system will perform call handling. 

Line optimization

The Line Optimization area allows you to calibrate the unit to match the telephone lines. 

Optimization calibrates transmission for the type of telephone line or equipment connected to 

the unit by setting the far end impedance. Optimization improves performance for call bridge 

(DISA) and call forwarding.

You should calibrate the lines:

• after adding or changing a telephone line.

• after connecting a line to equipment other than a telephone company line.

• if poor audio performance is encountered.
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1. Click Optimize Lines. The Optimize Lines window appears.

2. Select the line(s) to optimize, and then click Run Optimization.
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PRI Numbers

The PRI Numbers page allows you to set up the PRI numbers. A PRI number is a telephone 

number delivered over your T1/E1 PRI line. You will be provided a primary or main number, as 

well as DID numbers from the provider.

You can set up unique call handling for each number. You can set up call handling for Mode 1, 

Mode 2 and Holiday Mode.

If a PRI number is called, it can be sent directly to one extension or a sequence of extensions, to 

an auto attendant, ring group, voice mailbox or announcement.

1. Select the PRI Numbers page.

Activate number

The Activate Number area allows you to activate a PRI number.

1. Select an ID number.

2. Select the Activate Number checkbox.

3. Enter the phone Number.

Call handling

The Call Handling area allows you to set up what happens when a call comes in from this line. 

Calls can be handled differently in each of the three modes. Calls can be sent directly to an 

extension, or they can ring extensions, go to an auto attendant, ring group, voice mailbox, 

announcement or VoIP location.
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For example, the system can ring the receptionist when Mode 1 is active during the day. If the 

receptionist doesn't answer, it can start ringing other users as well. If there is still no answer, it 

can play an auto attendant. The auto attendant provides the dial-by-name directory, and allows 

the caller to dial an extension. A voice mailbox can immediately answer the PRI number when 

Mode 2 is active at night or on weekends. Another auto attendant can immediately route the call 

to a remote extension during Holiday Mode.

1. Select the Mode tab. Choices are Mode 1, Mode 2 and Holiday Mode.

2. Select the action you wish to apply:

• go to auto attendant — plays the selected auto attendant.

• go to local extension — goes to the specified extension. Busy or unanswered calls will 

follow the call cascade for that extension.

• go to remote extension — goes to the specified extension. Busy or unanswered calls will 

follow the call cascade for that extension.

• go to ring group — goes to the specified ring group. The call will follow the call cascade 

for that ring group.

• go to voicemail — Accesses the selected voice mailbox.

• play announcement — Plays the selected announcement.

• ring extensions — Sets extensions to ring.

You can set up a ring sequence. The ring sequence determines when each local 

extension will start ringing. The extensions will not use their call cascades during the ring 

sequence. The system transfers the call to the first extension that is answered.

i. Click Edit. The Ring Sequence window appears. 

ii. Select the local extensions to ring. 

iii. For each selected extension, set when the local extension will start ringing. All 

extensions ring after the first ring by default.

If you assign a different value to each extension, the extension with the lowest 

number of rings will ring first. The other extensions will start ringing as the number of 

rings goes up. For example, the system can ring the receptionist first, and then ring 

other users if the receptionist doesn’t answer.

iv. Set up call handling to route an unanswered call. Perform no action causes a generic 

auto attendant to answer after 15 rings to allow authorized callers to make 

configuration changes, access voicemail or dial extensions.

v. Select when the system will perform call handling.
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Settings

The Settings area allows you to configure the PRI service.

D Channel

The D Channel is the signalling channel for your PRI service.  This channel is configured to 

provide the system with inbound call notification and caller ID information.  The default channel 

is 24 for North American and channel 16 elsewhere.

Number of active PRI channels

If subscribing to a PRI service with fewer PRI channels, set the number of channels to match the 

amount being provided.
Configuration Page 99 FortiVoice v7.31 User Guide

http://www.fortinet.com/


VoIP Numbers

A VoIP number is like a telephone number. It allows a caller to dial the system through a VoIP 

service provider.

You can set up unique call handling for each VoIP number. Call handling for VoIP numbers is 

identical to call handling for telephone numbers. You can set up call handling for Mode 1, Mode 

2 and Holiday Mode.

If a VoIP number is called, it can be sent directly to one extension or a sequence of extensions, 

to an auto attendant, ring group, voice mailbox or announcement.

The VoIP Numbers page allows you to set up VoIP numbers.

1. Select the VoIP Numbers page. 

Activate VoIP number

The Activate VoIP Number area allows you to activate a VoIP number and select its profile.

1. Select a VoIP number.

2. Select the Activate VoIP Number checkbox.

3. Select the VoIP Profile. Choices are:

• Service provider (1 to 4) — The VoIP number will use the service provider. The Phone 

Number area will contain the Country code box, City or area code box and Number box, 

and the Username and Password area will be enabled.

Phone number

If a service provider profile is used, use the country code, area code and phone number, as 

provided by the service provider.

1. Enter the Country Code, if required.

2. Enter the City or Area Code.

3. Enter the Number.
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Username and password

If a service provider profile is used, the Username and Password area allows you to enter the 

authentication information required to access the service provider’s SIP server.

1. Enter the User/Account, as provided by the service provider.

2. Enter the Password, as provided by the service provider.

Registration status

See “Viewing registration status” on page 31.

Call handling

The Call Handling area allows you to set up what happens when a call comes in from this line. 

Calls can be handled differently in each of the three modes. Calls can be sent directly to an 

extension, or they can ring extensions, go to an auto attendant, ring group, voice mailbox, 

announcement or VoIP location.

For example, the system can ring the receptionist when Mode 1 is active during the day. If the 

receptionist doesn’t answer, it can start ringing other users as well. If there is still no answer, it 

can play an auto attendant. The auto attendant provides the dial-by-name directory, and allows 

the caller to dial an extension. A voice mailbox can immediately answer the VoIP number when 

Mode 2 is active at night or on weekends. Another auto attendant can immediately route the call 

to a remote extension during Holiday Mode.

1. Select the Mode tab. Choices are Mode 1, Mode 2 and Holiday Mode.

2. Select the action you wish to apply:

• go to auto attendant — plays the selected auto attendant.

• go to local extension — goes to the specified extension. Busy or unanswered calls will 

follow the call cascade for that extension.

• go to remote extension — goes to the specified extension. Busy or unanswered calls will 

follow the call cascade for that extension.

• go to ring group — goes to the specified ring group. The call will follow the call cascade 

for that ring group.

• go to voicemail — Accesses the selected voice mailbox.

• play announcement — Plays the selected announcement.

• ring extensions — Sets extensions to ring.

You can set up a ring sequence. The ring sequence determines when each local 

extension will start ringing. The extensions will not use their call cascades during the ring 

sequence. The system transfers the call to the first extension that is answered.
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i. Click Edit. The Ring Sequence window appears. 

ii. Select the local extensions to ring. 

iii. For each selected extension, set when the local extension will start ringing. All 

extensions ring after the first ring by default.

If you assign a different value to each extension, the extension with the lowest 

number of rings will ring first. The other extensions will start ringing as the number of 

rings goes up. For example, the system can ring the receptionist first, and then ring 

other users if the receptionist doesn’t answer.

iv. Set up call handling to route an unanswered call. Perform no action causes a generic 

auto attendant to answer after 15 rings to allow authorized callers to make 

configuration changes, access voicemail or dial extensions.

v. Select when the system will perform call handling. 
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Caller ID (or CLID) Based Routing

Incoming calls include caller ID information. The caller ID (referred to as CLID in some regions) 

includes the phone number and perhaps the name of the caller. The Caller ID Based Routing 

page allows you to set up call handling based on the caller ID information. The system will 

check the caller ID of each incoming call. If the caller ID matches a caller ID entry, the system 

will route the call accordingly.

For example, if the call is from an important client, the call can be routed directly to the 

president’s extension. If no caller ID is present, the call can be routed to voicemail.

You can define up to 200 caller ID entries. Each caller ID entry has an optional name, a phone 

number and a routing assignment. The routing assignment can use call handling set up for a 

group, or can display an alternate name on the user’s extension, instead of the name from the 

caller ID.

If caller ID entries have phone numbers with overlapping digits, the system will use the best 

(longest) match to route the call. For example, the first entry routes calls from phone numbers 

that start with 5551. The second entry routes calls from phone numbers that start with 555. If 

the incoming call is from 555-1234, both entries match. However the system will use the first 

entry because it is a better match with a longer set of matching digits.

You can set up call handling for up to ten groups for Mode 1, Mode 2 and Holiday Mode. Call 

handling for a group is identical to call handling for telephone numbers, except you can set the 

ring pattern for each group. Depending on the caller ID, an incoming call can ring selected local 

extensions in sequence, and then play an auto attendant or announcement, or go to a voice 

mailbox. Alternatively, it can immediately play an auto attendant or announcement, or go to a 

voice mailbox, without ringing the extensions.

1. Select the Caller ID Based Routing page.

 

Note: Caller ID is referred to as CLID in some regions.
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Caller ID lookup list or CLID matching list

The Caller ID lookup list area (or CLID matching list in some regions), allows you to define up to 

200 caller ID entries. Each entry has an optional name, a phone number and a routing 

assignment. The routing assignment can use call handling set up for a group, or can display an 

alternate name on the user’s extension, instead of the name from the caller ID.

1. Optionally, enter the name in the Replace Caller ID name with box. The extension will 

display this alternate name, instead of the name from the caller ID.

2. Select the Caller ID type to match or CLID type to match. Choices are:

• Private/blocked — Defines an entry for incoming calls that have caller ID blocked for 

privacy reasons.

• Long distance/unknown — Defines an entry for incoming calls that don’t have caller ID.

• Phone number ends with — Defines an entry for an incoming call from a phone number 

that ends with the specified digits. For example, you can enter an important client’s 

phone number if you want to route their calls directly to the president’s extension.

• All incoming calls from phone numbers with ending digits that match the specified digits 

will be routed the same way. For example, the specified digits are 5551212. The system 

will use the same routing if the phone number is 555-1212, 613-555-1212 or 

416-555-1212.

• Phone number starts with — Defines an entry for an incoming call from a phone number 

that starts with the specified digits. For example, you can enter an area code if you want 

to route long distance calls to a particular extension for faster processing, or if you want 

to route telemarketers with 1-800 numbers directly to voicemail.

• All incoming calls from phone numbers with starting digits that match the specified digits 

will be routed the same way. For example, the specified digits are 1800. The system will 

use the same routing if the phone number is 180-0121, 1-800-123-4567 or 

1-800-555-1234.

3. If you selected Phone number ends with or Phone number starts with, enter the digits.

4. Select the routing in the When matched, perform the following list. Choices are:

• use original Caller ID — The caller ID will not affect call routing.

• replace Caller ID name — The caller ID will not affect call routing, but the extension will 

display the alternate name, instead of the name from the caller ID.

• route using Group [1–10] — The caller ID is used to route the call according to the 

specified group. The extension will display the alternate name, instead of the name from 

the caller ID.

In North America, the 1 prefix is not present on PSTN lines. For PSTN in North America, use 

800-555-1234.
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Caller ID or CLID Routing Groups

The Caller ID Routing Groups area (or CLID Routing Groups in some regions), allows you to set 

up call handling for up to 10 groups for Mode 1, Mode 2 and Holiday Mode. Call handling for a 

group is identical to call handling for telephone numbers, except you can set the ring pattern for 

each group. Depending on the caller ID, an incoming call can be sent directly to an extension, or 

it can ring extensions in a sequence, go to an auto attendant, ring group, voice mailbox, 

announcement or VoIP location.

For example, when an important client calls, the system can ring the president during the day. If 

the president doesn’t answer, the call can be routed to voicemail. A voice mailbox can 

immediately answer the call when Mode 2 is active at night or on weekends. The call can go 

directly to the president’s remote extension during Holiday Mode.

1. Enter the Group Label to name the group.

2. Select the Mode tab. Choices are Mode 1, Mode 2 and Holiday Mode.

3. Select the action you wish to apply:

• go to auto attendant — plays the selected auto attendant.

• go to local extension — goes to the specified extension. Busy or unanswered calls will 

follow the call cascade for that extension.

• go to remote extension — goes to the specified extension. Busy or unanswered calls will 

follow the call cascade for that extension.

• go to ring group — goes to the specified ring group. The call will follow the call cascade 

for that ring group.

• go to voicemail — Accesses the selected voice mailbox.

• play announcement — Plays the selected announcement.

• ring extensions — Sets up a ring sequence. 

The ring sequence determines when each local extension will start ringing. The 

extensions will not use their call cascades during the ring sequence. The system 

transfers the call to the first extension that is answered.

i. Click Edit. The Ring Sequence window appears.  

ii. Select the local extensions to ring.

iii. For each selected extension, set when the local extension will start ringing. All 

extensions ring after the first ring by default.

If you assign a different value to each extension, the extension with the lowest 

number of rings will ring first. The other extensions will start ringing as the number of 

rings goes up. For example, the system can ring the receptionist first, and then ring 

other users if the receptionist doesn’t answer.
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iv. Set up call handling to route an unanswered call. Perform no action causes a generic 

auto attendant to answer after 15 rings to allow authorized callers to make 

configuration changes, access voicemail or dial extensions.

v. Select when the system will perform call handling.

Setting up caller ID routing with an extension

A user can set up caller ID routing with their extension, once the call is terminated. For example, 

a telemarketer can be added to a group that routes calls directly to an announcement.

1. To add the caller to a group, dial *81 [group number 1–10] #. The system adds the caller ID 

entry to the Caller ID lookup list (or CLID matching list in some regions). Future calls will be 

routed according to the group.

2. To display the alternate name instead of the caller ID name, dial *810#. The system adds the 

caller ID entry to the Caller ID lookup list (or CLID matching list in some regions). Future calls 

will display the name from the Replace Caller ID name with box.

3. To delete the caller ID entry from the Caller ID lookup list (or CLID matching list in some 

regions), dial *81255#. The system will no longer use the caller ID to route the call or display 

the alternate name.
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Line Hunt Groups

A line hunt group is a set of lines that are available for making an outbound call. It can use 

selected telephone lines, or all VoIP lines associated with a service provider VoIP network.

When placing an outbound call, the user first dials the hunt group number. The system selects 

an available line from the group. However, the user does not have to dial a hunt group before 

VoIP numbers. Nor does the user have to dial a hunt group before remote extension numbers. 

These automatically use the hunt group configured for the remote extension.

You can set the hunt order for telephone lines, but the system automatically determines the hunt 

order for VoIP lines.

You can set up nine different hunt groups. If you are using multiple service provider VoIP 

networks, set up a hunt group for each service provider.

A local extension can be restricted to a set of hunt groups, in order to reserve telephone lines for 

high-priority users, or to control access to VoIP networks. See “User Privileges” on page 34.

The unit uses a hunt group when placing a call from a local extension, to a remote extension, or 

with the call bridge (DISA) feature. The hunt groups do not affect incoming calls.

The system has the following hunt groups by default. If default settings are used, the system will 

first search the higher line numbers (e.g. line 4) for outgoing calls, since the lower line numbers 

are more heavily used for incoming calls. You can modify the default hunt groups as required. 

The Line Hunt Groups page allows you to set up the name, line type, set of telephone lines, 

hunting order, overflow hunt group and overflow notification for each hunt group.

Ensure that hunt group 9 or 0 is assigned to the group of telephone lines or VoIP trunks used for 

calls to emergency services.

Hunt Group 9 

(0 in some regions

Selects line 4, line 3, line 2, then line 1.

Hunt Group 81–88 No lines are assigned.
Configuration Page 107 FortiVoice v7.31 User Guide

http://www.fortinet.com/


1. Select the Line Hunt Groups page.

Note: Depending on the region, an operator may be dialed using 9 or 0.

Activate hunt group

The Activate Hunt Group area allows you to activate and name a hunt group.

1. Select a hunt group.

2. If necessary, select the Activate Hunt Group checkbox. All hunt groups are active by 

default.

3. Enter a name in the Hunt Group name box. The name will identify the hunt group elsewhere 

in the Management software.

Hunt group line assignments

The Hunt Group Line Assignments area allows you to set up a hunt group for telephone lines or 

VoIP lines.

1. Set the Line type. Choices are:

• Phone Lines — Allows you to select telephone lines.

• SPn VoIP Service — Uses the service provider VoIP lines in the hunt group.

• PRI Lines — use the PRI service in the hunt group.
Configuration Page 108 FortiVoice v7.31 User Guide

http://www.fortinet.com/


2. If you set Line type to Phone lines:

a. Click Add/Remove Lines. The Add/Remove Telephone Lines window appears.

b. Select the telephone lines for the hunt group, and then click OK.

c. Change the order of the lines by selecting a line, and then clicking Move Up and 

Move Down.

If you set Line type to SPn VoIP Service, VoIP lines are selected automatically.

Hunting order for outgoing calls

The Hunting Order for Outgoing Calls area allows you to specify how the system will hunt for an 

available line within the hunt group.

1. Set the Hunt lines in the following order list. Choices are:

• Order specified above — The system will start with the first line in the hunt group.

• Search lines on same unit first — The system will hunt for lines on the unit that the 

extension is connected to, before hunting on the other units. This minimizes network 

traffic between units.

• Uniform distribution (Circular) — The system will start with the line after the last hunted 

line in the hunt group. This way telephone lines are used more evenly for outbound calls.

For example, the hunt group has lines 1, 2, 3 and 4. The last call with the hunt group used 

line 2. The system will first check line 3 for availability.

The circular hunt mode can reduce costs if the line toll increases after utilization exceeds 

a threshold. For example, assume each line costs 5¢ per minute for the first 100 minutes, 

and then costs 10¢ per minute. The circular hunt mode makes it more likely users will 

finish the first 100 minutes on each line before the thresholds are exceeded and higher 

charges are incurred.

Hunt group busy overflow for outgoing calls

The Hunt Group Busy Overflow for Outgoing Calls area allows you to select overflow hunt 

groups. If the user dials a hunt group, but there are no lines available, the system will play a 

warning tone while hunting for a free line in the first overflow hunt group. If there are no lines 

available in the first group, the system will hunt for a free line in the second overflow group. The 

warning tone indicates the call may be more expensive or of different quality than expected. The 

user can then remain on the line, or hang up and wait for a line to become available in the 

original hunt group.

If the dialed hunt group and the overflow hunt group are both busy, the user will hear the 

busy tone.
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A hunt group that contains telephone lines can have overflow hunt groups that contain 

telephone lines or VoIP lines. Similarly, a hunt group that contains VoIP lines can have overflow 

hunt groups that contain telephone lines or VoIP lines.

The first overflow hunt group must contain different lines than the original hunt group, and the 

second overflow group must contain different lines than the first overflow group but all lines 

must support the same dialed number structure.

For example, assume the original hunt group contains telephone lines and the first overflow 

hunt group contains VoIP lines. If the lines within the original hunt group require you to dial 1 

before the area code and phone number (e.g. 1 613 555 1212), the lines within the overflow hunt 

group cannot require you to omit the 1 (e.g. 613 555 1212).

1. Select the overflow hunt group in the If all lines are busy in this hunt group list. Choices are 

no overflow and the activated hunt groups.

2. Select the overflow hunt group in the If all lines are busy in the previous hunt group, use list. 

Choices are no overflow and the activated hunt groups.

Overflow tone notification 

The Overflow Tone Notification area allows you to disable the warning tone that sounds when 

an overflow hunt group is being used. The warning tone sounds by default.

1. To disable the warning tone, clear the Play notification tone when overflowing to another 

hunt group checkbox.
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Auto Attendants

An auto attendant can answer a telephone line or VoIP number, and can be included in the call 

cascade of a local extension, remote extension or ring group.

An auto attendant can answer a call if the receptionist is away or if you don’t have a 

receptionist. Each auto attendant has a message and up to six options. The message tells the 

caller what the options are. You can load a professionally pre-recorded message, or can record 

a message using a handset. The caller selects an option by dialing 0 (9 in some regions), 1, 2, 3, 

4 or 5. The auto attendant then performs the action programmed for the option. The auto 

attendant can:

• Transfer the call to a local extension, remote extension or ring group. The call then follows 

the extension’s call cascade.

• Transfer the call to the call queue of a ring group. The call is placed on hold. The system will 

ring the next available local extension in the ring group.

• Transfer the call to a voice mailbox, allowing the caller to leave a message. The call can be 

transferred to a local extension, remote extension or general voice mailbox. Pressing * 
during the greeting returns to the auto attendant. If the 0 option is programmed (9 in some 

regions), pressing 0 during the greeting (9 in some regions) can route the call to an extension, 

voice mailbox, announcement or auto attendant. An authorized caller can retrieve messages 

and perform other voicemail activities by pressing 8 during the greeting. If no digit is pressed 

during the greeting, the system hangs up after the caller leaves a message.

• Play an announcement with directions, business hours, etc. The announcement can have 

the 0 option programmed (9 in some regions) to route the call to an extension, voice mailbox, 

announcement or auto attendant. The system hangs up after the announcement if no digit is 

dialed. Pressing * returns to the auto attendant.

• Access the dial-by-name directory so the caller can find a user’s extension number. The 

dial-by-name directory prompts the caller to enter the first three letters of the user’s last 

name. Pressing * returns to the auto attendant. See “Setting up the dial-by-name directory” 

on page 116.

• Route the call to another auto attendant, which allows actions to be nested into a powerful 

call routing system. For example, the main auto attendant can say “Press one for English. 

Oprima dos para Español.” Option 1 goes to the English auto attendant and option 2 goes to 

the Spanish auto attendant.

In addition to the six auto attendant options, the caller can:

• Reach an extension by dialing an extension number.

• Access voicemail by pressing ** then the mailbox number.

• Access call back by dialing 6.

• Access call bridge/DISA by dialing a hunt group number.

• Enter command mode by pressing #.

The caller is able to dial an extension, even if the first number of the extension is the same as an 

auto attendant option. For example, the caller can dial 111 even though the first “1” is the same 

as auto attendant option 1. This is because the system waits after the caller dials a digit, before 

following the action for that digit. The default wait time is 1.5 seconds. To change the wait time, 

go to Troubleshooting > Auto Attendants. The Auto Attendants window will appear. Select the 

desired time from the pull-down menu Single digit fall through time.

The system automatically copies the auto attendants to each unit on the network. This reduces 

network traffic and allows the system to continue functioning even if a unit loses power or is 

disconnected from the LAN.

The recording time for internal music on hold, voicemail, and the auto attendants is shared on 

the unit.
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Configuring auto attendants

1. Select the Auto Attendants page.

Note: In the Actions During Auto Attendant Playback section, depending on the region, callers can press either 0 or 9.

The Activate Auto Attendant area allows you to activate an auto attendant. All auto 

attendants are activated by default.

2. Select an auto attendant.

3. If necessary, select the Activate Auto Attendant checkbox.

4. Enter the Auto Attendant label. The name will identify the auto attendant elsewhere in the 

Management software.

Actions during auto attendant playback

The Actions During Auto Attendant Playback area allows you to configure the auto attendant 

with up to six options, associated with the caller pressing 0 (9 in some regions), 1, 2, 3, 4 or 5.

1. Select the Action. Choices are:

• go to voicemail — Accesses the selected voice mailbox.

• go to local extension — Transfers the call to the selected local extension. 

• go to remote extension — Transfers the call to the selected remote extension. 

• go to ring group — Transfers the call to the selected ring group. 

• play announcement — Plays the selected announcement.

• go to auto attendant — Routes the call to the selected auto attendant.

• queue at ring group — Transfers the call to the call queue of the selected ring group.

• dial-by-name directory — Accesses the dial-by-name directory. See “Setting up the 

dial-by-name directory” on page 116.

• perform no action — The option is unused.
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2. Select the Resource. Depending on the action selected in Step 1, resources are voice 

mailboxes, extensions, announcements or auto attendants.

3. Select the language in the Language of system prompts list. If the caller selects this option, 

they will hear all subsequent prompts in the selected language.

4. Select the action If a fax call is detected. The system can automatically detect a fax 

machine that plays a CNG tone. Choices are:

• go to local extension 

• go to remote extension

• perform no action 

• hang up

5. Depending on the action selected in Step 4, select the extension the fax machine is 

connected to.

6. If the caller dials an option that causes the auto attendant to transfer their call, the system 

will play the “One moment please” prompt by default. You can disable the prompt. See 

“From auto attendant tab” on page 135.

a. Choose Options > Transfer Preferences. The Transfer Preferences window appears.

b. Select the From Auto Attendant tab.

c. To disable the prompt, select the Disable playing of transfer prompts checkbox.

Action performed after auto attendant playback

The Action Performed After Auto Attendant Playback area allows you to set up how the system 

will react if the user makes no selection. This can occur if the caller does not understand the 

prompts, does not have tone dialing on their phone, or prefers to speak with a person.

1. Select the time limit, ranging from 0 seconds to 30 seconds.

2. Select the action. Choices include:

• go to voicemail

• go to local extension

• go to remote extension

• go to ring group

• play announcement

• go to auto attendant

• queue at ring group

• dial-by-name directory — See “Setting up the dial-by-name directory” on page 116.

• hang up

3. Depending on the action selected in Step 2, select the voice mailbox, extension, 

announcement, or auto attendant.
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Working with auto attendant messages

You can record a new message, load a professionally recorded message, or erase a message 

from the system. 

Recording a new message

You can record a new message from the Management software or from a local extension or 

remote phone.

To record from the software

1. Open the Auto Attendants page. Select the auto attendant that you wish to record and click 

the Record Greeting button in the Attendant Greeting section. 

2. Select the local extension that you wish to record from and click OK. The system will call the 

extension. 

3. Pick up the extension and follow the prompts to record the greeting.

To record from a local extension or remote phone

1. Pick up a local extension, or dial into the system from a remote phone. If you pick up a local 

extension, you will hear the dial tone. If you dial in from a remote phone, the auto attendant 

will answer.

2. Enter command mode by either pressing # on an analog extension phone, or *55# on a 

proprietary IP phone (note: other brands may use *55 Send or *55 Dial).

3. Enter the system password, followed by #.

4. Dial 4 [auto attendant number] # to record the message. For example, dial 41# to record the 

message for auto attendant 1.

5. Press # when you have completed saying the message.

6. Dial 5 [auto attendant number] # to listen to the message. For example, dial 51# to listen to 

the message for auto attendant 1.

7. Repeat Steps 4 to 6 to re-record the message, or hang up to keep the message.

Listening to the recorded message

In the Management software

1. Select the auto attendant that you wish to listen to and click on the Play Greeting button.

2. Choose a local extension then click OK. The system will call the extension and play the auto 

attendant greeting.

Loading a message

The Attendant Greetings area allows you to load the message for the auto attendant.

You can load an 8 kHz, 8 bit, Mono, u-Law .wav file that contains the auto attendant message. If 

using a professionally recorded message, ensure it is in this format. Maximum message length 

is 5 minutes.

1. Select an auto attendant.

If you don’t set up an auto attendant message, the system will answer without playing a 

message. The caller will hear silence and might assume the call did not get connected.
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2. Click Load Greeting. The Select Wav File window appears.

3. Click Browse to select the .wav file. Click Load to load the .wav file into the system. Play 

and Stop buttons are also provided, if you prefer to listen to the file before loading it.

Erasing a message

You can erase a recorded or loaded message using a local extension or remote phone. Erase 

unused auto attendant messages to free up space for voicemail. 

1. Pick up a local extension, or dial into the system from a remote phone. If you pick up a local 

extension, you will hear the dial tone. If you dial in from a remote phone, the auto attendant 

will answer.

2. Enter command mode by either pressing # on an analog extension phone, or *55# on a 

proprietary IP phone (note: other brands may use *55 Send or *55 Dial).

3. Enter the system password followed by #.

4. Dial 04 [auto attendant number] # to erase the message. For example, dial 041 # to erase 

the message for auto attendant 1. 
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Example auto attendant

The following auto attendant answers incoming calls, and plays the following recorded 

message:

“Welcome to ABC Company. If you know your party’s three-digit extension, you may dial it now. 

To reach the receptionist, dial 0 (9 in some regions) or stay on the line. Dial 1 to find your party’s 

extension in our dial-by-name directory. Dial 2 to hear our business hours and directions to our 

location. Dial 3 to talk to the next available customer support representative, or dial 4 to leave 

them a message.”

If the caller is a fax machine that plays the CNG tone, the system will route the call to the fax 

machine at extension 118. If no selection is made, the call is routed to the receptionist at 

extension 114.

 

Note: In the Actions During Auto Attendant Playback section, depending on the region, callers can press either 0 or 9.

Setting up the dial-by-name directory

The dial-by-name directory allows a caller to find a user’s extension number, and connect to 

their local extension or remote extension. This way the caller can reach their party without 

speaking to the receptionist.

When prompted by the auto attendant, the caller selects the dial-by-name directory, and then 

dials the first three letters of the user’s first or last name. Alternatively, the caller can dial only 

one or two letters. If a matching entry is found, the system will play the user’s name and 

extension number. The caller can then dial 1 to connect to the user’s extension. If there are 

multiple matches, the caller can dial 2 to hear the next matching name and extension number.

1. The directory can search by last name only, first name only or first and last name. Under the 

Options menu, select Dial-by-name Directory to specify the search method.

2. Set up the local extensions and remote extensions. The name fields from the extensions will 

be used in the directory.
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3. Have each user set up their voice mailbox by dialing **# and then following the prompts. 

They will record their names for the dial-by-name directory. Alternatively, you can set up 

their voice mailboxes by dialing ** + voice mailbox number + # and then following the 

prompts.

4. Configure the telephone line or VoIP number to be answered by an auto attendant. See 

“Call handling” on page 94.

5. Configure the auto attendant with an action to access the dial-by-name directory. See 

“Actions during auto attendant playback” on page 112.

6. Record an announcement for the auto attendant that tells the caller how to access the 

dial-by-name directory. See “Working with auto attendant messages” on page 114.

7. To make the dial-by-name directory available to users as well as callers, configure the Dial 0 

Routing feature (Dial 9 in some regions), to connect with the dial-by-name directory. See 

“Dial 0 or 9 routing” on page 7.

You can delete the names recorded for the dial-by-name directory by resetting the voice 

mailbox. See “Reset mailboxes” on page 86.

Setting the PBX extension length

You can configure a unit with an auto attendant, and then connect the unit to another PBX. This 

way the unit can route callers as requested.

If you will connect the unit to another PBX, set the extension length used by the other PBX. See 

“From auto attendant tab” on page 135.

1. Choose Options > Transfer Preferences. The Transfer Preferences window appears.

2. Select the From Auto Attendant tab.

3. Set the PBX extension length to the number of digits in an extension number on the 

other PBX.

The name must be recorded for the entry to be available.
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Auto Call Back

Auto call back lets a travelling user gain access to the system without completing the call to the 

telephone line or VoIP number. This minimizes long-distance and hotel telephone costs. You can 

set up four auto call back accounts per unit.

The Auto Call Back page allows you to set up auto call back accounts. You can set up four auto 

call back accounts per unit. Each auto call back account includes the name, call back number, 

telephone line or VoIP number that will trigger auto call back, announced message, password, 

dialing prefix, and hunt groups. 

1. Select the Auto Call Back page.

Using auto call back

1. Call the telephone line or VoIP number, let it ring twice, and then hang up. The unit will dial 

the call back number configured for that line.

2. Press # to accept the call back.

3. Enter the auto call back password + # to enter the system menu. From the system menu 

you can:

• Dial an extension. After you complete the call, you will be disconnected.

• Check your voicemail by dialing ** + extension. After you check your voicemail, press * 

to return to the system menu.

• Call an outside number by dialing 9 (0 in some regions), or 81–88 + phone number. To 

complete the call, press #* to return to the system menu. You can also press ## to call 

another outside number using the same hunt group.

• Configure the system by dialing #, entering the system password + #, and then entering 

the command.

You must ensure the auto attendant for the telephone line or VoIP number is set to answer after 

four rings. In order to trigger auto call back, the user must call the telephone line or VoIP 

number, and then hang up after two rings, but before the auto attendant answers.
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When the system returns your call, it can play a default message that tells the recipient to 

press # to accept the auto call back. You can record and enable an announced message that 

will be played instead of the default message. For example, the announced message can tell 

the front desk at your hotel to transfer the call to your room. You can also disable the 

announced message to use the default message.

To configure auto call back, call the telephone line or VoIP number, and let the auto attendant 

answer. Dial 6, and then follow the prompts. You can change the call back number, change the 

announced message, enable/disable the announced message, and enable/disable the auto call 

back account.

Activate auto call back

The Activate Auto Call Back area allows you to set up an auto call back account, with the name, 

call back number, and the telephone line or VoIP number that will trigger auto call back.

1. Select an available auto call back account.

2. Select the Activate Auto Call Back checkbox.

3. Enter the name of the auto call back account in the Label box.

4. Enter the call back number in the Number to call back box. This is the telephone number at 

the traveller’s destination. Do not enter a hunt group number. Note that the travelling user 

can change the call back number. The new call back number will replace that entered into 

the Auto Call Back page.

5. To have the unit dial a number before the call back number, select the Use call back prefix 

checkbox, and then enter the prefix. The prefix can include numbers 0–9, *, #, and “,” 

(comma for 2-second pause). For example, you can enter a calling card number, a pause, a 

PIN number, and another pause.

6. Select the telephone line or VoIP number in the Number to trigger call back list. Each auto 

call back account can be associated with one telephone line or VoIP number. Calling this 

telephone line or VoIP number and then hanging up will trigger the call back.

7. Assign a user privilege to this account.

8. After the unit dials an auto call back number or the prompted call back number, it will wait 

for a configurable number of rings for someone to answer. By default, it will wait six rings 

before hanging up. You can change the number of rings. See “Call Back” on page 138.

a. Choose Options > Call Back. The Call Back Options window appears.

b. Select the number of rings the unit should wait before hanging up.

Account options

To have the unit play a recorded message when the call back is answered, select the Use 

announced message checkbox. This is required if a receptionist will answer the phone after the 

unit dials the call back number. For example, the announced message can tell the hotel front 

desk: “Please transfer this call to Bob in room 307”. You can record the announced message 

using a local extension connected to the unit, or remotely by calling a telephone line connected 

to the unit. See “Recording an announced message” on page 120.
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Recording an announced message

This procedure describes how to record the announced message played by the unit when the 

call back is answered.

1. Pick up a local extension connected to the unit, or remotely call a telephone line or VoIP 

number connected to the unit. You must record the announced message on the same unit 

that has the auto call back account.

2. Enter command mode by either pressing # on an analog extension phone, or *55# on a 

proprietary IP phone (note: other brands may use *55 Send or *55 Dial).

3. Enter the system password, followed by #.

4. Enter the command listed below, and follow the prompts. 

5. Press * to exit command mode.

You can also record, enable or disable an announced message after dialing 6 at the auto 

attendant.

Prompted Call Back

Prompted call back lets a travelling user gain access to the system. This minimizes 

long-distance and hotel telephone costs. You can set up one prompted call back account for 

the system.

The Prompted Call Back page allows you to set up prompted call back for the system, including 

the name, call back number, announced message, password, dialing prefix, and hunt groups.

Auto call back

account number

Record

message

Erase

message

Play

message

1 61# 061# 71#

2 62# 062# 72#

3 63# 063# 73#

4 64# 064# 74#

You must ensure an auto attendant will answer. In order to trigger prompted call back, the user 

must call the system, wait for the auto attendant to answer, dial 61, and then hang up.
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1. Select the Prompted Call Back page.

Using prompted call back

1. Call the system, and let the auto attendant answer.

2. Dial 61, and then hang up. The system will dial the call back number.

3. Press # to accept the call back.

4. Enter the prompted call back password + # to enter the system menu. From the system 

menu you can:

• Dial an extension. After you complete the call, you will be disconnected.

• Check your voicemail by dialing ** + extension. After you check your voicemail, press * 

to return to the system menu.

• Call an outside number by dialing 9 (0 in some regions), or 81–88 + phone number. To 

complete the call, press #* to return to the system menu. You can also press ## to call 

another outside number using the same hunt group.

• Configure the system by dialing #, entering the system password + #, and then entering 

the command.

When the system returns your call, it can play a default message that tells the recipient to 

press # to accept the prompted call back. You can record and enable an announced message 

that will be played instead of the default message. For example, the announced message can 

tell the front desk at your hotel to transfer the call to your room. You can also disable the 

announced message to use the default message.

To configure prompted call back, call the system, and let the auto attendant answer. Dial 6, and 

then follow the prompts. You can change the call back number, change the announced 

message, and enable/disable the announced message.

You may incur long-distance and hotel telephone charges each time you access prompted call 

back from a remote location.
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Activate prompted call back

The Activate Prompted Call Back area allows you to enter the name and call back number.

1. Select the Activate Prompted Call Back checkbox.

2. Enter the call back number in the Number to call back box. This is the telephone number at 

the traveller’s destination. Do not enter a hunt group number.

3. Note that the travelling user can change the call back number. The new call back number 

will replace that entered into the Prompted Call Back page.

4. To have the unit dial a number before the call back number, select the Use call back prefix 

checkbox, and then enter the prefix. The prefix can include numbers 0–9, *, #, and “,” 

(comma for 2-second pause). For example, you can enter a calling card number, a pause, a 

PIN number, and another pause.

5. Assign a user privilege to this account.

6. After the unit dials an auto call back number or the prompted call back number, it will wait 

for a configurable number of rings for someone to answer. By default, it will wait 6 rings 

before hanging up. You can change the number of rings. “Call Back” on page 138.

a. Choose Options > Call Back. The Call Back Options window appears.

b. Select the number of rings the unit should wait before hanging up.

Account options

To have the unit play a recorded message when the call back is answered, select the Use 

announced message checkbox. This is required if a receptionist will answer the phone after the 

unit dials the call back number. For example, the announced message can tell the hotel front 

desk: “Please transfer this call to Bob in room 307”. You can record the announced message 

using a local extension connected to the unit, or remotely by calling a telephone line connected 

to the unit. “Recording an announced message” on page 122.

Recording an announced message

This procedure describes how to record the announced message played by the unit when the 

call back is answered.

1. Pick up a local extension, or remotely call the system.

2. Enter command mode by either pressing # on an analog extension phone, or *55# on a 

proprietary IP phone (note: other brands may use *55 Send or *55 Dial).

3. Enter the system password, followed by #.

4. Enter 65# to record the message, 065# to erase the message, or 75# to play the message, 

and then follow the prompts.

5. Press * to exit command mode.

You can also record, enable or disable an announced message after dialing 6 at the auto 

attendant.
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File menu

The File menu has commands for working with configuration files. A configuration file contains 

parameter settings for the system and has the .tsd extension. The unit uses parameter settings 

to control operation. The default location for storing configuration files is C:\Program Files, in 

the folder for the system.

The commands available within the File menu change depending upon whether a configuration 

is open.

If no configuration is open, and the Configuration Selection page is displayed, you can:

• Create a new configuration file from the template, with default parameter settings for your 

system. This way you can set up a configuration without a unit.

• Open the configuration from a unit.

• Open an existing configuration file.

If a configuration is open, you can:

• Save the configuration to a unit. The unit can be local or at a remote location. This is only 

available if you opened a configuration file. 

• Save a new configuration file.

• Save a configuration to an existing configuration file, overwriting it.

• Retrieve the current settings of a connected system.

For more information about the Configuration Selection page, see “Starting the Management 

software” on page 2.

New Template

The New Template command creates a configuration file from the template, with default 

parameter settings for your system. You can then modify the file using the Management 

software. 

1. Choose File > New Template. The Create a new template file window appears.

Alternatively, you can click the Open a Configuration File or Template button in the 

Configuration Selection page, and then click the Create a Template File button.

2. Select the types of units in your system.

3. Click the Browse button to select the location and name of the configuration file.

4. Click OK. The system creates the file, and opens it in the Management software.
Configuration Page 123 FortiVoice v7.31 User Guide

http://www.fortinet.com/


Open > Location

The Open > Location command connects to the selected phone system and retrieves the 

configuration. The unit can be local or at a remote location. You can then modify the file using 

the Management software. The command is only available when no configuration is open. 

1. Choose File > Open > Location. The Connect Via IP window appears.

Alternatively, you can also click the Connect to a Different System button or the Connect to 

a System Via IP button in the Configuration Selection page.

2. Enter the URL/IP Address of the unit, and then click OK. You can also choose the system 

from the address book.

Open > Configuration File

The Open > Configuration File command opens a saved configuration file. You can then use the 

Management software to modify the configuration. The command is only available when no 

configuration is open.

1. Choose File > Open > Configuration File. The Configuration File window appears.

Alternatively, you can also click the Open a Configuration File or Template button in the 

Configuration Selection page, and then click the Open a File button.

2. Choose the configuration file, and then click Open.
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Save

The Save command saves the configuration to the open configuration file or to the connected 

unit. The unit can be local or at a remote location. 

Save To > File

The Save To > File command saves the configuration to a new configuration file, or overwrites 

an existing configuration file. It does not save the parameter settings to the unit.

1. Choose File > Save To > File. The Save window appears.

2. Enter the name of the configuration file, and then click Save.

Save To > Location

The Save To > Location command saves the configuration from the open configuration file to 

the selected system. The system can be local or at a remote location. The command is only 

available if you opened a configuration file.

1. Choose File > Save To > Location. The Location window appears. If the Management 

software auto-discovered your local system, the window shows the unit configured as 

proxy.

New settings must be saved to the unit to take effect.
Configuration Page 125 FortiVoice v7.31 User Guide

http://www.fortinet.com/


2. To save the configuration to the auto-discovered local system, select the unit configured as 

proxy, and then click OK.

3. To save the configuration to a remote system:

a. Click Other. The Connect Via IP window appears.

b. Enter the URL/IP address of the remote system, and then click OK. You can also choose 

the system from the address book.

Retrieve Settings

The Retrieve Settings command opens the configuration from the current unit. You can then 

modify the configuration using the Management software.

Alternatively, you can also click the Configure Auto-Detected System button or the Retry Auto 

Discovery button on the Configuration Selection page.

Close

The Close command closes the configuration, and returns to the Configuration Selection page.

Exit

The Exit command closes the Management software.
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Tools menu

Memory Usage

1. Choose Tools > Memory Usage. The Memory Usage window appears. It shows the amount 

of time provided by the units, and the amount of time used by voicemail and auto attendant 

messages. 

The recording time for internal music on hold, voicemail, and the auto attendants is shared on 

the unit.

Due to deactivation of mailboxes or errors, the system may display messages currently not 

assigned to a mailbox. Clicking on the Unassigned link will allow you to either download wav 

files to your PC to listen to, or delete them. Saving the files will create a folder in the program 

directory.

Voicemail Manager > Mailbox Status

See “Mailbox status” on page 85.

Voicemail Manager > Delete Mailbox Password

See “Delete password” on page 86.

Voicemail Manager > Reset Mailboxes

See “Reset mailboxes” on page 86.

Terminal Window (CLI)

The Terminal Window (CLI) command displays the Command Console window. Use this as 

directed by customer support.
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Call Logging Output (CDR)

The Call Logging Output (CDR) command allows you to set up logging of call detail records. For 

information about call logging, see “Enabling call detail record logging” on page 172.

Defaults > Entire Configuration

The Defaults > Entire Configuration command resets the entire configuration to default values.

Defaults > Current Page

The Defaults > Current Page command resets the current page of the configuration to 

default values.

Uninstall License

The Uninstall License command facilitates the removal of licensed add-ons from systems.

To deactivate a licensed add-on, you will require a deactivation key from Technical Support. 

Technical Support will ask you for your System ID.

1. In the Uninstall License window, select the feature you wish to deactivate.

2. Enter the deactivation key from Technical Support in the bottom field. Click Deactivate.

Click-to-Dial

Users can dial their Microsoft Outlook contacts with a single click. 

The Click-to-Dial utility must be installed on the PC of the user. Get the free utility from your 

reseller.

The utility will require an internal IP address or Wan IP address and password for configuration. 

This information for configuring each extension is listed in the Click-to-Dial window.

Admin Observed Events

Admin Observed Events sends notifications to the administrator when certain events occur. The 

notification options are:

• EMS Dialed (emergency services was dialed)

• Call Blocked (attempted call to a blocked number)

To activate event notifications, enter the administrator's e-mail address in the Admin Observed 

Events window.

Update Phone

This launches the phone updater tool, which will allow you to update selected IP phones 

connected to your system to the latest version of phone firmware you have installed on your PC.
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Update Firmware

The Update Firmware command shows the firmware version of the units and the latest firmware 

version available with the Management software. It allows you to update the units with a newer 

firmware version.

1. Choose Tools > Update Firmware. The System Firmware Update window appears.

2. If the Firmware detected is lower than the Firmware file:

a. Set the Auto-Reboot checkbox.

• Select Auto-Reboot to automatically reboot the units once the firmware has been 

updated. This will cancel any calls in progress.

• Clear Auto-Reboot to prevent the units from rebooting automatically. You will have to 

manually reboot the units later, when there are no calls in progress. See “Reboot 

System” on page 130.

b. Click the Update button.

Update progress will be indicated in the software window, while the lights on the front of the 

unit(s) will display progress patterns. A dialog will appear to report successful completion of the 

update. Click OK to continue.
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Reboot System

The Reboot System command reboots the units at the specified time. This is required after 

updating the firmware, unless you selected the Auto-Reboot checkbox, and the units rebooted 

automatically.

1. Choose Tools > Reboot System. The Rebooting System window appears. 

2. Select when the units should reboot. They can reboot immediately, when all calls are 

complete, once the system has been unused for a period of time, or once a certain 

time arrives.

3. Click Reboot.

Print > Print Labels

The Tools > Print > Print Labels command allows you to print the labels for IP extensions.

1. Choose Tools > Print > Print Labels. The Select Extensions window appears. 

2. Choose the extensions that you wish to print the labels for.

3. Click Print.

Print > Print Resources

The Tools > Print > Print Resources command allows you output the resources configured 

within the system into Excel to save or print.
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1. Choose Tools > Print > Print Resources. The Select Resources window appears. 

2. Choose the resources that you wish to print:

• Local/Remote Extensions

• Ring/Page Groups

• Broadcast/General Voicemail

• System Speed Dials

• User Privileges

• Network Settings

• Email Service

• Auto Attendants

• Telephone Lines/PRI

• VoIP Configuration

• Caller ID Based Routing

• Line Hunt Groups

3. Click Proceed. The selected resources will be exported to an Excel file from which you can 

print.

Configuration Assistant

This opens the simplified assisted configuration tool.
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Options menu

The Options menu has commands for configuring the system.

Paging Options

The Audio Output Options section allows you to set the audio from the PA jack.

1. Choose Options > Paging. The Paging Options window appears.

2. Select the audio that is output from the PA jack. Choices are:

• PA announcements — Routes a PA announcement to the PA jack when a user dials *0.

If a user has dialed *80 to route music on hold through the PA jack, and a user dials *0 to 

make a PA announcement, the PA announcement will interrupt the music on hold.

• Voicemail screening — Routes a call to the PA jack if a caller reaches a voice mailbox, or 

if a user accesses a voice mailbox. In addition, the system will route a PA announcement 

to the PA jack if a user dials *0.

• Demo with router — Intended for demonstration purposes only.

• Static VoIP demo — Intended for demonstration purposes only.

Overhead Paging

If overhead paging results in feedback, you can enable delayed paging. The page will be played 

over the PA after the message has been recorded. 

Check the box to enable delayed paging.

Transfer Preferences

The Transfer Preferences command allows you to set options for transferring callers. You can 

set options for calls transferred to local extensions, remote extensions and ring groups, and 

from auto attendants and home phones.

1. Choose Options > Transfer Preferences. The Transfer Preferences window appears.

Unlike a PA announcement, voicemail screening will not interrupt music on hold.
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To local extension tab

The To Local Extension tab allows you to set call handling for calls manually transferred to a 

local extension, if the extension is busy or unanswered.

1. Select the To Local Extension tab.

2. Select the option if the extension is busy:

• Ring back the extension that transferred the call — If the extension is busy, transfer the 

call back to the source extension.

• Perform the Busy action — If the extension is busy, perform the target extension’s Busy 

call cascade.

3. Select the option if the extension is unanswered:

• Ring back the extension that transferred the call — If the extension is unanswered, 

transfer the call back to the source extension.

• Perform the No Answer action — If the extension is unanswered, perform the target 

extension’s No Answer call cascade.

To remote extension tab

The To Remote Extension tab allows you to set call handling for calls manually transferred to a 

remote extension, if the extension is busy or unanswered. It also sets transfer and clear, and 

screened or blind transfer.

1. Select the To Remote Extension tab.

2. Select the option if the remote extension is busy:

• Ring back the extension that transferred the call — If the remote extension is busy, 

transfer the call back to the source extension.

• Perform the Busy action — If the remote extension is busy, perform the remote 

extension’s Busy call cascade.
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3. Select the option if the remote extension is unanswered:

• Ring back the extension that transferred the call — If the remote extension is 

unanswered, transfer the call back to the source extension.

• Perform the No Answer action — If the remote extension is unanswered, perform the 

remote extension’s No Answer call cascade.

4. Select the Clear telephone line after call transferred checkbox to clear the telephone line 

after the call is transferred to a remote extension. The telephone line must have the Transfer 

and Clear service available and selected on the Telephone Lines page. See “Phone line 

services” on page 93.

5. Select how the system transfers calls from a remote extension to a local extension, ring 

group. Choices are:

• Allow screening of calls — When the user at a remote extension transfers a call, allows 

them to determine whether the other user wants it.

• Perform a blind transfer — When the user at a remote extension transfers a call, the 

system immediately connects the caller to the other user and releases the telephone line 

connected to the remote extension. 

To ring group tab

The To Ring Group tab allows you to set call handling for calls manually transferred to a ring 

group, if all the extensions are busy or unanswered.

1. Select the To Ring Group tab.

2. Select the option if all the extensions are busy:

• Ring back the extension that transferred the call — If all the extensions are busy, transfer 

the call back to the source extension.

• Perform the Busy action — If all the extensions are busy, perform the ring group’s Busy 

call cascade.

3. Select the option if all the extensions are unanswered:

• Ring back the extension that transferred the call — If all the extensions are unanswered, 

transfer the call back to the source extension.

• Perform the No Answer action — If all the extensions are unanswered, perform the ring 

group’s No Answer call cascade.

Transferring a call from a remote extension requires telephone lines without the 3-Way 

Calling/Conference service or the Transfer and Clear service.

When a call is transferred from one remote extension to another remote extension, it is always a 

blind transfer to avoid tying up a third line.
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From auto attendant tab

The From Auto Attendant tab allows you to set the PBX extension length and disable the 

transfer prompts.

1. Select the From Auto Attendant tab.

2. If the system is used as an auto attendant for another PBX, set the PBX extension length to 

the number of digits the PBX uses for its extensions. When the caller dials 7 followed by an 

extension number, the unit will capture the extension number, flash the line and then dial the 

extension number to complete the transfer. Choices range from not used to 7 digits.

3. Select the Disable playing of transfer prompts checkbox to disable the “one moment 

please” prompt when transferring a call.

Call Reminders

The Call Reminders command allows you to set reminder timers. When a reminder timer 

expires, the phone rings indicating a caller is on hold or parked. In addition, a queued caller 

hears a prompt when the Queue options reminder timer expires.

1. Choose Options > Call Reminders. The Call Reminder Timers window appears.

2. Set the Hold ringback reminder timer to how often the phone should ring when a caller is 

on hold.

3. Set the Park ringback reminder timer to how often the phone should ring when a caller 

is parked.

4. Set the Queue options reminder timer to how often a queued caller should hear a prompt.

This feature only works with PBXs that use hook flash as a transfer method. Please contact 

your PBX manufacturer for transfer details.
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VoIP Trunking

The VoIP Trunking command allows you to set the VoIP ports and choose the local Proxy.

1. Choose Options > VoIP Trunking. The VoIP Settings window appears. 

VoIP ports

The VoIP Ports area allows you to set the SIP server port, and the starting RTP port.

1. The SIP signalling port box allows you to change the SIP server port. The default SIP server 

port is 5060. If required, enter a different port number ranging from 1024 to 65535.

2. The default Base RTP port is 6000. If required, enter a different port number ranging from 

1024 to 65535.

Each unit requires 8 RTP ports. The RTP ports are evenly numbered from the starting port 

as follows:

• unit 1 — 6100 to 6114

• unit 2 — 6200 to 6214

• unit 3 — 6300 to 6314

• unit 4 — 6400 to 6414

These are the RTP ports the system listens to for audio. If these are not opened correctly, 

users will not hear their callers.

3. Ensure your router is set up to perform port forwarding for the SIP signalling and RTP ports. 

See “Firewall settings” on page 14.

Local proxy

If your system has multiple units, the Local Proxy area displays and allows you to change the 

unit acting as local proxy. The local proxy handles Internet communications for the system. It 

establishes connections across the Internet, and then routes Internet data to and from each 

unit.The lowest numbered unit acts as local proxy by default.

The router must map the SIP, TFTP and HTTP ports to the local proxy. See “Firewall settings” on 

page 14.

1. If necessary, click the Change Proxy button, then select the unit.

Clock Preferences

The Clock Preferences command allows you to have the system get the time and date (but not 

the year or time zone) from caller ID. This allows the system to refresh the clock automatically. It 

is beneficial if your area has frequent power outages that cause the system time to become 

inaccurate. However it is not recommended if you have more than one telephone service (e.g. 

regular telephone and VoIP) because the telephone services could have conflicting times.
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1. Choose Options > Clock Preferences. The Caller ID / Time Set Options window appears.

2. Select the Obtain and set system time from Caller ID checkbox to have the unit update its 

internal clock using the timestamp within caller ID. If it is not selected, set the time using the 

Date and Time Properties window. See “System time” on page 11.

PRI Settings

The PRI Settings command allows you to set the active number of channels, D channel and the 

Line Build Out level.

1. Choose Options > PRI Settings. The PRI Settings window appears.

PRI Channels

Select the number of channels being supplied by your PRI service provider.

Advanced Settings

Select the signalling channel used by your PRI service provider. The default D Channel is 24 for 

North America, or 16 elsewhere.

Line Build Out

The Line Build Out area allows you to set the signal strength if connected to a service with a 

long circuit length. The PRI provider will provide details about the circuit length and the line 

build out value that should be configured. The default level is SHORT.
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Internal Calls

The Internal Calls command allows you to set whether intercom calls use the call cascade of the 

dialed extension if the extension is busy, unanswered or in do not disturb mode. An intercom 

call is a call from a local extension to another local extension, remote extension or ring group.

1. Choose Options > Internal Calls. The Intercom Calls Options window appears.

2. Select the Intercom calls follow cascade settings checkbox to have an intercom call use the 

call cascade of the dialed extension. Otherwise the intercom call will ring continuously.

Call Back

The Call Back command allows you to set the number of rings the unit will allow before hanging 

up, during an auto call back or prompted call back.

1. Choose Options > Call Back. The Call Back Options window appears.

2. Select the number of rings the unit will allow during a call back before hanging up. Choices 

range from 1 ring to 9 rings.

Caller ID

You can turn off the missed calls indicators here. In offices with busy ring groups, the missed 

call indicators can be an annoyance. To disable missed call indication, uncheck the box and 

press OK.

Dial-by-name Directory

The Dial-by-name Directory command allows you to specify whether the dial-by-name directory 

search will provide results based on first, last, or both names.

The dial-by-name directory is an auto attendant option. Callers can connect to an extension 

using their telephone dialpad to spell the name of the party they wish to speak with.

1. Choose Options > Dial-by-name Directory. The Dial-by-name Directory window appears.

2. Select the desired search option. Choices include first name, last name, or both names. 
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Call Park

When you park a call, by default the system prompt tells you “Call parked at...” and the number 

of the park orbit. Check the Disable ‘Call Parked at’ prompt box to have the system prompt with 

the number of the orbit only.

Set Date & Time

The Set Date & Time command allows you to set the time, date, time zone, and NTP server. See 

“System time” on page 11. 
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Troubleshooting menu

The Troubleshooting menu allows access to diagnostics and advanced settings. Do not adjust 

these settings unless advised to do so by your local dealer or technical support centre. The 

default settings should provide correct operation.

Auto Attendants

The Auto Attendants window allows you to set auto attendant timers. 

1. Choose Troubleshooting > Auto Attendants. The Auto Attendants window appears. 

2. The Single digit fall through time sets a time-out period at the auto attendant for detection 

of additional digits after the first digit — e.g. an extension number. Once the wait time 

elapses, the auto attendant processes the received digits. Selecting immediately limits each 

entry to a single number, and prevents callers from dialing extensions directly. The other 

options allow callers to enter extension and ring group numbers. If the caller dials three 

digits, the auto attendant immediately processes the entry.

Extensions > Regular Analog Extensions

The Extensions > Regular Analog Extensions window allows you to set analog extension timers 

and the volume level. 

If your system does not appear to be functioning properly, first ensure the country where the 

system operates is set correctly in the Registration Selection field of the About page, then save 

your configuration to the system. If this does not resolve the problem, please contact your local 

dealer or technical support centre for assistance.

Do not adjust these settings unless directed by your local dealer or technical support centre. 

The default settings should provide correct operation.

If your system does not appear to be functioning properly, first ensure the country where the 

systemh operates is set correctly in the Region Selection field of the About page, then click the 

Use Defaults button on this window. If this does not resolve the problem, please contact your 

local dealer or technical support centre for assistance.

Do not adjust these settings unless directed by your local dealer or technical support centre. 

The default settings should provide correct operation.

If your system does not appear to be functioning properly, first ensure the country where the 

systemh operates is set correctly in the Region Selection field of the About page, then click the 

Use Defaults button on this window. If this does not resolve the problem, please contact your 

local dealer or technical support centre for assistance.
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1. Choose Troubleshooting > Extensions > Regular Analog Extensions. The Regular Analog 

Extensions window appears. 

2. The Minimum length sets the minimum accepted duration of a valid Flash/Recall signal from 

a local extension. If there are false ring backs after a call, try increasing the Minimum length. 

If the system ignores genuine Flash/Recall signals, try reducing the Minimum length. 

3. The Maximum length sets the maximum accepted duration of a valid Flash/Recall signal 

from a local extension. If the system disconnects on genuine Flash/Recall signals, try 

increasing the Maximum length. If some calls are placed on hold when the user hangs up 

and quickly places a subsequent call, try reducing the Maximum length. 

4. The Phantom Rings timer is used to ignore false Flash/Recall signals before the end of a 

call. If extensions experience false ring backs after users hang up, try increasing the Ignore 

flash/recall signals timer. 

5. The Volume heard at local extensions setting controls the inbound volume level for calls and 

system prompts heard on extensions.

Extensions > IP Extensions

The Extensions > IP Extensions window allows you to set the amount of time between 

registration messages from IP extensions. You can also change the Starting SIP, Base RTP and 

HTTP ports. 

Do not change the following controls unless directed by your local dealer or technical 

support centre.
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Internal Registration Interval

The interval for registration messages from IP extensions within the office.

External Registration Interval

The interval for registration messages from IP extensions outside the office.

Line Appearance Optimization

Activate this if your 350i, 450i and/or 550i phones are experiencing line appearance 

inconsistencies.

External IP Extension Codec Options

Control the audio quality of external IP extensions. For more information on codecs, see 

“Setting codec options” on page 31.

HTTP Port

The default HTTP port is 8484. If required, enter a different port number ranging from 1024 to 

65535. If your system will use a proprietary IP phone as an external IP extension, ensure the 

router maps this port to the unit acting as local proxy.

IP Extension VoIP Ports

The default Starting SIP port is 5000. If required, enter a different port ranging from 1024 to 

65535.

The default Base RTP port is 4000. If required, enter a different port number ranging from 1024 

to 65535.

Time Format

Choose the time format to be displayed on your phones, either 12 Hour (default) or 24 Hour.

Phone Configuration

Click to open a browser with detailed configuration files for each IP extension.
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Fax Detection

The Fax Detection window allows you to set up detection of Fax Over IP and CNG tones. 

1. Choose Troubleshooting > Fax Detection. The Fax Detection window appears.

2. Select the Automatically detect and switch to G.711 for fax over IP checkbox to have the 

unit detect fax over IP and then switch to G.711.

3. Set the number of CNG tones the unit must detect before the auto attendant routes the call 

to the fax machine. Choices are:

• Detect 1 tone — The auto attendant will route the call to the fax machine if the unit 

detects one CNG tone. Select this if fax calls are not being routed to the fax machine.

• Detect 2 tones — The auto attendant will route the call to the fax machine if the unit 

detects two CNG tones. Select this if regular calls are being routed to the fax machine.

Telephone Lines > Audio

The Telephone Lines > Audio window allows you to automatically calibrate the unit to match the 

telephone lines and select the volume level on the lines.

For the best call audio quality and volume levels, your system parameters must be matched to 

your telephone lines. The Telephone Line Audio Optimization area offers calibration to match 

your telephone lines.

1. Choose Troubleshooting > Telephone Lines > Audio. The Telephone Lines - Audio window 

appears. 

Do not change the following controls unless directed by your local dealer or technical 

support centre.
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2. Optimize the unit to match the far end impedance of the telephone lines. Click Optimize 

Lines. The Optimize Lines window appears. Click Run Optimization. 

Telephone Lines > Detection and Timers

The Telephone Lines > Detection and Timers window allows you to set telephone line timers, 

and perform the ring pattern test. 

 

The Line Disconnect timer controls the duration a telephone line may be disconnected before 

the system clears the telephone call. In some cases this may be used by the telephone network 

to indicate a calling party has hung up and the call has ended (also known as Disconnect Clear, 

K-Clear or CPC signal). Incidents of disconnected calls may indicate a faulty telephone line, or 

may be resolved with a longer Line disconnect time setting.

Do not adjust these settings unless directed by your local dealer or technical support centre. 

The default settings should provide correct operation.

If your system does not appear to be functioning properly, first ensure the country where the 

system operates is set correctly in the Region Selection field of the About page, then click the 

Use Defaults button on this window. If this does not resolve the problem, please contact your 

local dealer or technical support centre for assistance.
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To test the ring pattern for incoming calls on telephone lines:

1. Click Ring Pattern Test. The Ring Pattern Test window appears.

2. Click Test Ring Pattern. Call one of the telephone lines. After three rings the window will 

adjust to reflect the results of the test. The time is displayed in milliseconds. 

The Call waiting and other Flash/Recall Based Services timer sets the time required for a 

Flash/Recall signal to activate calling features on a telephone line. If a Flash/Recall signal is not 

successfully engaging telephone company features, try adjusting the timer.

The 3-way calling/Centrex Transfer timer sets the required delay after a Flash/Recall signal 

before the first digit of a telephone number is dialed. This setting may need to be increased if 

same line connect calls are misdirected and the initial digits are not detected by the telephone 

company. The same line connect feature may not be compatible with some telephone 

companys’ 3-way calling features.

VoIP

The VoIP window permits adjustment of ports, timers and network-related settings affecting 

VoIP communications. 

VoIP ports

The SIP server port and starting RTP port can be specified for the SIP server.

UPnP

By default, the system uses Universal Plug'n Play (UPnP) to attempt to automatically open the 

required ports for VoIP communication through supported firewalls. By disabling this feature, 

the ports must be manually configured within your firewall in order for VoIP communication 

to operate.

For information on configuring your router ports for VoIP service providers and external IP 

extensions, see “Firewall settings” on page 14.

Global Dial Plan Codec Options

Control the audio quality for your multiple locations. For more information on codecs, see 

“Setting codec options” on page 31.

Do not change the following controls unless directed by your local dealer or technical 

support centre.
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Firewall Test

The Troubleshooting > Firewall Test window allows you to test the status of each port through 

the firewall. See “Firewall settings” on page 14.

1. Choose Troubleshooting > Firewall Test. The Firewall Test window appears. 

2. Select the services you want to check.

3. Click Test Ports. The system will check the ports of the selected services.

System Information and Diagnostics

This window provides system information and diagnostics for the system as a whole, for local 

extensions, VoIP numbers, your network and memory usage.

System Information

The System Information tab includes general system information, MAC and IP addresses, 

system ID software and firmware versions, languages and uptime.
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Local Extensions

The Local Extensions tab includes status, type, MAC address, IP address and firmware for each 

extension.

VoIP Numbers

The VoIP Numbers tab includes service provider profile information and username, password 

and status for VoIP numbers.

Network

The Network tab includes LAN and WAN configuration details, gateway device information and 

port configuration details. You can run the Check Firewall test from this tab.

Memory Usage

The Memory Usage tab includes memory statistics by function and voicemail memory usage by 

mailbox.

Support Tools > Call Logging Options 

The Troubleshooting > Support Tools > Call Logging Options window provides diagnostic 

logging tools to capture call data and phone system events. These tools are intended for the 

exclusive use of technical support personnel.

1. Choose Troubleshooting > Support Tools > Call Logging Options. The Logging window 

appears.

This feature is intended for the exclusive use of technical support personnel. Do not use this 

feature unless directed by your local dealer or technical support centre.
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2. Select the SIP Trace Capturing url to open a browser interface to permit detailed logging of 

SIP messages for calls to IP phones and/or VoIP lines. 

3. Select the CP Logging url to open a browser interface to permit detailed logging of phone 

system events. 

4. Click OK to exit the Logging window.
Configuration Page 148 FortiVoice v7.31 User Guide

http://www.fortinet.com/


Support Tools > Email Software Configuration Logs

The Troubleshooting > Support Tools > Email Software Configuration Logs window allows you 

to automatically e-mail log files to Customer Support. Only use this feature as directed, after 

receiving a Case ID from Customer Support.

Automatically e-mailing log files requires Microsoft Outlook to be configured as your default 

e-mail client. Note that the e-mail will only include information related to your system.

1. Choose Troubleshooting > Support Tools > Email Software Configuration Logs. The Support 

window appears.

2. Select the files you would like to send to support. Click Next.

3. Enter the Case ID supplied by Technical Support.

If you use a different e-mail client, or don’t have one configured (e.g. you use a web-based 

e-mail service like Hotmail) you can manually e-mail the log files. Enter the Case ID in the 

Subject line. Attach the .zip file listed in the Support window.
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Using your phone system
Receiving calls

With the auto attendant

If you don’t have a receptionist, the auto attendant helps you handle all your inbound calls. 

Once an auto attendant has been configured and recorded, it will follow the instructions given in 

the configuration.

When calls are answered by an auto attendant, callers can: 

• Dial any local or remote extension

• Dial any ring group

• Dial voicemail directly

• Use the dial-by-name directory

• Choose options 0 (9 in some regions), 1, 2, 3, 4, 5 (if configured to perform specific actions)

• Transmit a fax

• Go to a different auto attendant

• Remain on the line to follow an action programmed for that auto attendant

System users can access other options at the auto attendant:

• Call back or call bridge 

• Retrieve voicemail 

• Enter command mode to make system changes 

All these features can be password-protected to avoid unauthorized access.

The system also provides the option of ringing specific extensions or ring groups prior to the 

engagement of an auto attendant. 
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Using an analog extension

This section describes how to use a third party analog phone with the system.

Making calls

Placing an intercom call

An intercom call is a call from a local extension to another local extension, remote extension or 

ring group.

1. Dial the extension number.

If the Intercom calls follow cascade settings checkbox is selected in the configuration, an 

intercom call will follow the call cascade of the dialed extension. Otherwise the intercom call will 

ring continuously.

The dialed extension rings as follows:

• A local extension uses two short rings to identify the intercom call.

• A remote extension rings normally.

• A ring group uses the ring pattern selected in the configuration. The ring group uses the 

same ring pattern for intercom calls and outside calls.

Overhead paging

Overhead paging is a call from a local extension through the optional PA amplifier connected to 

the phone system.

1. Dial *0.

Two-way paging

Two-way paging is a call from a local extension to another local extension that activates the 

speakerphone of the dialed extension. The user at the dialed extension can reply through the 

speakerphone. You can perform two-way paging from a local extension to a FortiFone 

telephone.

1. Dial *84.

2. Dial the extension number.

One-way group paging

One-way group paging is a call from a local extension to another local extension or to a 

ring/page group that activates the speakerphones of the dialed extensions. The users at the 

dialed extensions can't reply through the speakerphone. You can perform one-way group 

paging from a local extension to FortiFone telephones.

1. Dial *85.

2. Dial the extension or ring group number.

Place out-of-office calls from a local extension

1. Dial 9 (0 in some regions) or 81–88 to choose a hunt group. The hunt group gives you 

access to an available line to dial out.

2. If your system requires permissions for outgoing calls, enter your access code.

3. Dial the phone number. 
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Extensions can be restricted to specific hunt groups by using User Privileges. See “Routing and 

blocking” on page 36.

Your extension can also be configured with direct line access. When you pick up the handset, 

you hear the telephone company dial tone and can dial an outside number without dialing a 

hunt group number. See “Direct line access” on page 48. 

If you dial your own extension you will be directed to your voicemail. If your voicemail is not set 

up, you will get a busy signal.

Click-to-Dial from Microsoft Outlook

Dialing directly from Outlook requires the Click-to-Dial utility to be installed on your computer. 

Visit http://support.fortinet.com to download and install the software.

To call a contact from Outlook, follow the Outlook instructions for initiating calls.

Receiving calls 

The steps below apply when an analog extension is ringing. If an auto attendant engages before 

you are able to pick up, the caller can select an option at the auto attendant.

For your local extension

You can answer a call that is ringing your local extension.

1. If the call went through the auto attendant and call screening is enabled:

• Press # to accept the call.

• Press * to reject and re-route the call to its extension‘s call cascade, and then hang up.

For any other local extension

You can intercept a call that is ringing another local extension. 

1. Press *9.

For a specific local extension

You can intercept a call that is ringing a specific extension.

1. Press *7.

2. Dial the extension number.

While you’re on a call

You can intercept a call while connected to another caller.

1. Press Flash or Recall to place the first call on hold.

2. Press *9, or *7 and the extension number to intercept the second call.

3. Once you are finished with the second call or would like to return to the first caller, press 

Flash 5 or Recall 5.

If direct line access is enabled for a local extension, you need to press Flash or Recall before 

dialing any extensions or voice mailboxes.
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Placing calls on hold

1. Press Flash or Recall to place the call on hold.

2. Press Flash or Recall again to take the call off hold.

3. If you have multiple callers on hold or in queue at your extension, press Flash 7 or Recall 7 

to retrieve callers on a first in/first out basis.

If you put a caller on hold using the Hold button on some third party analog phones, you won’t 

be able to access the phone system features while the caller is holding, and the caller will not 

hear music while on hold.

While a call is on hold, your phone will ring once each time the reminder timer expires. See “Call 

Reminders” on page 135.

Transferring calls to an extension

You can transfer a call from a local extension to another local extension, remote extension or 

ring group.

Unscreened transfer

1. Press Flash or Recall to put the caller on hold. 

2. Dial the extension you want to transfer to, and then hang up. The caller is taken off hold 

when the receiving extension answers. If the extension is busy or the call not answered, the 

system can either perform the call cascade’s Busy action or No Answer action, or can ring 

back the extension that transferred the call. See “To local extension tab” on page 133.

Screened transfer

1. Press Flash or Recall to put the caller on hold.

2. Dial the extension number you want to transfer to, and wait for them to answer. 

• If the person at the receiving extension wishes to take the call, complete the transfer by 

hanging up or pressing Flash 4 or Recall 4. The caller is immediately taken off hold and 

connected to the receiving extension. You hear an internal dial tone. 

• If the person at the receiving extension does not wish to take the call, return to the caller 

by pressing Flash 5 or Recall 5. 

• If you dial an extension that is busy or not answered, you can complete the transfer by 

hanging up or pressing Flash 4 or Recall 4. The call will be routed according to that 

extension’s call cascade settings. You hear an internal dial tone. 

Transferring calls to an outside number

You can transfer a call from a local extension to an outside number.

If the telephone line has the 3-Way Calling/Conference service or the Transfer and Clear service, 

and the local extension has enabled Allow the use of same line connect (by dialing 80), the user 

can select hunt group 80 to dial the outside number on the same line the caller is on.

If you handle many calls, you may want to complete or cancel a transfer without hanging up. 

Flash 4 or Recall 4 will complete the transfer and provide an internal dial tone. Flash 5 or 

Recall 5 cancels the transfer and connects you back to the caller.
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Unscreened transfer

1. Press Flash or Recall to put the caller on hold.

2. Dial 9 (0 in some regions) or 81–88 to choose a hunt group.

3. Dial the outside phone number.

4. Press Flash 4 or Recall 4 to complete the transfer. Do not hang up to complete the transfer, 

because this disconnects the call.

Screened transfer

Instead of completing the transfer once you have dialed the outside number, wait until the call is 

answered and ask the recipient if he or she wishes to take the call. If the recipient accepts the 

call, press Flash 4 or Recall 4 to complete the transfer. If not, press Flash 5 or Recall 5 to return 

to the caller.

Parking and retrieving calls

Call park is a feature for placing a call on hold and then retrieving it from another local 

extension. The system has 10 park orbits (500–509).

Parking a call 

1. Press Flash or Recall to put the caller on hold.

2. Press *510 or the Park button or softkey. The system selects the first available park orbit 

(500–509).

3. Provide the park orbit to the person with the parked call (e.g. “Mary, there is a call parked for 

you in 500”).

While a call is parked, your phone will ring once each time the reminder timer expires. See “Call 

Reminders” on page 135.

Retrieving a parked call

1. If direct line access is enabled at your extension, press Flash or Recall to get an internal dial 

tone.

2. Press ** or the Un-park button or softkey and the appropriate park orbit.

Queuing and retrieving callers 

Call queue is a useful feature for placing multiple callers on hold at your extension while you are 

on an existing call.

Queuing callers at a local extension

If an extension is busy and the Busy call cascade is set to queue at extension, incoming callers 

hear one of the prompts below, followed by music (if enabled) while they are on hold:

• If the call came from the auto attendant and the extension has a voice mailbox: “The 

extension you have reached is currently busy. If you wish to continue holding, please remain 

on the line. To leave a voicemail message, press 1, and to return to the main menu, 

press star.”

• If the call came from the auto attendant and the extension has no voice mailbox: “The 

extension you have reached is currently busy. If you wish to continue holding, please remain 

on the line. To return to the main menu, press star.”
Using your phone system Page 154 FortiVoice v7.31 User Guide

http://www.fortinet.com/


• If the call was transferred from another extension and the extension has a voice mailbox, but 

there is no auto attendant on this line with a main menu to return to: “The extension you have 

reached is currently busy. If you wish to continue holding, please remain on the line. To leave 

a voicemail message, press one.”

• If the call was transferred from another extension and the extension has no voice mailbox 

and there is no auto attendant on this line with a main menu to return to: “The extension you 

have reached is currently busy. If you wish to continue holding, please remain on the line.”

While the caller is on hold at your extension, you hear a call waiting beep every 75 seconds. If 

you want to rotate through queued callers, press Flash 7 or Recall 7. The caller you are speaking 

to is placed on hold, and the first caller in the queue is retrieved. If you have multiple callers 

queued, press Flash 7 or Recall 7 to retrieve callers on a first in/first out basis.

If an extension is busy and the Busy call cascade is set to invoke call waiting, callers hear 

ringing (or music if enabled) while the local extension hears a call waiting beep and receives the 

caller ID for the new call. To connect to the new caller, press Flash 7 or Recall 7. To let the caller 

fall through to the next level of the cascade, ignore the beep.

Queuing callers at a ring group

If you want to queue callers at a ring group, configure this action using an auto attendant.

For example, configure auto attendant 1 to queue callers to ring group 301 for technical support 

if they have pressed 5. When a caller presses 5 for technical support, they enter the 

queue immediately.

Every 60 seconds (configurable) the caller hears the following prompt: “Your call is important to 

us. Please remain on the line. To return to the previous menu, press star.” Extensions that are 

part of the ring group and are available will start ringing within 10 seconds of hanging up the 

phone from a previous call. The delay allows time to make a new call or activate Do not Disturb 

as a log out option. After 5 extension rings, available phones will ring once every 16 seconds. 

When you pick up, you hear a prompt that provides the option to accept the queued call by 

pressing # or leave the caller in the queue by pressing * and returning to the dial tone to make a 

new call.

Using call waiting

The call waiting feature is activated by setting the If extension is busy list to invoke call waiting. 

This control is in the Busy tab of the Local Extensions/Fax page. When the dialed local 

extension is busy, the caller hears ringing or music depending on the settings. 

If the phone supports call waiting caller ID (type II signaling), you hear a beep followed by a 

short blip. Depending on your phone, you may hear something similar to a modem noise. This is 

normal. During this notification, the caller ID information is displayed on the phone. The caller 

does not hear the beep. The phone mutes the other side.

If the phone does not support call waiting and caller ID, you hear a beep. When the call waiting 

notification beep is heard, you can either press Flash 7 or Recall 7 to put the current caller on 

hold and answer the new call, or press Flash 5 or Recall 5 to terminate the current call and 

answer the new call. If you do not want to answer the new call, ignore the call waiting beeps. 

The system will direct the caller to the next level of the call cascade for your extension.
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Conference calling

You can set up conference calling between three local extensions, two local extensions and one 

outside caller, or two outside callers and one local extension.

Two local extensions and one outside caller

You do not require access to the telephone company’s 3-Way Calling/Conference service to use 

the conference calling capabilities.

1. Establish a call with an outside party.

2. Press Flash or Recall to place the outside caller on hold.

3. Dial the number of the local extension you wish to conference with.

4. When the extension is picked up, press Flash 6 or Recall 6 to establish the 3-way call.

Two outside callers and one local extension

There are two different methods for this type of conference call. The first method is similar to the 

one above, using only the phone system for the conference function.

1. Establish a call with an outside party.

2. Place the outside caller on hold.

3. Dial 9 (0 in some regions) or 81–88 to choose a hunt group.

4. Dial the number of the other outside party.

5. When the call is answered, press Flash 6 or Recall 6 to establish the 3-way call.

The second method requires the same line connect feature and uses the telephone company’s 

3-Way Calling/Conference service.

1. Establish a call with an outside party.

2. Place the outside caller on hold.

3. Dial 80 to choose same line connect.

4. Dial the number of the other outside party.

5. When the call is answered, press Flash 6 or Recall 6 to establish the 3-way call. 

Call Barge

Call Barge enables a user to join another user’s call. This feature is restricted to calls connected 

via PSTN telephone line to an outside party.

1. Dial *82.

2. Enter the local extension you wish to join.

3. Enter your privilege PIN.

All 3 parties are now joined in a conference.

The conference initiator can disengage the second conferenced party at any time by pressing 

Flash 5 or Recall 5.

Call Barge must be enabled in User Privileges and requires temporary access to a conference 

room.
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Using an IP extension

This section describes how to use a third party IP phone with the system.

Making calls

Placing an intercom call

An intercom call is a call from a local extension to another local extension, remote extension or 

ring group.

1. Dial the extension number.

If the Intercom calls follow cascade settings checkbox is selected in the configuration, an 

intercom call will follow the call cascade of the dialed extension. Otherwise the intercom call will 

ring continuously.

Overhead paging

Overhead paging is a call from a local extension through the optional PA amplifier connected to 

the phone system.

1. Dial *0.

Two-way paging

Two-way paging is a call from a local extension to another local extension that activates the 

speakerphone of the dialed extension. The user at the dialed extension can reply through the 

speakerphone. You can perform two-way paging from a local extension to a FortiFone telephone.

1. Dial *84.

2. Dial the extension number.

One-way group paging

One-way group paging is a call from a local extension to another local extension or to a 

ring/page group that activates the speakerphones of the dialed extensions. The users at the 

dialed extensions can't reply through the speakerphone. You can perform one-way group 

paging from a local extension to FortiFone telephones.

1. Dial *85.

2. Dial the extension or ring group number.

Place out-of-office calls from a local extension 

1. Dial 9 (0 in some regions) or 81–88 to choose a hunt group. The hunt group gives you 

access to an available line to dial out.

2. If your system requires permissions for outgoing calls, enter your access code.

3. Dial the phone number.

4. Depending on your IP phone, press Dial, Send or #. 

Using an external IP extension to call an emergency service number will not send the correct 

address to the emergency operator. We strongly recommend that you apply a warning label to 

any external IP extension stating:

If an emergency call is made from this phone, you must provide your address to the 

emergency operator.
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Extensions can be restricted to specific hunt groups by using User Privileges. See “Routing and 

blocking” on page 36.

Your extension can also be configured with direct line access. When you pick up the handset, 

you hear the telephone company dial tone and can dial an outside number without dialing a 

hunt group number. See “Direct line access” on page 48. 

Receiving calls

If an auto attendant engages before you are able to pick up, the caller can select an option at 

the auto attendant. The steps below apply when you pick up an extension that is ringing.

For your local extension

You can answer a call that is ringing your local extension.

1. If the call went through the auto attendant and call screening is enabled:

• Press #, then press Dial, Send or # to accept the call.

• Press *, then press Dial, Send or # to reject and re-route the call to its extension‘s call 

cascade.

For any other local extension

You can intercept a call that is ringing on any other local extension. 

1. Press *9, then press Dial, Send or #.

For a specific local extension

You can answer a call that is ringing at a specific extension.

1. Press *7.

2. Dial the extension, then press Dial, Send or #.

While you’re on a call

You can intercept a call while connected to another caller.

1. Press Hold to place the first call on hold.

2. Press *9, or *7 and the extension number, then press Dial, Send or #. 

3. Once you are finished with the second call or would like to return to the first caller, 

press Cancel.

Placing calls on hold

1. Press Hold. 

2. If you have multiple callers on hold or in queue at your extension, you can retrieve them on 

a first in/first out basis. Depending on your phone, you can either:

• Press the flashing line key that corresponds to the caller on hold.

• Press Hold and 7, then press Dial, Send or #.

If direct line access is enabled for a local IP extension, you need to press ** before 

dialing any extensions or voice mailboxes.
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Transferring calls to an extension

Unscreened transfer 

1. Press Transfer or xfer to put the caller on hold. 

2. Dial the extension number.

3. Press Transfer or xfer. If the IP phone supports the hang-up transfer feature, hang up the 

phone. Please check the documentation of the IP phone to see if it supports this feature.

The caller is taken off hold when the receiving extension answers. If the extension is busy or the 

call not answered, the system can perform the call cascade’s Busy action or No Answer action, 

or can ring back the extension that transferred the call. See “Transfer Preferences” on page 132.

Screened transfer

To initiate a screened transfer from an IP extension to another local extension, remote extension 

or ring group:

1. Press Transfer or xfer to put the caller on hold. 

2. Dial the extension number. 

• If the person at the receiving extension wishes to take the call, press Transfer or xfer to 

complete the transfer. If the IP phone supports the hang-up transfer feature, hang up the 

phone. Please check the documentation of the IP phone to see if it supports this feature. 

The caller is immediately taken off hold and connected to the receiving extension.

• If the person at the receiving extension does not wish to take the call and you want to 

return to the caller, press Cancel. If this softkey is unavailable, press the flashing line 

button that corresponds to the caller on hold. You can also press Hold and 7, then press 

Dial, Send or #.

• If you dial an extension that is busy or not answered, you can complete the transfer. The 

caller will be directed according to that extension’s call cascade settings. 

Transferring calls to an outside number

You can initiate a transfer from an IP extension to an outside number.

If the telephone line has the 3-Way Calling/Conference service or the Transfer and Clear service, 

and the local extension has enabled Allow the use of same line connect (by dialing 80), the user 

can select hunt group 80 to dial the outside number on the same line the caller is on.

Unscreened transfer

1. Press Transfer or xfer to put the caller on hold.

2. Dial 9 (0 in some regions) or 81–88 to choose a hunt group.

3. Dial the outside phone number.

4. Press Transfer or xfer to complete the transfer. Do not hang up to complete the transfer, 

because this disconnects the call. 

Screened transfer

1. Press Transfer or xfer to put the caller on hold.

2. Dial 9 (0 in some regions) or 81–88 to choose a hunt group.

3. Dial the outside phone number.

4. Wait until the call is answered and ask the recipient if he or she wishes to take the call. If the 

recipient accepts the call, press Transfer or xfer to complete the transfer. If not, press 

Cancel to return to the caller. If this softkey is unavailable, press the flashing line button that 

corresponds to the caller on hold.
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Call park — parking and retrieving callers

Call park is a feature for placing a call on hold and then retrieving it from any other local 

extension. The system has 10 park orbits, 500–509.

Parking a caller

1. Press Transfer or xfer to put the caller on hold.

2. Press *510, then press Dial, Send or #. The system selects the first available park orbit (500–

509). You hear a confirmation indicating the caller has been parked successfully and into 

which park orbit.

3. Provide the park orbit to the person with the parked call (e.g. “Mary, there is a call parked for 

you in 500”).

Retrieving a parked call

1. Press **, the park orbit, then press Dial, Send or #.

Queuing and retrieving callers

This feature is used the same way on analog and IP extensions except for the slight differences 

outlined in the next paragraph.

Some IP extensions display a notification on the screen while the caller is on hold at your 

extension. If you want to rotate through queued callers while you are on the phone, dial 7 and 

press Dial, Send or #. The caller you are speaking to is placed on hold, and the first caller in the 

queue is retrieved. If several callers are queued, dial 7 and press Dial, Send or # to retrieve them 

on a first in/first out basis.

Using call waiting

If the call waiting feature is activated as a Busy option in the call cascade routing for a local 

extension and the dialed extension is in use, the caller hears ringing or music depending on the 

music on hold settings. You hear the following:

• If the phone supports call waiting caller ID, you hear a beep followed by a short blip.

• If the phone does not support call waiting caller ID, you hear a beep. When the call waiting 

notification beep is heard, you can pick up another line and dial 7 and press Dial, Send or # 

to put the current caller on hold and answer the new caller. To return to the previous call, 

press the flashing line key that corresponds to the previous call. On most IP extensions, this 

will put the current call on hold and connect to the other caller.

• To terminate the current call and go back to the other caller on hold, hang up, then go 

off-hook and press the button that corresponds to the flashing line of the caller on hold. If 

you do not want to take the new call, ignore the call waiting beeps. The system will direct the 

caller to the next level of the call cascade for that extension (i.e. send the caller to the 

associated voice mailbox).
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Conference calling 

Two local extensions and one outside caller

You do not require access to the telephone company’s 3-Way Calling/Conference service to use 

the conference calling capabilities.

1. Establish a call with an outside party.

2. Press Conf or Hold to place the outside caller on hold.

3. Dial the local extension you wish to conference with.

4. When the extension answers, press Conf to establish the 3-way call.

Two outside callers and one local extension

There are two different methods for this type of conference call. The first method is similar to the 

one above, using only the phone system for the conference function.

1. Establish a call with an outside party.

2. Press Conf or Hold to place the outside caller on hold.

3. Dial 9 (0 in some regions) or 81–88 to choose a hunt group.

4. Dial the number of the other outside party.

5. When the call is answered, press Conf to establish the 3-way call.

The second method uses the same line connect feature and the telephone company’s 3-Way 

Calling/Conference service.

1. Establish a call with an outside party.

2. Press Hold to place the outside caller on hold. 

3. Dial 80 to choose the hunt group.

4. Dial the number of the other outside party and press Dial, Send or #.

5. When the call is answered, press Transfer to establish the 3-way call.

Call Barge

Call Barge enables a user to join another user’s call. This feature is restricted to calls connected 

via PSTN telephone line to an outside party.

1. Dial *82.

2. Enter the local extension you wish to join.

3. Enter your privilege PIN.

All 3 parties are now joined in a conference.

If you try to initiate a conference call with a 9112i IP phone, but there is no line available, you will 

not hear a busy signal. You will instead be reconnected with the other caller.

Call Barge must be enabled in User Privileges and requires temporary access to a conference 

room.
Using your phone system Page 161 FortiVoice v7.31 User Guide

http://www.fortinet.com/


Programmable phone key functions

FortiFone IP phones have programmable keys. The function and associated resources are 

assigned using the Management software in the Local Extensions/Fax > IP Extension Details > 

Configure Keys page. Supported functions for a phone model typically include most of the 

items listed below.

• Line appearance — Select a telephone line or VoIP number as the resource. The 

corresponding button or softkey will display the status of the line, and allow you to make 

calls with a single press of the button or softkey.

For phones equipped with button lights, the button will light up when the line is in use, flash 

if the line is ringing, or be off when the line is available.

For phones with softkeys, a status icon and line ID will be displayed beside the softkey. 

The display will show an off-hook icon when the line is in use, show a ringing icon when the 

line is ringing, and show an on-hook icon when the line is available.

• Extension appearance — Select a local extension as the resource.

The corresponding button or softkey will display the status of the selected extension, and 

allow you to call the extension with a single press of the button or softkey.

For phones equipped with button lights, the button will light up when the selected extension 

is in use, flash if the extension is ringing, or be off when the extension is available.

For phones with softkeys, a status icon and extension call ID will be displayed beside the 

softkey. The display will show an off-hook icon when the selected extension is in use, show 

a ringing icon when the extension is ringing, and show an on-hook icon when the extension 

is available. The extension call ID is also be displayed.

• Queue appearance — Select a local extension as the resource. The corresponding button or 

softkey will indicate whether calls are queued at the selected extension, and allow you to 

pick up the oldest queued call with a single press of the button or softkey.

For phones equipped with button lights, the button will flash if calls are queued for the 

extension, or be off when there are no queued calls.

For phones with softkeys, a status icon, extension number and “Q” will be displayed beside 

the softkey. The display will show a ringing icon if calls are queued for the extension, or an 

on-hook icon when there are no queued calls.

• Voicemail — Do not select a resource. Press the button or softkey to access the voice 

mailbox of the . Lights or icons are not used for voicemail keys. Note: You can also access 

Voicemail by pressing **#.

• DND — Do not select a resource. Press the button or softkey to toggle Do Not Disturb mode 

on or off. Lights or icons are not used for DND keys. Note: You can also toggle DND mode by 

pressing *62#.

• Park — Do not select a resource. Press the button or softkey to put the call on hold, in the 

next available park orbit. The system will respond with the park orbit number (500 to 509). 

Lights or icons are not used for Park keys. Note: You can also Park a call by pressing  

*510# on a 350i, or  *510# on a 450i or 550i.

• Un-park — Do not select a resource. Press the button or softkey, select the park orbit 

number (500 to 509), then press Unpark to retrieve the call. Softkey displays will show the 

parked call ID beside the orbit number. Lights or icons are not used for Unpark keys. Note: 

You can also Unpark a call by lifting the handset, pressing **, dialing the park orbit number, 

then pressing #.

• Pickup any — Do not select a resource. Press the button or softkey to answer a call from an 

outside number ringing any extension. Lights or icons are not used for Pickup keys. Note: 

You can also pick up a call by pressing *9#.
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• Pickup ext — Do not select a resource. Press the button or softkey, dial an extension, then 

dial # (or softkey again) to answer a call from an outside number or extension ringing the 

selected extension. Lights or icons are not used for Pickup keys. Note: You can also pick up 

a call at a selected extension by pressing *7, dialing the extension, then pressing #.

• Intercom page — Do not select a resource. Press the button or softkey, dial an extension, 

then press # to page the extension in Intercom mode. The intercom page function can only 

page FortiFone telephones. Lights or icons are not used for Page keys. Note: You can also 

page a FortiFone telephone by pressing *84, dialing the extension, then pressing #, or the 

Dial key or softkey.

• Overhead page — Do not select a resource. Press the button or softkey to connect to an 

attached external PA system. Lights or icons are not used for Page keys. Note: You can also 

page the external PA system by pressing *0#.

• Queue (show list) — Do not select a resource. Press the Queue softkey, select a queued call, 

then press Retrieve to connect to the selected call. This function is only available when 

programmed as a function key on supported phone models.

• Phone book access — Select the phone book record two-digit speed dial number as the 

resource. Press the button or softkey to place a call using the contact information from the 

associated phone book record. When the button is pressed, it will light up for the duration of 

the call. This function is available on the 350i, 450i and 550i models.

• User Defined (phone) — The button or softkey function is assigned using the phone's 

configuration options, and is not assigned using the Management software.

• Call Recording (360i/460i/560i only) — Select Call Recording from the pulldown menu. Press 

the button to start call recording during a call. The light will flash and a tone will be played 

when call recording is started. Press the button to stop recording. Recorded calls will be 

saved to the extension’s voice mailbox.

• None — The button or softkey is not programmed.

Forwarding calls out of the office

Automatic call forwarding

The auto attendant can forward an office call to a remote extension. Use the auto attendant 

message to prompt callers to select your remote extension number(s). (e.g. “To speak to John 

Smith, dial 211.”)

Manual call forwarding

If you have answered a call at a local extension, you can forward the call to a remote extension.

1. Put the call on hold at the local extension.

2. Dial the remote extension number (e.g. 211) to which you want the call forwarded.

3. Hang up an analog extension or press Transfer or xfer on an IP extension. 

The call is handled according to the call cascade options of that remote extension.

Conditional call forwarding

If the auto attendant answers a call and the caller selects an extension or ring group number 

that is busy or is not answered, the auto attendant can forward the call to a remote extension. 

Conditional call forwarding is configured in the Management software using the call cascade’s 

No answer or Busy settings for each local extension, remote extension and ring group.
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Transferring calls from a remote extension

You can forward calls from a remote extension without using Centrex or 3-way calling services. 

Calls can be transferred to any local or remote extension, ring group or voice mailbox. This 

feature also applies to VoIP numbers.

1. Press ** to place a call on hold at a remote extension anytime during a conversation. You 

hear the same dial tone as at a local extension and have the following three possibilities:

• Press ** to retrieve the call placed on hold.

• Dial any local extension, remote extension, voice mailbox, VoIP location or ring group.

• If the system is configured to perform a blind transfer, the system plays “Call 

Transferred — Goodbye.” and then hangs up.

• If the system is configured to allow call screening, determine whether the other 

person wants the call, and then press **4 to complete the transfer or **5 to cancel the 

transfer and return to the caller.

Screening options for forwarded calls 

The screening options for call forwarding are configured in the Management software using the 

Answered tab in the Remote Extensions page.

Forwarding calls with screening

When play accept/reject prompt is configured in the Answered call cascade option in the 

Remote Extensions page, the system plays a pre-recorded prompt to callers asking them to 

hold and then dials your call forwarding number. When you answer the forwarded call, you hear 

a prompt saying: “You have a forwarded call. To accept the call, press #. To reject the call, 

press *.” If you reject the call, it is routed according to the call cascade option specified next to 

If a call is rejected from this ext.

When play caller’s name first is configured in the Answered call cascade option, the system 

plays a pre-recorded prompt to callers asking them to record their name at the sound of the 

tone. The system asks the caller to hold and dials the call forwarding phone number. When you 

answer the forwarded call, the system plays a pre-recorded prompt saying: “This is call forward, 

you have a call from...” and plays the recording of the caller’s name. To accept the forwarded 

call, press # on your telephone keypad, re-route the call to its call screening call cascade 

options by pressing *.

When either screening option is used, music on hold is enabled and you are not using the 3-way 

calling feature (Same Line Connect) to forward calls, the caller hears music while the system is 

waiting for the remote extension to accept the call. 

If a forwarded call is not answered or the line is busy, the system:

• follows the remote extension’s No Answer or Busy call cascade action. If the call was 

manually forwarded, this action can be changed to ring the extension back to the person 

who performed the transfer.

Using the voicemail system

Internal music on hold, voicemail, and the auto attendants use the memory of the phone 

system. If you need to expand the memory, talk to your reseller.

There is a limit of 99 voicemail messages per mailbox, so users should delete messages before 

the mailbox fills up.
Using your phone system Page 164 FortiVoice v7.31 User Guide

http://www.fortinet.com/


Activating voice mailboxes

You can activate voicemail with a mailbox, as an announcement, or you can deactivate it. There 

are three types of voice mailboxes:

• Local extension mailboxes are associated with local extensions. All local extensions are 

activated with a respective mailbox by default. 

• Remote extension mailboxes are associated with the remote extensions. If you activate a 

remote extension, the mailbox is activated by default.

• General voice mailboxes are not associated with extensions.

Callers can reach voice mailboxes from a call cascade, be transferred from a local extension or 

have announcements played through the auto attendant.

If you want incoming calls to go straight to a voice mailbox after a specified number of rings, 

program an auto attendant to answer the line and then route the call to voicemail.

To leave a message from an analog extension:

1. Press * and the mailbox number. 

To leave a message from an IP extension:

1. Press * and the mailbox number and press Dial, Send or #.

To transfer a caller directly to voicemail from an analog extension:

1. Press Flash or Recall *, the mailbox number and hang up.

To transfer a call to a voice mailbox from an IP extension: 

1. Press Transfer or xfer *.

2. Enter the mailbox number.

3. Press Transfer or xfer to complete.

4. Press Dial, Send or #.

When a caller presses # after leaving a message or after 2 minutes have elapsed, the system 

plays a prompt asking callers if they wish to keep the message, listen to the message or 

re-record the message. Callers can dial 0 (9 in some regions) and the system directs the call 

according to the settings of that mailbox.

Retrieving messages and accessing a voice mailbox

The first time you access your voice mailbox, you are prompted to assign a password, record a 

greeting and record your name for the dial-by-name directory. 

For the general mailboxes, there are no directory listings and you are not prompted to record a 

name. If you wish to have your name in the company directory, use the mailbox associated with 

its extension, as the directory is related to the extension’s mailbox. When your mailbox has 

been set up, you access it through the prompt instructions.

If a new message is left in a local extension mailbox, the system plays a stutter dial tone when 

the handset is picked up (not applicable to the 850i). On some phones, the message waiting 

light flashes. Selected phones will also show a message waiting counter, and some display the 

number of new messages stored in the mailbox(es) associated with that extension. 

1. If direct line access is enabled, be sure to press Flash or Recall before trying to access your 

mailbox. From a Grandstream or Polycom IP extension, press MSG or Messages button.

2. Press **# from a local extension or ** and the mailbox number at the auto attendant if you 

are dialing from an outside location. From an IP extension, press Dial, Send or #.
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3. Dial 1 to listen to messages.

By default, the system starts with newest message before it plays the older ones. While the 

message is playing or after the message has finished, you can dial the following: 

4. Dial 2 to change greeting options.

This allows you to record a new personal voicemail greeting. The default greeting is: “The 

extension you have reached is unavailable at this time. Please leave a message after the 

tone”.

While recording your greeting or announcement, remember that callers can press * to return 

to the auto attendant, if the call came from the auto attendant. When they are done 

recording, they can press # for more options. You may want to give your callers these 

options for their convenience. In local extension mailbox options, 0 (9 in some regions) can 

be configured as an option for additional routing.

5. Dial 3 to change personal options.

• change your current password 

• turn the auto date and time stamp on/off 

• set up or change pager and remote phone notification 

By default, the auto date and time stamp is on. This information is played at the end of each 

message. If you have caller ID service, the phone number is displayed with the time 

and date.

6. Dial 4 to record your name for the dial-by-name directory.

If you haven’t recorded your name for the directory or if you wish to change the recording, 

dial 4. The dial-by-name directory is accessed at the auto attendant according to your 

configuration. Callers are directed to enter the first 3 letters of the employee’s name. The 

system finds the exact or closest match and plays the recorded name with the extension 

number, giving callers the option to connect to that extension. 

7. You can transfer a caller to voicemail by pressing Flash or Recall ** and entering the mailbox 

number. From an IP extension, press Transfer or xfer + mailbox + Dial, Send or #.

1 to rewind 10 seconds

11 to rewind to beginning of the message

3 to skip ahead 10 seconds

33 to skip to the end of the message

5 to listen to the time and date stamp

6 to forward the message

7 to delete a message

9 to save a message

* to back up one level

# to skip to next message, leaving new messages as new

You must record your name in order for the extension to be included in the 

dial-by-name directory.
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Using Voicemail broadcast

Voicemail broadcast distributes a recorded message to a group of voice mailboxes. You can set 

up to ten voicemail broadcast groups system-wide. Voicemail broadcast groups must be 

configured before use. See “Voicemail Broadcast” on page 87 for configuration instructions.

To send a broadcast voicemail, dial * + the voicemail broadcast group number and follow 

the prompts.

Recording an announcement on a local extension

An announcement is a recorded message providing information to callers. It can be recorded 

using your phone as a voicemail message or loaded as an audio file. The system hangs up after 

playing an announcement. Callers have the option of pressing * during an announcement to 

return to the auto attendant. Callers can also dial 0 (9 in some regions) to perform other actions 

if this is configured in the voicemail options.

You might include in the announcement a mention of the selections a caller may press and leave 

a section of silence at the end to give the caller time to make a selection.

To record an announcement, access a voice mailbox and select option 2 to change greeting 

options as described in “Retrieving messages and accessing a voice mailbox” on page 165.

Pager and cell phone notification

When a new message is left in a voice mailbox, it can notify a pager, cell phone or a 

remote number. 

You can configure the system to notify you for every new message or for only the first new 

message received since the last time you accessed new messages.

If you use remote phone notification, you can accept or reject the notification call when 

you answer. 

• Press # to listen to messages.

• Press * to postpone listening to messages.

Music on hold

The system can play music to callers when they are on hold, parked or queued. The music 

played is provided by the source you have connected to the music jack or from a sound file (8 

KHz, 8 bit, mono, u-law, .wav format) stored on the unit(s). When a sound file is loaded on one 

of the systems, it is duplicated to all units on the LAN. 

Music on hold and call forwarding to remote extensions 

If you are using the telephone company’s 3-Way Calling/Conference service with the same line 

connect feature to activate the phone system’s call forwarding feature, callers do not hear 

music on hold while they are being forwarded to a remote extension. The caller is put on hold by 

the telephone company’s central office switch rather than by the phone system, and the caller 

hears silence while being transferred.

A system prompt indicates that callers will hear silence while the system is locating their party. 

This prompt explains to callers why there is silence for an extended period of time before 

connecting to the remote extension. This prompt cannot be disabled. 

If you have two or more units on a LAN, we recommend that you use a .wav file. If you use an 

external audio source, connect it to each phone system unit. Use 1/8" audio splitters, which are 

available at most electronics stores.
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Switching modes 

Switching modes manually

Use telephone keypad commands at a local extension or at the auto attendant to switch modes.

Locally

1. Enter one of the following commands:

• ***30 + # to hear the current mode.

• ***31 + # to enable Mode 1.

• ***32 + # to enable Mode 2.

• ***33 + # to enable Holiday Mode.

Remotely

1. Call into the system.

2. Enter command mode by pressing # during the auto attendant.

3. Enter the system password, followed by #.

4. Enter one of the following commands:

• 30 + # to hear the current mode. 

• 31 + # to enable Mode 1.

• 32 + # to enable Mode 2.

• 33 + # to enable Holiday Mode.

Switching modes automatically

Use the Management software to set up automatic mode switching. See “Scheduling” on 

page 10.

If you switch modes manually, the system will automatically switch modes during the next 

scheduled mode change.

Ensure the Management software is closed during automatic mode switching, or if an 

administrator is switching modes remotely. In these cases, the mode cannot switch while the 

Management software is open.

Note that the mode can switch while the Management software is open, if you are switching 

modes using the software.
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Using call bridge and call back

Working together, call back and call bridge act as your personal long-distance operator. 

Whether you are across town or around the world, these two features allow you to place calls 

from your office telephone line.

You can make a call to the phone system, access a telephone line connected to it and enter the 

number you want to dial. This is especially useful when you are out of the office with your cell 

phone and need to make a long-distance call. You can avoid the long-distance cell rates by 

making a local call to the system and access your office savings plan through call bridge.

Using call bridge

1. Dial into a telephone line. 

2. When the auto attendant answers, select a hunt group — 9 (0 in some regions), 81–88 or 

Same Line Connect 80. 

3. Enter your account password. If you are using Same Line Connect and your line supports 

the 3-way calling/conference service, you are prompted to enter the phone number.

4. When you have completed your call, do one of the following:

a. Make another call by pressing ##.

The system disconnects you from the call in progress. You can dial another number or 

redial the same number. 

b. Activate the auto attendant by pressing #*.

The system ends the call bridge session and activates the auto attendant. When the 

auto attendant message begins to play, you have the following options:

• Press # to enter command mode

• Dial 6 to change/enter call back settings

• Dial a local or remote extension or a ring group. This option allows you to contact 

someone in your office, check your voicemail, etc.

c. End the call bridge session by hanging up. This disconnects you from the system. To 

ensure the system disconnects at the end of a call bridge session, press ## before 

hanging up.

The call bridge phone number you dial can be local, long-distance, toll free (800 and 888) or 

international. Enter the phone number as you would in your office. For long-distance calls, 

include the 1, country code and area code.

Using call back

The call back feature allows you to initiate the system to call you at a specified phone number. 

This gives you access to the following:

• Call bridge

• Local extensions, remote extensions and ring groups

• Voicemail 

• Configuration settings

Using call back involves 3 steps:

1. Call your system phone number to activate call back.

2. Answer and accept call back. The system calls you back within 30 seconds.

3. At the auto attendant you can choose to perform call bridge, dial an extension, access and 

retrieve voicemail or configure your system.
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Activating call back

There are two ways to activate call back from your out-of-office location.

Using prompted call back activation

1. Dial your system’s phone number. 

2. Let the line ring until the auto attendant answers.

3. To initiate call back at the current call back number, dial 61 on the telephone keypad, and 

then hang up. The system will call you back and then prompt you for your password.

4. To initiate call back at a new call back number, dial 62 on the telephone keypad. The system 

will prompt you for your password. Enter your password and the new call back number, and 

then hang up. The system will call you back and then prompt you for your password. 

Using auto call back activation

1. Dial one of the call back phone numbers that has been configured for auto call 

back activation.

2. Let the line ring at least once but no more than three times and hang up before the call 

is answered.

3. Within 20 seconds, the system calls your auto call back number. 

Accepting the call back

There are two ways to accept a call back.

Directly answering the call back

1. Answer the call and press #.

If required, enter your password. This option is used when you have a direct line to your call 

back phone number.

Using the announced message option

The Use announced message option allows the call back from the system to reach you when 

you are in a hotel or an office where calls are intercepted by a receptionist or switchboard 

operator. When the call back is answered, the system begins playing your pre-recorded 

message (e.g. “Please forward this call to Bob Smith in room 312”). The message is repeated for 

2 minutes.

1. When the call is forwarded to you, press # and enter your password on the telephone 

keypad to accept the call back. If the call back is not accepted within the initial 2-minute 

period, the system disconnects the call back.

When you accept the call, you hear the auto attendant. You can select to check your voicemail, 

ring an extension, use call bridge or enter command mode.

For prompted call back, the system always dials the last prompted call back number entered. If 

you do not have the auto attendant answer a line, a generic system auto attendant will answer 

after 15 rings. You can then dial 6 to access the call back settings.

It is important to remember that all call back settings must be configured to use auto call back. 

Please ensure the auto attendant for the line using call back does not answer before 4 rings.
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Using Conference Bridge

The system supports 10 conference bridge accounts that will allow up to 8 participants to join a 

conference. 

All participants get a number to dial when they call into the system to enter the conference area. 

The moderator creates another access code for participants to enter their particular conference.

Create a conference bridge number

1. Go to the Conference Bridge page.

2. Check the Activate Conference Bridge checkbox.

3. Assign a conference bridge number. This is a unique 3-, 4- or 5-digit number, depending on 

your dial plan.

4. Assign moderator access codes. Under Moderator Codes, select 1 of the 10 conference 

numbers and assign a code. Give the code a label so you can remember what it's for.

5. Assign a lifespan to participant access codes in the Participant access code expires in: 

pull-down menu. The participant access codes are assigned by the moderators.

Assigning participant access codes

1. The moderator calls into the conference area by entering the conference bridge number 

from a local extension.

2. Follow the prompts to create a new participant access code.

The moderator distributes the conference bridge number and the participant access code to the 

participants prior to the conference.
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Call Detail Record Logging
Introduction

This chapter covers the setup and retrieval of call detail records (CDRs), which are records 

generated by calls through the phone system.

The unit can store the CDRs. The system can automatically e-mail the CDRs, or you can 

manually retrieve them with the Call Reporting licensed add-on application or a web browser.

If multiple units are networked on a LAN, the CDRs from all the units are stored on one unit. The 

unit stores approximately 6000 records in a circular buffer. This means that after about 6000 

calls, the oldest records will be deleted and new ones created. On a very busy system, 6000 

records may only cover a couple of days, but on a system with less traffic, 6000 records may 

cover more than a month.

Enabling call detail record logging 

1. Choose Tools > Call Logging Output (CDR). The Call Logging window appears. 

2. Select how the unit will process CDRs. Choices are:

• Deactivated — CDRs are neither stored nor sent to the computer.

• Store to file on unit — CDRs are stored in the unit. Selecting this enables the Unit area 

and the Email Log File area.

Unit

The Unit area allows you to select the unit that will store the CDRs. It is enabled when you select 

Store to file on unit.

1. Select the unit that will process the CDRs. Only active units are available.

Email log file

The Email Log File area allows you to have the system regularly e-mail a log file containing the 

CDRs. It is enabled if you selected Store to file on unit.
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Note that if you want the system to e-mail a log file, you must configure the outgoing mail server 

(SMTP). See “Email Service” on page 19.

1. To have the system e-mail the log file, select the Email log file checkbox.

2. Enter the Email Address.

3. Select the Time to send.

4. Select the Days to send.

Retrieving call data records

There are two methods for retrieving CDRs:

• Call Reporting licensed add-on application

• Browser

Call reporting

The Call Reporting licensed add-on application automatically connects to the unit, downloads 

the CDRs, and builds detailed reports of call activity. The application requires the Store to file on 

unit setting in the Call Logging window. 

Browser

You can connect to the unit and download the CDRs using a browser. Retrieving the CDRs 

using a browser requires the Store to file on unit setting in the Call Logging window.

1. Select the IP Configuration page in the Management software, and note the Unit IP Address 

(e.g. 192.168.1.102) where the CDR is being stored.

2. Select the Administration page in the Management software, and note the System name. 

You will also require the System password.

3. Enter the following into the Address field of a web browser: http://, followed by the unit 

IP address, followed by :8484/ (e.g. http://192.168.1.102:8484/). The Log in 

window appears.

4. Enter the system name in the User Name field of the Log in window, and the system 

password in the Password field. The browser then shows the Welcome screen.

5. Click the Call Detail Record (CDR) Management link. The browser shows the Call Detail 

Record (CDR) Management screen.
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6. Scroll down to the Download CDR section.

7. You can either right-click the Download CDR link to save the information to your PC, or can 

click the link to view the current information.

8. Once the CDR file has been downloaded, scroll down to the Clear CDR section.

Analyzing the data 

The data can be viewed either through the web interface or downloaded into a spreadsheet 

(e.g. Excel) as a tab delimited text file. The log is divided into 12 columns identified by numbers: 

Each column contains specific information related to the current state of the call. The following 

is a list of the columns with a description:

1. Type — This column can contain the following characters:

• I — Inbound call

• T — Transfer state

• O — Outbound call

• B — Bridged call. For example, a call in on one line that is forwarded over another line. 

This can include calls forwarded to remote extensions.

• X — Blocked call

• A — Account number assigned to the call with the same log #

• D — Dropped / Abandoned call.

2. Log — This column indicates log number for the call. For the duration of the call, the log 

number remains the same. The event number will increment with each change of state. The 

first digit of the log number indicates on which unit the event originated.

3. Event — This column tracks various state changes of the call. For example, when an auto 

attendant answers, the counter might be 1. When the caller selects an extension, the 

counter increments to 2, etc.

4. Date — This column shows the date of the call (MM/DD/YYYY).

We recommend that you clear the unit immediately after downloading the CDRs. The unit will 

then start saving data to a new file. This allows easier viewing and analyzing of the captured 

information.

1. Type 5. Time 9. Caller ID Name

2. Log 6. Duration 10. Line

3. Event 7. Connection 11. Account Number

4. Date 8. Phone Number 12. User
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5. Time — This column contains the time that the call entered a specific state. The time is 

displayed in 24-hour format (HH:MM).

6. Duration — This column indicates the total time the call was in this state/event. The time is 

displayed in 24-hour format (HH:MM:SS).

7. Connection — This column indicates where the call was for each event. This includes auto 

attendants, voicemail, extension ringing or queuing.

• Ex = Connected to extension x

• A0x = Connected to auto attendant x (x = 01 to 20)

• Rx = Ringing at extension x

• RCO = Ringing at telephone line.

• Qx = Queued at extension x

• Hx = Call on hold at extension x

• Mx = Connected to voice mailbox x

• Cxy = Forwarded out on unit x line y. (See “10. Line” below for more details).

8. Phone Number — This column displays the phone number of the inbound or the outbound 

caller if available.

9. Caller ID Name — This column displays the name of the caller if available. 

10. Line — This column indicates on which unit and line the call came in or out. The format of 

this information is unit and line number. Lines 01–08 are telephone lines and 09–16 are 

VoIP lines. 

Example: 101 — unit 1, line 1

203 — unit 2, line 3

110 — unit 1, VoIP 2

11. Account Number — This column contains an account number that the user can assign after 

a call. This allows you to group calls together that may have been placed over time to 

calculate the total amount of time spent with a particular customer. The account number 

can be a numerical code up to 15 digits long.

To assign an account number after a call has been completed, dial *88. When prompted, 

dial <Account Number> + #. 

If Direct Line Access is enabled on an extension: 

• Analog extension — press Flash or Recall, then dial *88. When prompted, dial <Account 

Number> + #.

• IP extension — press **, then dial *88. When prompted, dial <Account Number> + #.

12. User — If Permissions are enabled, this column shows the code name associated with the 

access code used to dial out.

The data can be imported into any call management software or an Excel spreadsheet as a tab 

delimited text file. After the import, the data can be grouped and tallied based on the criteria set 

forth.

Example: 

1. Total line usage for a day 4. Average call times

2. Number of inbound calls 5. Number of calls per line

3. Wait times
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VoIP Information
Connecting to a network

Each location requires a high-speed connection to the Internet or private IP network that is 

sufficient for VoIP calls.

Connecting to local and IP networks

Set up a LAN (local area network) with an Ethernet switch, router, and modem or gateway. The 

Ethernet switch can be integrated into the router. Connect a computer to the LAN for 

configuring the phone system and other equipment. Use the provided RJ-45 Ethernet cable to 

connect the phone system to the LAN. To ensure reliability, all equipment should be connected 

to a UPS (uninterrupted power supply).

Figure 1: Local and IP network setup

Confirming network capacity

Ensure the LAN in each location has a reliable high-speed broadband connection to the Internet 

or private IP network. The quality of VoIP calls, especially on mixed voice and data networks, 

depends on high data-transfer rates across the network. The limiting factor is the upstream 

bandwidth to the ISP (Internet Service Provider). ‘Lite’ broadband connections (128 Kbps or 

less) are not suitable for simultaneous voice and data traffic.
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Configuring IP addresses

Setting the system IP settings

Each system must be configured with a local IP address. These addresses are used to direct 

VoIP calls to the appropriate location.

1. In the Management software, select the IP Configuration page. By default, Obtain IP and 

DNS information automatically is selected and the area shows IP addresses from the router.

2. Change Obtain IP and DNS information automatically to Use configured IP and DNS 

information in order to lock in the IP addresses.

3. In some cases, the System IP Settings area may be blank because your router has not 

delivered the IP addresses. If so, enter the following IP addresses from your 

LAN administrator:

a. Enter a static IP address for each system in the Unit IP address boxes.

b. Enter the Subnet mask for the LAN. This address determines the subnet that the unit IP 

addresses belong to.

c. Enter the IP address of the Default gateway on your network. A gateway is a hardware 

device that connects the office network to the Internet. The router may act as 

default gateway.

d. Enter the IP address of the Preferred DNS server. DNS is a service that is used to resolve 

a domain name to an IP address. The router may act as DNS server.

e. If applicable, enter the IP address of the Alternate DNS server.
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Setting the public IP address

If you are setting up an external IP extension or multiple locations, you must configure a public 

IP address for the system. Some service provider VoIP networks also require the system to have 

a public IP address.

1. Set the Type of public address. Choices are:

• Dynamic public IP address — This is the default setting. Your ISP (Internet Service 

Provider) will assign different public IP addresses to your location. The system will check 

its public IP address every few minutes. When the public IP address changes, the 

system will automatically use the new one, in order to manage VoIP calls properly.

• Static public IP address — A static IP address doesn’t change. It’s assigned by your ISP.

If Static public IP address is selected, the window allows you to enter the Current public IP 

address.

2. If you selected Dynamic public IP address, enter the Public domain name. Get the public 

domain name from your ISP.

A DDNS (Dynamic Domain Name Service) provider such as www.dyndns.com matches your 

dynamic IP addresses to your public domain name, so your multiple locations and external 

IP phones will continue to work when the IP address changes.

If your router supports DDNS, ensure it supports your DDNS provider, and configure it to 

update the DNS servers.

If your router does not support DDNS, download one of the applications specified on 

www.dyndns.com. To update the DNS servers, the application needs to run on a PC 

connected to the same LAN as the phone system.

3. If you selected Static public IP address, enter the Current public IP address from your 

Internet Service Provider. Leave the Public domain name box blank.

If the system is not behind a router, or if a private virtual network is used, the public IP 

address is the local IP address of the system acting as local proxy.

Note that it will take up to one minute for the new static public IP address to take effect.

4. Record the Current public IP address or the Public domain name.

If you are setting up an external IP extension, you will need the public IP address or public 

domain name of the system.
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Configuring the router

The Firewall Settings area of the IP Configuration page displays the type of gateway device (i.e. 

the type of router), the IP address of the gateway (i.e. router), and whether router configuration 

is required.

A router is a gateway between the local area network and the Internet. Most routers have a 

firewall to block unwanted data from the Internet. For voice data to reach the phone system 

through the firewall, port forwarding is required.

If you are setting up external IP extensions, or a VoIP service that doesn’t handle port 

forwarding, port forwarding is required.

If port forwarding is required, and your router supports uPNP (Universal Plug and Play), ensure 

uPNP is enabled. The system will use uPNP to automatically set up port forwarding, and the 

Automatic (uPNP Enabled) link will appear. No router configuration is required.

If port forwarding is required but your router doesn’t support uPNP, or automatic port forwarding 

doesn’t work, the Manual Port Mapping Required link will appear. You will need to configure the 

router as described below.

1. Select the IP Configuration page.

2. If required, click the Manual Port Mapping Required link. The Manual Port Mapping window 

appears. It lists the packet type, port number, IP address and protocol of each required 

port.

3. To access the router configuration:

a. Click the link containing the IP address of the gateway. The default browser starts, and 

prompts you for the router’s user name and password.

b. Enter the router’s user name and password. The browser shows a setup screen.

c. Navigate to the screen used to set up port forwarding. See your router documentation.

d. Set up port forwarding using the information from the Manual Port Mapping window. See 

your router documentation for instructions on how to map ports. For information on 

configuring routers and mapping ports, visit http://www.portforward.com/.
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4. To check the status of each port through the firewall, click Check Firewall. The Firewall Test 

window appears.

5. Select the services you want to check.

6. Click Test Ports. The system will check the ports for the selected services.
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Configuring the router manually

If you cannot access the router configuration through the IP Configuration page, configure the 

router manually.

1. Open the router configuration and navigate to the screen used to set up port forwarding. 

See your router documentation.

2. In the Management software on the IP Configuration page, click the Manual Port Mapping 

Required link.

3. Map the port indicated for SIP (VoIP) signaling.

If required, you can map a different port. Select Troubleshooting > VoIP and enter the port in 

the SIP signalling port field.

Map the rest of the ports to the IP addresses indicated in the Manual Port Mapping window. 

If required, you can map different ports. Select Troubleshooting > VoIP.

4. Map ports 9393, 8485 and 8486 (Type: TCP) to the unit acting as local proxy to allow remote 

configuration of the system.

5. If available, enable Quality of Service (QoS) to give voice traffic priority over data.

6. Save the configuration to the router.
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External IP extensions 

An external IP extension is an IP phone located outside the office. It is configured as a local 

extension of a system, but connects over the Internet or private data network. A user can 

receive or place a call with their external IP extension through the system to the standard 

telephone network, or to a VoIP network.

For example, the following illustration shows external IP extension 151 at a home office, and 

152 at a branch office. The external IP extensions connect to the phone system at the main 

office over the Internet. In this example, a user can receive or place a call with their external IP 

extension through the phone system to the standard telephone network.

Figure 2: External IP extensions

Before proceeding, ensure you have:

• Connected the system at each location to a network (page 176).

• Configured local and public IP addresses (page 177).

• Configured the router (page 179).

To set up an external IP extension:

1. Add the external IP extension, as described in “Adding IP phones” on page 55.

2. Verify operation of the external IP extension:

a. Select the Extension/Fax page.

b. Select the external IP extension.

c. Confirm Extension status is Registered, and the phone’s IP address appears in the IP 

Extension Details area.  

3. Optionally, set the Time zone of the extension.

Using an external IP extension to call an emergency service number will not send the correct 

address to the emergency operator. We strongly recommend that you apply a warning label to 

any external IP extension stating:

If an emergency call is made from this phone, you must provide your address to the 

emergency operator.
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4. Optionally, perform advanced VoIP configuration:

a. All VoIP lines are shared by default. You can reserve VoIP lines for the external IP 

extensions. See “Reserving VoIP lines” on page 190.

b. External IP extensions use G.711µ as their preferred codec. This can be changed under 

Troubleshooting > Extensions > IP Extensions.

Service provider VoIP network

The service provider acts as the SIP server. The service provider assigns the VoIP numbers and 

VoIP configuration parameters.

For example, the following illustration shows a service provider VoIP network.

Figure 3: Service provider VoIP network

To reach an outside party, the user dials the hunt group number associated with the service 

provider profile, and then dials the phone number.

To reach a local extension, an outside party dials the VoIP number that was assigned to the 

system by the service provider.

Before proceeding, ensure you have:

• Connected the system at each location to a network (page 176).

• Configured local IP addresses (page 177), and public IP addresses if required.

• Configured the router (page 179).
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Setting up a service provider profile

A service provider profile contains the registration details for connecting to the service 

provider’s SIP server. 

1. Select the VoIP Configuration page.

2. Select a Profile (SP 1 to SP 4).

Activate profile

You can set up a service provider profile automatically or manually.

Automatic configuration

1. Select the Activate Profile checkbox.

2. The Service Provider menu offers a list of approved VoIP service providers. If your service 

provider appears in the menu, click on the name. The name is then displayed in the Service 

Provider field.

If you are using an approved VoIP service provider, visit the “Support” section at 

http://www.fortivoice.com to access the service configuration guide for your VoIP service 

provider. Otherwise use the procedures in this section.
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3. Click the Update Configuration button. The essential settings for communication with the 

service provider’s registration server will be completed automatically. 

4. If you want to customize other aspects of your VoIP lines, you may do so in the System VoIP 

Options area. See “System VoIP options” on page 32.

Account-specific and number-specific settings are not automatically configured. These 

must be entered on the VoIP Numbers page.

Manual configuration

1. Select the Activate Profile checkbox.

2. Enter the Profile name. The default profile name is Service provider n (e.g. Service 

provider 1).

Additional settings

Public IP

If your service provider requires you to register using your private IP address, select the Disable 

public IP address substitution checkbox. Check with your service provider.

NAT

1. If your service provider requires keep alive messages, and if your router does not support 

uPNP, check the Enable NAT keep alives checkbox.

a. Select the method used to keep ports open. Choices are:

• Simple ping — A standard ping message that works with all SIP servers.

• Nortel ping — A ping message that works with Nortel SIP servers (e.g. Nortel 

MCS 5200).

b. If necessary, change the ping frequency. The default setting is 45 seconds. 
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Preferred ID

Preferred Identity is a supported service provider feature that allows your system to make calls 

with an anonymous caller ID. Please ensure your service provider offers this feature before 

enabling it, or you might be unable to make calls.

Codec

You can specify which codecs to use by clicking the Additional Settings button. See “Setting 

codec options” on page 31.

Registration method

Some providers require the system to register using the username or account information rather 

than the VoIP number(s) provided. If so, check the Register with authentication username box to 

have the system register with the username information provided in the VoIP numbers page. 

Check with your VoIP service provider if you’re uncertain which method of registration is 

required.

VoIP Provider

Enter the IP addresses or public domain names, as provided by the service provider, into the 

following boxes. If the service provider does not specify a value, leave the box blank.

• Proxy/Registrar server name

• Registrar server name

• Outbound proxy

• Realm/domain

The View All Registration button will allow you to confirm connection to your service provider 

once you have completed the configuration of your VoIP numbers.

If you want to customize other aspects of your VoIP lines, you may do so in the System VoIP 

Options area. See “System VoIP options” on page 32.
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Setting codec options 

A codec is a method of compressing and decompressing audio signals for communication 

across a network. The system supports the G.729 and G.711 (µ-law or A-law) codecs for VoIP 

calls. If your service provider or equipment requires specific codecs for VoIP or Fax over IP 

calls, you can restrict the system to use the required codec. The following codes are supported:

• G.729 — This codec provides good quality. It requires the least bandwidth and 

accommodates the highest number of concurrent calls.

• G.711µ — This codec provides high quality and supports Fax over IP. It requires the most 

bandwidth and accommodates the fewest number of concurrent calls. G.711µ is used in 

North America and Japan.

• G.711A — This codec provides high quality and supports Fax over IP. It requires the most 

bandwidth and accommodates the fewest number of concurrent calls. G.711A is used 

worldwide outside North America and Japan.

• Voice activity detection (VAD) — Enabling VAD reduces voice bandwidth when no speech is 

detected, and reduces transmission of background noise. We recommend disabling VAD to 

keep bandwidth available for speech.

You may select which codecs to use or clear the unsupported codecs as well as select a 

Preferred codec.

If you are using an approved VoIP service provider, visit the “Support” section at 

http://www.fortivoice.com to access the service configuration guide for your VoIP service 

provider. The service configuration guide lists supported codecs.
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Configuring VoIP numbers for a service provider VoIP network 

Your service provider will assign you VoIP numbers.

1. Select the VoIP Numbers page. 

2. Select a VoIP number slot.

3. Select the Activate VoIP Number checkbox.

4. Set the VoIP profile to the service provider (e.g. My Service Provider).

5. Enter the Country Code (if required), the City or Area Code and the Number.

6. Enter the User/account and the Password (if required) for this number.

7. Set up call handling for the VoIP number. For more information, click the Help icon ( ) in 

the Call Handling area. 

8. Repeat steps 2 to 7 for each additional VoIP number.

If you are using an approved VoIP service provider, visit the “Support” section at 

http://www.fortivoice.com to access the service configuration guide for your VoIP service 

provider. The service configuration guide lists supported codecs.
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Setting up line hunt groups 

A line hunt group is a set of lines that are available for making an outbound call. It can use 

selected telephone lines, all VoIP lines associated with a service provider VoIP network.

The configuration has nine different hunt groups. You can modify these default settings as 

required. If you are using multiple service provider VoIP networks, set up a hunt group for each 

service provider.

A local extension can be restricted to a set of hunt groups in order to control access to VoIP 

networks by using User Privileges. See “Routing and blocking” on page 36.

1. Select the Line Hunt Groups page. 

2. Select a hunt group.

3. If necessary, select Activate Hunt Group. All hunt groups are active by default.

4. Enter a Hunt Group name. The default name is Hunt Group.

5. Set Line type to SPn VoIP Service.

6. Select the overflow hunt group. Choices are no overflow and the other activated hunt 

groups. If you select an overflow hunt group, ensure it contains different lines than the 

original hunt group.

Ensure that hunt group 9 or 0 is assigned to the group of telephone lines or VoIP trunks used 

for calls to emergency services. Failure to properly configure hunt groups could prevent 

emergency calls.
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Advanced VoIP configuration

Setting up caller ID

The VoIP Caller ID area allows you to set up the source for caller ID for outbound VoIP calls. The 

same setting is used for all service provider profiles. Extension names are used by default.

1. Select the VoIP Configuration page.

2. Set the caller ID for outbound VoIP calls.

• To use the System name from the Administration page, select Use System Name in caller 

ID information for all outgoing VoIP calls.

• To use the First name and Last name from the Local Extension/Fax page set up for each 

extension, select Use Extension Names in caller ID information for all outgoing VoIP calls.

Reserving VoIP lines

By default, all VoIP lines are available for external IP extensions, and/or service provider calls on 

a first-come first-served basis. You can also reserve VoIP lines for a specific use. For example, 

you can set aside two lines for external IP extensions.

Reserving VoIP lines guarantees resources for a specific network. Sharing VoIP lines uses them 

most efficiently.

1. Select the VoIP Configuration page.

2. Click Reserve VoIP Lines. The VoIP Resource Reservation window appears.

3. Select the number of VoIP lines to set aside for each service. Choices range from 1 to the 

number of unreserved VoIP lines at this location. Shared means no VoIP lines are reserved 

for this service. Only unreserved lines will be available.

4. To transfer settings from your computer to the system, choose File > Save. A window 

appears indicating the configuration is being sent.
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Troubleshooting and Support
Troubleshooting

• Configuration

• Auto attendant

• Music on hold

• Call routing

• Answering and fax machines

• Local extensions

• Multiple units

• VoIP

Some problems might be due to physical connections such as loose cables.

Configuration

I am unable to configure the system using a touchtone phone

1. You cannot configure the system using a phone sharing the same line in parallel. You have 

to configure it using one of the extensions plugged into the back panel of the system.

2. You cannot configure the system using touchtone keypad commands while the 

Management software is open. If the software is closed and you hear the prompt “I’m sorry, 

the system is currently being configured”, reboot the system. 

3. If you are using a local extension, check if the extension has direct line access to your 

telephone lines. If direct line access is enabled, press Flash or Recall on an analog 

extension or ** on a IP extension to receive an internal dial tone. Press # to enter command 

mode. Enter the correct password, if you have password protection.

4. From an out-of-office phone, call into the system and wait for the auto attendant. Enter 

command mode by pressing # on an analog extension phone, or *55# on a proprietary IP 

phone (note: other brands may use *55 Send or *55 Dial). Enter the correct password, if you 

have password protection.

Auto attendant

The auto attendant does not play when calls come in

1. Check if the line light on an incoming call is flickering while the phone is ringing. If not, 

replace the phone cord.

2. Make sure you have an auto attendant message recorded.

3. Ensure the system is running the correct mode. Open the Management software. Select 

Scheduling. Check the Current mode in the Modes area.

4. Ensure the telephone line has the correct auto attendant setup. Select Telephone Lines. 

Ensure the right auto attendant is selected for the mode, telephone number, and telephone 

line. Try setting the auto attendant to answer Immediately.
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The auto attendant message is broken up or very faint

1. Open the Management software. Choose Troubleshooting > Telephone Lines > Audio. 

Adjust the Transmit levels volume setting.

2. The quality of the microphone in the telephone handset you used to record your auto 

attendant can affect the quality of your recording. Try recording the auto attendant from 

another extension/telephone.

The auto attendant answers calls before any of the extensions ring

If users wish to have their local extensions ring before the auto attendant picks up incoming 

calls, do the following:

1. Open the Management software. Select Telephone Lines. Select the telephone line, 

telephone number, and mode. Click Edit. Increase the number of rings. 

The auto attendant is transferring calls to the wrong extension

1. Check if the extension jacks of your devices (phones, faxes) are plugged into the 

corresponding jacks on the back panel (i.e. extension 111 is plugged into E1).

The auto attendant answers calls, but does not transfer them to the extensions

1. Make sure your extensions are plugged into the extension jacks on the back panel of the 

system (instead of your telephone wall jacks).

2. Open the Management software. Expand Auto Attendants. In the Actions During Auto 

Attendant Playback area, check if the actions and resources point to the correct extensions.

Calls are going to my phone company voicemail instead of being answered by the 
system

This may be a result of two different situations:

1. If the line is currently busy and you do not have the hunt/rollover service from the phone 

company, then the call will go into voicemail.

2. If calls are ringing, then going into voicemail, the system may be set to answer after a 

predetermined number of rings that is larger than the number of rings set for your phone 

company voicemail. 

To remedy this situation, decrease the number of rings before the auto attendant answers or 

increase the number of rings before your phone company voicemail answers.

To decrease the number of rings before an auto attendant answers:

1. Open the Management software, select Lines and Greetings > Telephone Lines. The 

Telephone Lines section appears. 

Under the Call Handling section, set the Routing option to less than the phone company's 

voicemail number of rings, or to immediately.

How do I access my voicemail remotely?

To access your voicemail remotely: 

1. Call into the system. The auto attendant answers.
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2. Press **, followed by your extension number. This will take you into the standard voicemail 

options and allow you to listen to your messages and change voicemail options. 

Music on hold

Callers hear the “One moment please” message and then total silence when the 
auto attendant transfers their call to an extension

1. There is a problem with the music source. Check all connections and the power.

Callers hear only silence when put on hold at an extension

1. Make sure you use the Flash or Recall or Link button on an analog extension, or the Hold 

button on an IP extension, to put callers on hold. If you use the Hold button on an analog 

extension, callers will be placed on hold at the extension itself and not through the system.

2. You have enabled the music on hold feature, but have not attached an audio device to the 

music jack.

3. You have enabled play the Play music from file feature but have not loaded a .wav music 

file.

Call routing

Callers are disconnected when transferring calls from one extension to another

1. If you are using the hook switch rather than the Flash or Recall button to put callers on hold, 

you may be holding the hook switch down too long and disconnect.

I can’t use my conference/3-way calling feature from the phone company

1. You need to make sure you have checked the box indicating you have 3-Way 

Calling/Conference service or the Transfer and Clear service on the appropriate lines in the 

Telephone Lines page.

I’m unable to place intercom calls from a local extension

1. If the local extension has been set up for direct line access to your telephone lines, you 

need to press Flash or Recall on an analog extension, or ** on an IP extension, before 

intercom calling. 

Answering and fax machines 

The answering machine and/or fax machine picks up calls before they can be 
answered by telephone extensions

1. Check the ring sequence for the telephone line, telephone number and mode. Ensure the 

extension for your fax machine and/or answering machine is not set to answer calls at the 

same time as your telephone extensions. If necessary, remove the extension for the fax 

machine and/or answering machine from the list of extensions to ring on an incoming call. 

If your inbound call is answered by a , they can transfer you to your voicemail box by 

transferring your call by pressing **, followed by your extension number.
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Incoming faxes are not automatically detected and routed to the fax machine

1. Ensure you selected the correct extension in the If a fax call is detected list in the Auto 

Attendants page.

2. Not all fax machines emit a CNG tone that the system can detect and route. Therefore, you 

may consider incorporating an additional method of fax routing. This could include the use 

of a dedicated fax line or a distinctive ring number.

3. Many fax machines/modems will time-out or disconnect after 25 seconds on average if they 

have not connected with another fax machine/modem. If you set up the Action Performed 

After Auto Attendant Playback area, the fax call may time-out before it reaches your fax 

extension. If you have a long auto attendant message, you may want to shorten it or use 

another fax routing option.

4. The level of the auto attendant is too loud and is overpowering the CNG tone, affecting the 

detection. Try lowering the volume level of the auto attendant.

Local extensions

I am unable to access lines with a local extension

1. Check your direct line access setting in the Additional Settings window of the Local 

Extensions/Fax page. If a local extension has not been given direct line access to your 

telephone lines, you must dial 9 (0 in some regions) or 81–88 to access a line.

2. Check if routing and blocking is enabled in the User Privilege page. This can re-direct or 

block calls.

One of the local extensions (telephones) does not ring

1. Some telephones require more voltage in order to ring. These phones are usually the older 

‘Bell’ phones with mechanical ringers. These phones should not be used as extensions.

2. Make sure the telephone cord you are using between the phone and the system is 

working properly. 

3. Ensure the ringer is turned on.

Extension(s) ring, but there is no caller

This can occur when a caller hangs up after the auto attendant has begun to play. In some 

areas, the telephone company’s disconnect/clear signal is weak. The auto attendant may not be 

able to pick up the disconnect signal as soon as a caller hangs up. The auto attendant will not 

receive a response after playing its message and the call will fall through to your settings in the 

Action Performed After Auto Attendant Playback area in the Auto Attendants page.

When I try to access voicemail, I hear a busy tone

1. Check your direct line access settings in the Additional Settings window of the Local 

Extensions/Fax page in the Management software. If a local extension has been given direct 

line access to your telephone lines, you must first press Flash or Recall on an analog 

extension, or ** on an IP extension, before dialing the mailbox. The same applies for dialing 

other extensions to initiate intercom calls.
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 Multiple units 

The configuration does not show the other unit(s)

1. Check the LAN connection on the system.

2. Check the front LEDs for error codes. Refer to the FVC Hardware Specification Guide for an 

explanation of the light sequences. 

After recording an auto attendant greeting, I can’t play it back

1. Try again in a few minutes. After recording an auto attendant on one of the units, it will copy 

it to other units on the LAN. During this process, you cannot listen to that particular auto 

attendant.

VoIP 

Callers complain the sound is distorted or choppy

1. Your broadband connection may not have enough upstream bandwidth to support many 

simultaneous VoIP calls. In the Codec Options area, you may need to disable the G.711 and 

G.726 codecs and only use G.729.

2. You may have too much data traffic on your Internet connection at the same time you are 

trying to make voice calls. We suggest you use a router that supports QoS (Quality of 

Service) for VoIP. 

When I call someone or they call me, voice is only heard in one direction

1. The cause of this problem is usually a result of a router being misconfigured with respect to 

port mappings. Ensure all required VoIP ports are mapped to your unit. Also, ensure you use 

a static private IP address when connected to your router as this can also affect port 

mappings from the firewall/router.

2. Use a router that supports uPnP.

For more VoIP information, see “VoIP Information” on page 176.

Support

If you are having problems with the configuration or operation of your system:

1. Contact your authorized reseller or point of purchase. 

2. In the Management software, go to Help > Online Support.
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Appendix A: Functions and Commands
Functions you can enter from local extensions

On an analog extension, press Flash or Recall. On an IP extension, press Hold.

Keys Function performed

Flash or Recall/Hold If you are connected to a caller, Flash or Recall/Hold puts 

the call on hold and you hear the internal dial tone.

Flash or Recall/Hold Pressing Flash or Recall/Hold again at the internal dial 

tone retrieves the most recent call on hold.

Flash or Recall/Hold at external dial 

tone

When you are connected to an outside line, pressing Flash 
or Recall/Hold switches you to the internal dial tone.

* and mailbox number Dials into a local, remote or general voice mailbox to 

leave a message.

** and mailbox number Accesses a local, remote or general voice mailbox. You 

can retrieve messages, change greetings, password, etc.

** # Accesses the mailbox associated with your extension.

Flash or Recall/Hold 4 Completes a transfer and returns to the internal dial tone.

On an analog extension, press Flash 4 or Recall 4. On an IP extension, press Hold 4 followed 

by Dial, Send or # to complete the transfer.

0 (9 in some regions) Dials the receptionist.

*0 External PA access to make an announcement through 

the attached external PA system.

* and the speed dial number Dials the system speed dial number.

* and voicemail broadcast group Dials the voicemail broadcast group to broadcast a 

message.

Flash or Recall/Hold 5 Disconnects the current caller and reconnects to the last 

caller on hold. A conference-call initiator can disengage 

the second conferenced party by pressing Flash 5 or 
Recall 5.

Flash or Recall/Hold *500–509 Press Flash or Recall/Hold to place a call on hold and 

then press *500–509 to place the call in one of ten park 

orbits.

Flash or Recall/Hold *510 Press Flash or Recall/Hold to place a call on hold and 

then press *510 to place the call in the next available park 

orbit, starting at 500.

**500–509 Retrieves a parked call. 
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Flash or Recall/Hold 6 Conference call for 3 parties. Press Flash or Recall to put 

the first caller on hold, dial another extension or external 

number and press Flash 6 or Recall 6.

**050 Plays the music on hold

*60

*61

*62

Disables Do Not Disturb at the current extension. 

Enables Do Not Disturb at the current extension. 

Toggles Do Not Disturb at the current extension.

*7 and extension Call pick-up at a specific extension. Dial from dial tone to 

pick up a call ringing at another extension.

Flash or Recall/Hold 7 Press Flash 7 or Recall 7 to cycle through queued calls 

on a first in/first out basis.

80 Accesses Same Line Connect when transferring an 

outside caller to another outside number.

9 (0 in some regions), 81–88 Dial to access an outside line.

91# The phone system unit will announce its IP address.

On an IP extension, press Dial, Send or # after your entry for the following options:

*80 Play music on hold from an internal .wav file or an external 

audio source through the PA jack. If music on hold is 

playing through the PA jack, and a user dials *0 to make an 

overhead page, the overhead page will interrupt the music 

on hold. However, if the PA jack is configured to perform 

voicemail screening, and a user or caller accesses a voice 

mailbox, music on hold will not be interrupted.

*810# Add the last caller’s ID information to the Caller ID routing 

table.

*81 [1–10] # Route future calls from the last caller according to the 

specified Caller ID-based routing group.

*81255# Delete the last caller from the caller ID lookup list.

*84 and extension Hands-free intercom call to an extension, automatically 

answered in speaker mode, enabling instant hands-free 

2-way communication (for supported sets). 

*85 and extension or ring group 

number

Page a phone at an extension or the phones of a ring 

group.

*88 and account code Attach account code to call detail record (CDR) for last 

call.

*9 Call pick-up of any ringing line.

# on an analog phone, or *55# on 

IP phones (others may use *55 

Send or *55 Dial).

Enters command mode.

Keys Function performed
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Functions you can enter from outside phones

Enter these keys after the auto attendant answers. 

Keys Function performed

0 (9 in some regions),

1, 2, 3, 4 and 5

Performs the action defined in the auto attendant 

configuration.

Local extension Rings at the local extension (e.g. 111). 

Remote extension Rings at the remote extension (e.g. 211). 

Ring group Rings all the extensions in the ring group (e.g. 301). There 

are 10 ring groups for the entire system.

61 Causes the system to call you back at the current 

prompted call back number, after you hang up.

62 Causes the system to prompt you for your password and 

then the new prompted call back number. After you hang 

up, the system calls you back.

7 and extension Transfers a caller on hold to another phone system used 

in conjunction with the system. As soon as the call 

connects to the other system, it disconnects from the 

system.

9 (0 in some regions) and 81–88 Accesses a hunt group for call bridge and is protected 

with the call bridge password.

80 Accesses call bridge using Same Line Connect. Requires 

3–way calling/conference on the line.

* and mailbox number Dials into a local, remote or general voice mailbox to 

leave a message. 

** and mailbox number Accesses voicemail of a local, remote or general voice 

mailbox. You can retrieve messages, change greetings, 

password, etc.
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Functions you can enter in command mode

Enter command mode by either pressing # on an analog extension phone, or *55# on some IP 

phones (others may use *55 Send or *55 Dial). When prompted, enter the system password + #. 

You can then enter the command.

Keys Function performed

00 + # The system tells you the Unit ID of the unit you are 

connected to.

0 and ID number + # Assigns a Unit ID (1 to 4).

30 + # The system tells you which mode it is currently using.

3 and mode number + # Switch modes (1 = mode 1, 2 = mode 2, 3 = holiday mode).

4 and auto attendant number + # Record auto attendant message.

04 and auto attendant number + # Erase auto attendant message.

5 and auto attendant number + # Play auto attendant message.

6 and auto call back number + # Record auto call back announced message (1 to 4).

06 and auto call back number + # Erase auto call back announced message (1 to 4).

7 and auto call back number + # Play auto call back announced message (1 to 4).

65 + # Record prompted call back announced message.

065 + # Erase prompted call back announced message.

75 + # Play prompted call back announced message.

91 + # Play IP address of unit 1.

92 + # Play IP address of unit 2.

93 + # Play IP address of unit 3.

94 + # Play IP address of unit 4.

80 + Remote extension number + * 
+ desired external phone number

Set a remote extension phone number.

61 +  number + # Enable Do Not Disturb at the local extension.

60 +  number + # Disable Do Not Disturb at the local extension.
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Appendix B: Power Interruptions
Settings and configurations

In the event of a power failure, your settings and configuration will not be lost.

The configuration is stored in non-volatile memory. Non-volatile memory means your feature 

settings (configuration) remain in the memory despite interruptions in the power supply. 

Calling features

In the event of a power failure, each unit will connect extension E4 to phone Line 1 to permit 

calls (except-AU models).

Calls must be dialed without a hunt group. All other functions will not be available until power is 

restored. We recommend that a telephone that does not depend on mains power be available 

for emergency use. 

Mode scheduling and power interruptions 

When the power supply to the system has been interrupted, the system’s internal clock will 

continue to run for up to 12 hours. If you have enabled the automatic mode scheduling feature 

and it has been longer than 12 hours, the system will not function properly until the internal 

clock is reset via a caller ID call or with the Management software. When power is restored, it 

will check the time and determine the mode it should be running according to the configuration 

and set itself to that mode.

To check the current mode of operation:

1. Enter command mode by either pressing # on an analog extension phone, or *55# on IP 

phones (others may use *55 Send or *55 Dial).

2. Dial the system password + #.

3. Dial 30#. The system will report the current mode.
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